summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2005-02-12 01:02:55 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2005-02-12 01:02:55 +0000
commitaca9af0af61835d9dd4eb9ba134ffd1a8474e9ea (patch)
treec29bf5debad84c42967332f6388ca43ffaf4daea /games-emulation
parentneed to call games_pkg_postinst (diff)
downloadgentoo-2-aca9af0af61835d9dd4eb9ba134ffd1a8474e9ea.tar.gz
gentoo-2-aca9af0af61835d9dd4eb9ba134ffd1a8474e9ea.tar.bz2
gentoo-2-aca9af0af61835d9dd4eb9ba134ffd1a8474e9ea.zip
need to call games_pkg_postinst
(Portage version: 2.0.51-r15)
Diffstat (limited to 'games-emulation')
-rw-r--r--games-emulation/mupen64/mupen64-0.4-r1.ebuild12
1 files changed, 6 insertions, 6 deletions
diff --git a/games-emulation/mupen64/mupen64-0.4-r1.ebuild b/games-emulation/mupen64/mupen64-0.4-r1.ebuild
index 8486b31d1ebb..912774c195c2 100644
--- a/games-emulation/mupen64/mupen64-0.4-r1.ebuild
+++ b/games-emulation/mupen64/mupen64-0.4-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-emulation/mupen64/mupen64-0.4-r1.ebuild,v 1.2 2005/01/20 04:31:50 morfic Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-emulation/mupen64/mupen64-0.4-r1.ebuild,v 1.3 2005/02/12 00:58:40 mr_bones_ Exp $
inherit games gcc eutils libtool
@@ -86,20 +86,20 @@ src_install() {
cp -r mupen64* lang plugins save roms path.cfg ${D}/${dir}/
rm ${D}/${dir}/mupen64_test.ini
- dogamesbin ${FILESDIR}/mupen64
+ dogamesbin ${FILESDIR}/mupen64 || die "dogamesbin failed"
dosed "s:GENTOO_DIR:${dir}:" ${GAMES_BINDIR}/mupen64
- newgamesbin ${FILESDIR}/mupen64 mupen64_nogui
+ newgamesbin ${FILESDIR}/mupen64 mupen64_nogui || die "newgamesbin failed"
dosed "s:GENTOO_DIR:${dir}:" ${GAMES_BINDIR}/mupen64_nogui
# plugins docs are in subdirs of the doc main directory
- cd ${S}/emu64
- dodoc *.txt
- dodoc doc/readme.pdf
+ cd "${S}/emu64"
+ dodoc *.txt doc/readme.pdf
prepgamesdirs
}
pkg_postinst() {
+ games_pkg_postinst
ewarn "If you are upgreading from previous version of mupen64"
ewarn "you have to do rm -rf on your .mupen64 directory."
ewarn "Copy your saved games and after launching new mupen"