summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2004-06-28 23:10:10 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2004-06-28 23:10:10 +0000
commitc096afc025586e15f53d840bfae6b08e83235b5d (patch)
tree0d10c1411278ef0b42422eb6f1bbe65009af7b2a /games-emulation
parentsync IUSE (-debug) (Manifest recommit) (diff)
downloadgentoo-2-c096afc025586e15f53d840bfae6b08e83235b5d.tar.gz
gentoo-2-c096afc025586e15f53d840bfae6b08e83235b5d.tar.bz2
gentoo-2-c096afc025586e15f53d840bfae6b08e83235b5d.zip
fix use flag invocation; tidy
Diffstat (limited to 'games-emulation')
-rw-r--r--games-emulation/stella/ChangeLog5
-rw-r--r--games-emulation/stella/stella-1.3-r1.ebuild29
2 files changed, 20 insertions, 14 deletions
diff --git a/games-emulation/stella/ChangeLog b/games-emulation/stella/ChangeLog
index f758ff80084d..80cb5310eceb 100644
--- a/games-emulation/stella/ChangeLog
+++ b/games-emulation/stella/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for games-emulation/stella
# Copyright 2000-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-emulation/stella/ChangeLog,v 1.9 2004/06/24 22:36:30 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-emulation/stella/ChangeLog,v 1.10 2004/06/28 23:10:10 mr_bones_ Exp $
+
+ 28 Jun 2004; Michael Sterrett <mr_bones_@gentoo.org> stella-1.3-r1.ebuild:
+ fix use flag invocation; tidy
26 May 2004; Michael Sterrett <mr_bones_@gentoo.org> stella-1.3-r1.ebuild:
USE fixups
diff --git a/games-emulation/stella/stella-1.3-r1.ebuild b/games-emulation/stella/stella-1.3-r1.ebuild
index a885e8f6feae..21a94a9eeb23 100644
--- a/games-emulation/stella/stella-1.3-r1.ebuild
+++ b/games-emulation/stella/stella-1.3-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-emulation/stella/stella-1.3-r1.ebuild,v 1.6 2004/06/24 22:36:30 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-emulation/stella/stella-1.3-r1.ebuild,v 1.7 2004/06/28 23:10:10 mr_bones_ Exp $
inherit eutils
@@ -22,10 +22,9 @@ DEPEND="|| (
media-libs/libpng"
src_unpack() {
- unpack ${A} || die
- cd ${S}
- epatch ${FILESDIR}/${P}-alsa-fix.patch || die \
- "Alsalib 1.0 fix failed"
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}/${P}-alsa-fix.patch"
}
src_compile() {
@@ -35,24 +34,28 @@ src_compile() {
if use alsa ; then
MYOPTS="${MYOPTS} SOUND_ALSA=1"
fi
- if use X || [ -z "`use X``use sdl`" ] ; then
+ if use X || ! use sdl ; then
cd ${S}/src/build
- emake OPTIMIZATIONS="${CFLAGS}" $MYOPTS linux-x || die
+ emake OPTIMIZATIONS="${CFLAGS}" $MYOPTS linux-x \
+ || die "emake failed"
fi
if use sdl ; then
cd ${S}/src/build
- emake OPTIMIZATIONS="${CFLAGS}" $MYOPTS SOUND_SDL=1 linux-sdl || die
+ emake OPTIMIZATIONS="${CFLAGS}" $MYOPTS SOUND_SDL=1 linux-sdl \
+ || die "emake failed"
fi
}
src_install() {
- use X && dobin src/build/stella.x11
- use sdl && dobin src/build/stella.sdl
- [ -z "`use X``use sdl`" ] && dobin src/build/stella.x11
+ if use X || ! use sdl ; then
+ dobin src/build/stella.x11 || die "dobin failed"
+ fi
+ if use sdl ; then
+ dobin src/build/stella.sdl || die "dobin failed"
+ fi
insinto /etc
- doins src/stellarc
- doins src/emucore/stella.pro
+ doins src/stellarc src/emucore/stella.pro
dohtml -r docs/
dodoc *.txt