summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2015-02-09 21:39:51 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2015-02-09 21:39:51 +0000
commitdb8faf363ea279915d3b77a7cccaefd7f940eeb6 (patch)
treec00136ddbbc75e5b4effb2e98957894efc1ffc3b /games-emulation
parentRemove optional dependency on pinentry-qt in preparation of lastriting of thi... (diff)
downloadgentoo-2-db8faf363ea279915d3b77a7cccaefd7f940eeb6.tar.gz
gentoo-2-db8faf363ea279915d3b77a7cccaefd7f940eeb6.tar.bz2
gentoo-2-db8faf363ea279915d3b77a7cccaefd7f940eeb6.zip
version bump
(Portage version: 2.2.14/cvs/Linux x86_64, unsigned Manifest commit)
Diffstat (limited to 'games-emulation')
-rw-r--r--games-emulation/yabause/ChangeLog12
-rw-r--r--games-emulation/yabause/files/yabause-0.9.14-RWX.patch24
-rw-r--r--games-emulation/yabause/files/yabause-0.9.14-cmake.patch51
-rw-r--r--games-emulation/yabause/yabause-0.9.14.ebuild69
4 files changed, 154 insertions, 2 deletions
diff --git a/games-emulation/yabause/ChangeLog b/games-emulation/yabause/ChangeLog
index f84380577d3d..30e0c72283a6 100644
--- a/games-emulation/yabause/ChangeLog
+++ b/games-emulation/yabause/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for games-emulation/yabause
-# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-emulation/yabause/ChangeLog,v 1.37 2013/03/02 21:15:10 hwoarang Exp $
+# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/games-emulation/yabause/ChangeLog,v 1.38 2015/02/09 21:39:51 mr_bones_ Exp $
+
+*yabause-0.9.14 (09 Feb 2015)
+
+ 09 Feb 2015; Michael Sterrett <mr_bones_@gentoo.org>
+ +files/yabause-0.9.14-RWX.patch, +files/yabause-0.9.14-cmake.patch,
+ +yabause-0.9.14.ebuild, files/yabause-0.9.12-RWX.patch,
+ files/yabause-0.9.12-cmake.patch:
+ version bump
02 Mar 2013; Markos Chandras <hwoarang@gentoo.org> yabause-0.9.12.ebuild:
Move Qt dependencies to the new category
diff --git a/games-emulation/yabause/files/yabause-0.9.14-RWX.patch b/games-emulation/yabause/files/yabause-0.9.14-RWX.patch
new file mode 100644
index 000000000000..8022be90f852
--- /dev/null
+++ b/games-emulation/yabause/files/yabause-0.9.14-RWX.patch
@@ -0,0 +1,24 @@
+--- yabause-0.9.13.orig/src/sh2_dynarec/linkage_x64.s
++++ yabause-0.9.13/src/sh2_dynarec/linkage_x64.s
+@@ -747,3 +747,11 @@
+ ret
+ /* Set breakpoint here for debugging */
+ .size breakpoint, .-breakpoint
++
++#if defined(__linux__) && defined(__ELF__)
++.section .note.GNU-stack,"",%progbits
++#endif
++
++#if defined(__linux__) && defined(__ELF__)
++.section .note.GNU-stack,"",%progbits
++#endif
+--- yabause-0.9.13.orig/src/sh2_dynarec/linkage_x86.s
++++ yabause-0.9.13/src/sh2_dynarec/linkage_x86.s
+@@ -743,3 +743,7 @@
+ ret
+ /* Set breakpoint here for debugging */
+ .size breakpoint, .-breakpoint
++
++#if defined(__linux__) && defined(__ELF__)
++.section .note.GNU-stack,"",%progbits
++#endif
diff --git a/games-emulation/yabause/files/yabause-0.9.14-cmake.patch b/games-emulation/yabause/files/yabause-0.9.14-cmake.patch
new file mode 100644
index 000000000000..a126c010bb7a
--- /dev/null
+++ b/games-emulation/yabause/files/yabause-0.9.14-cmake.patch
@@ -0,0 +1,51 @@
+--- yabause-0.9.13.orig/l10n/CMakeLists.txt
++++ yabause-0.9.13/l10n/CMakeLists.txt
+@@ -2,9 +2,12 @@
+
+ set(LANGS de es fr it lt nl pt pt_BR sv)
+
++# paths
++set(TRANSDIR "share/yabause/yts" CACHE STRING "dir to translation files")
++
+ if (UNIX AND NOT APPLE)
+ foreach(LANG ${LANGS})
+- install(FILES "yabause_${LANG}.yts" DESTINATION "share/yabause/yts" RENAME "${LANG}.yts")
++ install(FILES "yabause_${LANG}.yts" DESTINATION ${TRANSDIR} RENAME "${LANG}.yts")
+ endforeach()
+ elseif (WIN32)
+ foreach(LANG ${LANGS})
+--- yabause-0.9.13.orig/src/gtk/CMakeLists.txt
++++ yabause-0.9.13/src/gtk/CMakeLists.txt
+@@ -59,7 +59,10 @@
+ yab_port_success(yabause-gtk)
+ configure_file(yabause.desktop.in ${YAB_PORT_NAME}.desktop)
+
+-install(TARGETS yabause-gtk DESTINATION "bin")
++# paths
++set(BINDIR "bin" CACHE STRING "dir to binary")
++
++install(TARGETS yabause-gtk DESTINATION ${BINDIR})
+ install(FILES ${CMAKE_CURRENT_BINARY_DIR}/${YAB_PORT_NAME}.desktop DESTINATION "share/applications")
+ install(FILES "doc/yabause.1" DESTINATION "${YAB_MAN_DIR}/man1" RENAME "${YAB_PORT_NAME}.1")
+ install(FILES "yabause.png" DESTINATION "share/pixmaps")
+--- yabause-0.9.13.orig/src/qt/CMakeLists.txt
++++ yabause-0.9.13/src/qt/CMakeLists.txt
+@@ -237,6 +237,9 @@
+ yab_port_success(yabause-qt)
+ configure_file(yabause.desktop.in ${YAB_PORT_NAME}.desktop)
+
++# paths
++set(BINDIR "bin" CACHE STRING "dir to binary")
++
+ if (WIN32)
+ install(TARGETS yabause-qt DESTINATION ".")
+ if (GLUT_FOUND)
+@@ -277,7 +280,7 @@
+ endif()
+ endif ()
+ else ()
+- install(TARGETS yabause-qt DESTINATION "bin")
++ install(TARGETS yabause-qt DESTINATION ${BINDIR})
+ install(FILES ${CMAKE_CURRENT_BINARY_DIR}/${YAB_PORT_NAME}.desktop DESTINATION "share/applications")
+ install(FILES "doc/yabause.1" DESTINATION "${YAB_MAN_DIR}/man1" RENAME "${YAB_PORT_NAME}.1")
+ install(FILES "resources/icons/yabause.png" DESTINATION "share/pixmaps")
diff --git a/games-emulation/yabause/yabause-0.9.14.ebuild b/games-emulation/yabause/yabause-0.9.14.ebuild
new file mode 100644
index 000000000000..b0df0bceb4bd
--- /dev/null
+++ b/games-emulation/yabause/yabause-0.9.14.ebuild
@@ -0,0 +1,69 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-emulation/yabause/yabause-0.9.14.ebuild,v 1.1 2015/02/09 21:39:51 mr_bones_ Exp $
+
+EAPI=5
+inherit eutils cmake-utils games
+
+DESCRIPTION="A Sega Saturn emulator"
+HOMEPAGE="http://yabause.org/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="openal opengl qt5 sdl"
+
+# x11-libs/libXrandr is an automagic dep
+# qt5 over qt4 and libsdl2 over libsdl is
+# also done automatically. Send patches
+# upstream to make the choices explicit.
+RDEPEND="
+ x11-libs/libXrandr
+ openal? ( media-libs/openal )
+ opengl? (
+ media-libs/freeglut
+ virtual/glu
+ virtual/opengl
+ )
+ qt5? (
+ dev-qt/qtcore:5
+ dev-qt/qtwidgets:5[opengl?]
+ opengl? ( dev-qt/qtopengl:5 )
+ )
+ !qt5? (
+ dev-libs/glib:2
+ x11-libs/gtk+:2
+ x11-libs/gtkglext
+ )
+ sdl? ( media-libs/libsdl2[opengl?,video] )"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-RWX.patch \
+ "${FILESDIR}"/${P}-cmake.patch
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -DBINDIR="${GAMES_BINDIR}"
+ -DTRANSDIR="${GAMES_DATADIR}"/${PN}/yts
+ -DYAB_OPTIMIZATION=""
+ $(cmake-utils_use sdl YAB_WANT_SDL)
+ $(cmake-utils_use openal YAB_WANT_OPENAL)
+ $(cmake-utils_use opengl YAB_WANT_OPENGL)
+ -DYAB_PORTS=$(usex qt5 "qt" "gtk")
+ )
+ cmake-utils_src_configure
+}
+
+src_compile() {
+ cmake-utils_src_compile
+}
+
+src_install() {
+ cmake-utils_src_install
+ dodoc AUTHORS ChangeLog GOALS README README.LIN
+ prepgamesdirs
+}