summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Goller <morfic@gentoo.org>2005-01-07 21:11:14 +0000
committerDaniel Goller <morfic@gentoo.org>2005-01-07 21:11:14 +0000
commitde87ec295279f325110711df7c7ccd372938e3b4 (patch)
treece754f9dbcc9a531cea047510d8195a55242dd5b /games-emulation
parentClose #74924 again. (Manifest recommit) (diff)
downloadgentoo-2-de87ec295279f325110711df7c7ccd372938e3b4.tar.gz
gentoo-2-de87ec295279f325110711df7c7ccd372938e3b4.tar.bz2
gentoo-2-de87ec295279f325110711df7c7ccd372938e3b4.zip
fixed config dialog not working with gtk2
Diffstat (limited to 'games-emulation')
-rw-r--r--games-emulation/mupen64-glN64/ChangeLog6
-rw-r--r--games-emulation/mupen64-glN64/files/mupen64-glN64-gtk2.patch16
-rw-r--r--games-emulation/mupen64-glN64/mupen64-glN64-0.4.1_rc2.ebuild6
3 files changed, 24 insertions, 4 deletions
diff --git a/games-emulation/mupen64-glN64/ChangeLog b/games-emulation/mupen64-glN64/ChangeLog
index 7c29263f7315..d344d81ed965 100644
--- a/games-emulation/mupen64-glN64/ChangeLog
+++ b/games-emulation/mupen64-glN64/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for games-emulation/mupen64-glN64
# Copyright 2000-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-emulation/mupen64-glN64/ChangeLog,v 1.3 2005/01/07 10:44:50 swegener Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-emulation/mupen64-glN64/ChangeLog,v 1.4 2005/01/07 21:11:13 morfic Exp $
+
+ 07 Jan 2005; Daniel Goller <morfic@gentoo.org>
+ +files/mupen64-glN64-gtk2.patch, mupen64-glN64-0.4.1_rc2.ebuild:
+ Fixed config dialog problem with gtk2
*mupen64-glN64-0.4.1_rc2 (05 Jan 2005)
diff --git a/games-emulation/mupen64-glN64/files/mupen64-glN64-gtk2.patch b/games-emulation/mupen64-glN64/files/mupen64-glN64-gtk2.patch
new file mode 100644
index 000000000000..935da498aa33
--- /dev/null
+++ b/games-emulation/mupen64-glN64/files/mupen64-glN64-gtk2.patch
@@ -0,0 +1,16 @@
+--- glN64-0.4.1-rc2/Makefile.old 2005-01-07 12:21:52.532224798 -0800
++++ glN64-0.4.1-rc2/Makefile 2005-01-07 12:26:18.302433792 -0800
+@@ -1,11 +1,11 @@
+ DEFINES = -D__LINUX__ -DX86_ASM
+ CXX = g++
+-CXXFLAGS = -I. $(DEFINES) `sdl-config --cflags` `gtk-config --cflags gtk gthread` `glib-config --cflags`
++CXXFLAGS = -I. $(DEFINES) `sdl-config --cflags` `pkg-config --cflags gtk+-2.0 glib-2.0` -D_GTK2
+ #CXXFLAGS = -I. $(DEFINES) `sdl-config --cflags` `gtk-config --cflags gtk gthread` \
+ # `glib-config --cflags` -g3 #-DDEBUG
+ LD = g++
+ LDFLAGS = -shared -Wl,-Bsymbolic
+-LIBS = `sdl-config --libs` `gtk-config --libs gtk gthread` `glib-config --libs` -lGL -lGLU
++LIBS = `sdl-config --libs` `pkg-config --libs gtk+-2.0 glib-2.0 gthread-2.0` -lGL -lGLU
+ TARGET = glN64-0.4.1.so
+ OBJECTS = 2xSAI.o \
+ CRC.o \
diff --git a/games-emulation/mupen64-glN64/mupen64-glN64-0.4.1_rc2.ebuild b/games-emulation/mupen64-glN64/mupen64-glN64-0.4.1_rc2.ebuild
index 88a7f037cceb..2c10451c2fcf 100644
--- a/games-emulation/mupen64-glN64/mupen64-glN64-0.4.1_rc2.ebuild
+++ b/games-emulation/mupen64-glN64/mupen64-glN64-0.4.1_rc2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-emulation/mupen64-glN64/mupen64-glN64-0.4.1_rc2.ebuild,v 1.1 2005/01/06 04:29:40 morfic Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-emulation/mupen64-glN64/mupen64-glN64-0.4.1_rc2.ebuild,v 1.2 2005/01/07 21:11:13 morfic Exp $
inherit games
@@ -19,10 +19,10 @@ RDEPEND="media-libs/libsdl"
src_compile () {
epatch ${FILESDIR}/${PN}-compile.patch || die "patch failed"
-
+ epatch ${FILESDIR}/${PN}-gtk2.patch
if use x86; then
if use asm; then
- einfo "using x86 asm where aviable"
+ einfo "using x86 asm where available"
else
epatch ${FILESDIR}/${PN}-noasm.patch
fi