summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTristan Heaven <nyhm@gentoo.org>2008-05-08 19:25:54 +0000
committerTristan Heaven <nyhm@gentoo.org>2008-05-08 19:25:54 +0000
commitebb46eeb79ca920c6b1f03b86f390befd6a9ee0e (patch)
treef705e8db4ffcaf9adeae0cec690ad31d40552e3d /games-emulation
parentNo longer needs control-center, just gnome-settings-daemon; bug #220865 (diff)
downloadgentoo-2-ebb46eeb79ca920c6b1f03b86f390befd6a9ee0e.tar.gz
gentoo-2-ebb46eeb79ca920c6b1f03b86f390befd6a9ee0e.tar.bz2
gentoo-2-ebb46eeb79ca920c6b1f03b86f390befd6a9ee0e.zip
Version bump, bug #214712
(Portage version: 2.1.5_rc7)
Diffstat (limited to 'games-emulation')
-rw-r--r--games-emulation/yabause/ChangeLog8
-rw-r--r--games-emulation/yabause/files/yabause-0.9.4-build.patch14
-rw-r--r--games-emulation/yabause/yabause-0.9.4.ebuild50
3 files changed, 71 insertions, 1 deletions
diff --git a/games-emulation/yabause/ChangeLog b/games-emulation/yabause/ChangeLog
index 553245efc028..ed4bdb5253bc 100644
--- a/games-emulation/yabause/ChangeLog
+++ b/games-emulation/yabause/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for games-emulation/yabause
# Copyright 2000-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-emulation/yabause/ChangeLog,v 1.23 2008/01/20 22:26:28 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-emulation/yabause/ChangeLog,v 1.24 2008/05/08 19:25:54 nyhm Exp $
+
+*yabause-0.9.4 (08 May 2008)
+
+ 08 May 2008; Tristan Heaven <nyhm@gentoo.org>
+ +files/yabause-0.9.4-build.patch, +yabause-0.9.4.ebuild:
+ Version bump, bug #214712
*yabause-0.9.3 (20 Jan 2008)
diff --git a/games-emulation/yabause/files/yabause-0.9.4-build.patch b/games-emulation/yabause/files/yabause-0.9.4-build.patch
new file mode 100644
index 000000000000..400056f8f1f4
--- /dev/null
+++ b/games-emulation/yabause/files/yabause-0.9.4-build.patch
@@ -0,0 +1,14 @@
+--- configure.in 2008/03/12 22:09:23 1.85
++++ configure.in 2008/03/25 20:45:28 1.86
+@@ -3,6 +3,11 @@
+ AC_CANONICAL_HOST
+ AC_CANONICAL_TARGET
+
++# hack to reset host_alias when we're not cross compiling
++if test "x$host_alias" = "x$host"; then
++ host_alias=
++fi
++
+ AM_INIT_AUTOMAKE([1.8.0])
+
+ AC_PROG_RANLIB
diff --git a/games-emulation/yabause/yabause-0.9.4.ebuild b/games-emulation/yabause/yabause-0.9.4.ebuild
new file mode 100644
index 000000000000..98ccd3af1dab
--- /dev/null
+++ b/games-emulation/yabause/yabause-0.9.4.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-emulation/yabause/yabause-0.9.4.ebuild,v 1.1 2008/05/08 19:25:54 nyhm Exp $
+
+inherit autotools eutils games
+
+DESCRIPTION="A Sega Saturn emulator"
+HOMEPAGE="http://yabause.org/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+
+RDEPEND="=x11-libs/gtk+-2*
+ x11-libs/gtkglext
+ virtual/opengl
+ virtual/glu
+ virtual/glut
+ media-libs/libsdl"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/${P}-build.patch
+ eautoreconf
+ cd src/c68k
+ sed -i \
+ -e 's/nodist_pkgdata/noinst/' \
+ Makefile.am \
+ || die "sed failed"
+ eautoreconf
+}
+
+src_compile() {
+ egamesconf \
+ --datadir=/usr/share \
+ --with-port=gtk \
+ || die
+ emake || die "emake failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+ dodoc AUTHORS ChangeLog GOALS README README.LIN TODO
+ prepgamesdirs
+}