summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChris Gianelloni <wolf31o2@gentoo.org>2007-03-07 16:34:56 +0000
committerChris Gianelloni <wolf31o2@gentoo.org>2007-03-07 16:34:56 +0000
commitf202fb4f9fd3c5d6cb7de97c954eeec7e94fdcfd (patch)
tree12138417b05c5bed7831d1fcff304daf86d8ed01 /games-emulation
parentstable x86; bug 169784 (diff)
downloadgentoo-2-f202fb4f9fd3c5d6cb7de97c954eeec7e94fdcfd.tar.gz
gentoo-2-f202fb4f9fd3c5d6cb7de97c954eeec7e94fdcfd.tar.bz2
gentoo-2-f202fb4f9fd3c5d6cb7de97c954eeec7e94fdcfd.zip
Change all instances of [ to [[.
(Portage version: 2.1.2.1)
Diffstat (limited to 'games-emulation')
-rw-r--r--games-emulation/epsxe/ChangeLog5
-rw-r--r--games-emulation/epsxe/files/epsxe24
2 files changed, 16 insertions, 13 deletions
diff --git a/games-emulation/epsxe/ChangeLog b/games-emulation/epsxe/ChangeLog
index 618ff2682ac4..79e8262923ce 100644
--- a/games-emulation/epsxe/ChangeLog
+++ b/games-emulation/epsxe/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for games-emulation/epsxe
# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-emulation/epsxe/ChangeLog,v 1.11 2007/02/24 00:16:13 nyhm Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-emulation/epsxe/ChangeLog,v 1.12 2007/03/07 16:34:56 wolf31o2 Exp $
+
+ 07 Mar 2007; Chris Gianelloni <wolf31o2@gentoo.org> files/epsxe:
+ Change all instances of [ to [[.
24 Feb 2007; Tristan Heaven <nyhm@gentoo.org> epsxe-1.6.0-r3.ebuild:
Fix dependencies, bug #168179
diff --git a/games-emulation/epsxe/files/epsxe b/games-emulation/epsxe/files/epsxe
index ce3b446197c0..f50f33acfd38 100644
--- a/games-emulation/epsxe/files/epsxe
+++ b/games-emulation/epsxe/files/epsxe
@@ -11,47 +11,47 @@ mkdir -p memcards bios cfg cheats snap sstates patches plugins
shopt -s nullglob
for f in `find "${EPSXEDIR}" -maxdepth 1 -type f -printf '%f '` ; do
- [ -e "${f}" ] && continue
+ [[ -e "${f}" ]] && continue
ln -s "${EPSXEDIR}/${f}" "${f}" >& /dev/null
done
-if [ -d "${PSEMUDIR}" ] ; then
- if [ -d "${PSEMUDIR}/plugins" ]; then
+if [[ -d "${PSEMUDIR}" ]] ; then
+ if [[ -d "${PSEMUDIR}/plugins" ]] ; then
for plugin in `find "${PSEMUDIR}/plugins" -maxdepth 1 -type f -printf '%f '` ; do
- if [ ! -e "plugins/${plugin}" ]; then
+ if [[ ! -e "plugins/${plugin}" ]] ; then
echo "Loading new plugin: ${plugin}"
ln -s "${PSEMUDIR}/plugins/${plugin}" "plugins/${plugin}"
fi
done
fi
- if [ -d "${PSEMUDIR}/cfg" ]; then
+ if [[ -d "${PSEMUDIR}/cfg" ]] ; then
for configlib in `find "${PSEMUDIR}/cfg" -maxdepth 1 -iname '*.cfg' -prune -o -type f -printf '%f '`; do
- if [ ! -e "cfg/${configlib}" ]; then
+ if [[ ! -e "cfg/${configlib}" ]] ; then
echo "Loading config utility: ${configlib}"
ln -s "${PSEMUDIR}/cfg/${configlib}" "cfg/${configlib}"
fi
done
for config in `find "${PSEMUDIR}/cfg" -maxdepth 1 -iname '*.cfg' -type f -printf '%f '`; do
- if [ ! -e "cfg/${config}" ]; then
+ if [[ ! -e "cfg/${config}" ]] ; then
echo "Loading default config: ${config}"
cp "${PSEMUDIR}/cfg/${config}" "cfg/${config}"
fi
done
fi
- if [ -d "${PSEMUDIR}/cheats" ]; then
+ if [[ -d "${PSEMUDIR}/cheats" ]] ; then
for cheat in `find "${PSEMUDIR}/cheats" -maxdepth 1 -type f -printf '%f '`; do
- if [ ! -e "cheats/${cheat}" ]; then
+ if [[ ! -e "cheats/${cheat}" ]] ; then
ln -s "${PSEMUDIR}/cheats/${cheat}" "cheats/${cheat}"
fi
done
fi
- if [ -d "${PSEMUDIR}/bios" ]; then
+ if [[ -d "${PSEMUDIR}/bios" ]] ; then
for bios in `find "${PSEMUDIR}/bios" -maxdepth 1 -type f -printf '%f '`; do
- if [ ! -e "bios/${bios}" ] ; then
+ if [[ ! -e "bios/${bios}" ]] ; then
ln -s "${PSEMUDIR}/bios/${bios}" "bios/${bios}"
fi
done
@@ -59,7 +59,7 @@ if [ -d "${PSEMUDIR}" ] ; then
fi
# check for bios
-if [ -z "`cd bios && ls`" ] ; then
+if [[ -z "`cd bios && ls`" ]] ; then
# if the bios directory is empty, then ... well ...
echo
echo "*** Put your BIOS file into ~/.epsxe/bios/"