summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2003-10-30 09:52:56 +0000
committerMike Frysinger <vapier@gentoo.org>2003-10-30 09:52:56 +0000
commitfb512eb5a007e3ec63fbbde4be9f4c6ae89521e7 (patch)
tree7743e19585e78baba9e15c4397cbc3172d218caa /games-emulation
parentattempt to fix EXTRA_COMPILE_ARGS bug (diff)
downloadgentoo-2-fb512eb5a007e3ec63fbbde4be9f4c6ae89521e7.tar.gz
gentoo-2-fb512eb5a007e3ec63fbbde4be9f4c6ae89521e7.tar.bz2
gentoo-2-fb512eb5a007e3ec63fbbde4be9f4c6ae89521e7.zip
path fix #32314
Diffstat (limited to 'games-emulation')
-rw-r--r--games-emulation/daphne/ChangeLog7
-rw-r--r--games-emulation/daphne/daphne-0.99.6-r1.ebuild (renamed from games-emulation/daphne/daphne-0.99.6.ebuild)11
-rw-r--r--games-emulation/daphne/files/0.99.6-local-dapinput.patch14
-rw-r--r--games-emulation/daphne/files/digest-daphne-0.99.6-r1 (renamed from games-emulation/daphne/files/digest-daphne-0.99.6)0
-rw-r--r--games-emulation/daphne/metadata.xml10
5 files changed, 36 insertions, 6 deletions
diff --git a/games-emulation/daphne/ChangeLog b/games-emulation/daphne/ChangeLog
index 6b41567c8cc3..1b578a9e8d82 100644
--- a/games-emulation/daphne/ChangeLog
+++ b/games-emulation/daphne/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for games-emulation/daphne
# Copyright 2000-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-emulation/daphne/ChangeLog,v 1.2 2003/09/10 16:00:43 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-emulation/daphne/ChangeLog,v 1.3 2003/10/30 09:52:56 vapier Exp $
+
+*daphne-0.99.6-r1 (30 Oct 2003)
+
+ 30 Oct 2003; Mike Frysinger <vapier@gentoo.org> :
+ Fix stupid path bug i made #32314.
*daphne-0.99.6 (15 Jul 2003)
diff --git a/games-emulation/daphne/daphne-0.99.6.ebuild b/games-emulation/daphne/daphne-0.99.6-r1.ebuild
index d5642b0ac7ed..e4ab28a8804a 100644
--- a/games-emulation/daphne/daphne-0.99.6.ebuild
+++ b/games-emulation/daphne/daphne-0.99.6-r1.ebuild
@@ -1,10 +1,8 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-emulation/daphne/daphne-0.99.6.ebuild,v 1.1 2003/09/09 16:26:49 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-emulation/daphne/daphne-0.99.6-r1.ebuild,v 1.1 2003/10/30 09:52:56 vapier Exp $
inherit games eutils flag-o-matic
-replace-flags -march=i686 -march=i586 # Bug 18807 Comment #11
-replace-flags -march=pentium3 -march=i586 # Bug 18807 Comment #4
DESCRIPTION="Laserdisc Arcade Game Emulator"
SRC_URI="http://www.daphne-emu.com/download/${P}-src.tar.gz"
@@ -34,11 +32,14 @@ src_unpack() {
sed -i "s:roms/:${GAMES_DATADIR}/${PN}/roms/:g" game/game.cpp
sed -i "s:sound/:${GAMES_DATADIR}/${PN}/sound/:g" sound/sound.cpp
sed -i "s:./lib:${GAMES_LIBDIR}/${PN}/lib:g" io/dll.h
- sed -i "s:daphne_log.txt:/tmp/daphne_log.txt:g" daphne.cpp daphne.h io/error.cpp
- sed -i "s:dapinput.ini:~/.dapinput.ini:" io/input.cpp
+ sed -i 's:daphne_log.txt:/tmp/daphne_log.txt:g' daphne.cpp daphne.h io/error.cpp
+ epatch ${FILESDIR}/${PV}-local-dapinput.patch
}
src_compile() {
+ replace-flags -march=i686 -march=i586 # Bug 18807 Comment #11
+ replace-flags -march=pentium3 -march=i586 # Bug 18807 Comment #4
+
cd ${S}/src
emake || die "src build failed"
cd ${S}/src/vldp
diff --git a/games-emulation/daphne/files/0.99.6-local-dapinput.patch b/games-emulation/daphne/files/0.99.6-local-dapinput.patch
new file mode 100644
index 000000000000..7867be6712ec
--- /dev/null
+++ b/games-emulation/daphne/files/0.99.6-local-dapinput.patch
@@ -0,0 +1,14 @@
+--- src/io/input.cpp.orig 2003-10-30 04:47:16.997745896 -0500
++++ src/io/input.cpp 2003-10-30 04:47:46.725226632 -0500
+@@ -25,0 +25,1 @@
++#include <unistd.h>
+@@ -113,7 +113,8 @@
+ char strTemp[25] = {0};
+ char thisChar = 0;
+
+- F = fopen("dapinput.ini", "rt");
++ chdir(getenv("HOME"));
++ F = fopen(".dapinput.ini", "rt");
+
+ // if we opened the file successfully
+ if (F != NULL)
diff --git a/games-emulation/daphne/files/digest-daphne-0.99.6 b/games-emulation/daphne/files/digest-daphne-0.99.6-r1
index 115b93db4360..115b93db4360 100644
--- a/games-emulation/daphne/files/digest-daphne-0.99.6
+++ b/games-emulation/daphne/files/digest-daphne-0.99.6-r1
diff --git a/games-emulation/daphne/metadata.xml b/games-emulation/daphne/metadata.xml
new file mode 100644
index 000000000000..b78c2d6d4aaa
--- /dev/null
+++ b/games-emulation/daphne/metadata.xml
@@ -0,0 +1,10 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>no-herd</herd>
+<longdescription>
+Welcome to DAPHNE, the First Ever Multiple Arcade Laserdisc Emulator! =] DAPHNE is a
+program that lets one play the original versions of many laserdisc arcade games on
+one's PC.
+</longdescription>
+</pkgmetadata>