summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2003-09-21 04:56:47 +0000
committerMike Frysinger <vapier@gentoo.org>2003-09-21 04:56:47 +0000
commitfeba97aaee637209f5b6dc8fe2eac33bb62f7128 (patch)
tree1daa4dc8f40b1d6e411b85622e090cf11c44aea5 /games-emulation
parentnow in games-server (diff)
downloadgentoo-2-feba97aaee637209f5b6dc8fe2eac33bb62f7128.tar.gz
gentoo-2-feba97aaee637209f5b6dc8fe2eac33bb62f7128.tar.bz2
gentoo-2-feba97aaee637209f5b6dc8fe2eac33bb62f7128.zip
fix for #29179
Diffstat (limited to 'games-emulation')
-rw-r--r--games-emulation/gxmame/ChangeLog7
-rw-r--r--games-emulation/gxmame/files/0.33-newxmame.patch24
-rw-r--r--games-emulation/gxmame/files/digest-gxmame-0.33-r1 (renamed from games-emulation/gxmame/files/digest-gxmame-0.33)0
-rw-r--r--games-emulation/gxmame/gxmame-0.33-r1.ebuild (renamed from games-emulation/gxmame/gxmame-0.33.ebuild)8
4 files changed, 37 insertions, 2 deletions
diff --git a/games-emulation/gxmame/ChangeLog b/games-emulation/gxmame/ChangeLog
index 1b074f6df6d6..7cbf3c79ca77 100644
--- a/games-emulation/gxmame/ChangeLog
+++ b/games-emulation/gxmame/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for games-emulation/gxmame
# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-emulation/gxmame/ChangeLog,v 1.2 2003/09/10 16:01:53 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-emulation/gxmame/ChangeLog,v 1.3 2003/09/21 04:56:47 vapier Exp $
+
+*gxmame-0.33-r1 (21 Sep 2003)
+
+ 21 Sep 2003; Mike Frysinger <vapier@gentoo.org> :
+ Add patch to fix changing of cmdline options for hot rod controllers #29179.
*gxmame-0.33 (13 Jul 2003)
diff --git a/games-emulation/gxmame/files/0.33-newxmame.patch b/games-emulation/gxmame/files/0.33-newxmame.patch
new file mode 100644
index 000000000000..da71ec76c180
--- /dev/null
+++ b/games-emulation/gxmame/files/0.33-newxmame.patch
@@ -0,0 +1,24 @@
+--- src/options.c.orig 2003-09-20 20:10:37.496519168 +1000
++++ src/options.c 2003-09-20 21:00:37.709417480 +1000
+@@ -6555,8 +6555,8 @@
+ "-%sanalogstick "
+ "%s " /* joy */
+ "-%smouse "
+- "-%shotrod "
+- "-%shotrodse "
++ "%s "
++ "%s "
+ "-%susbpspad "
+ "-%srapidfire "
+ "%s " /* trackball1 */
+@@ -6571,8 +6571,8 @@
+ (target->analogstick)?"":"no",
+ joy?joy:"",
+ (target->mouse)?"":"no",
+- (target->hotrod)?"":"no",
+- (target->hotrodse)?"":"no",
++ (target->hotrod)?"-ctrlr HotRod":"",
++ (target->hotrodse)?"-ctrlr HotRodSE":"",
+ (target->usbpspad)?"":"no",
+ (target->rapidfire)?"":"no",
+ trackball1?trackball1:"",
diff --git a/games-emulation/gxmame/files/digest-gxmame-0.33 b/games-emulation/gxmame/files/digest-gxmame-0.33-r1
index 252d98a085ee..252d98a085ee 100644
--- a/games-emulation/gxmame/files/digest-gxmame-0.33
+++ b/games-emulation/gxmame/files/digest-gxmame-0.33-r1
diff --git a/games-emulation/gxmame/gxmame-0.33.ebuild b/games-emulation/gxmame/gxmame-0.33-r1.ebuild
index c8cf3ef4d18b..a8d9321ffa0b 100644
--- a/games-emulation/gxmame/gxmame-0.33.ebuild
+++ b/games-emulation/gxmame/gxmame-0.33-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-emulation/gxmame/gxmame-0.33.ebuild,v 1.2 2003/09/09 23:33:23 msterret Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-emulation/gxmame/gxmame-0.33-r1.ebuild,v 1.1 2003/09/21 04:56:47 vapier Exp $
DESCRIPTION="frontend for XMame using the GTK library"
HOMEPAGE="http://gxmame.sourceforge.net/"
@@ -18,6 +18,12 @@ DEPEND="virtual/x11
RDEPEND="nls? ( sys-devel/gettext )
games-emulation/xmame"
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ epatch ${FILESDIR}/${PV}-newxmame.patch
+}
+
src_compile() {
econf `use_enable nls` || die
emake || die