summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2004-03-02 14:18:47 +0000
committerMike Frysinger <vapier@gentoo.org>2004-03-02 14:18:47 +0000
commit0ae39b4e76dd3504d0156055f67991da460c5889 (patch)
treefa558e5891c40b1a62dc6fef2f3fb7c6b8c1aa1e /games-engines/xzip
parentuse mirror://debian (diff)
downloadgentoo-2-0ae39b4e76dd3504d0156055f67991da460c5889.tar.gz
gentoo-2-0ae39b4e76dd3504d0156055f67991da460c5889.tar.bz2
gentoo-2-0ae39b4e76dd3504d0156055f67991da460c5889.zip
use epatch
Diffstat (limited to 'games-engines/xzip')
-rw-r--r--games-engines/xzip/xzip-1.8.2-r2.ebuild24
1 files changed, 13 insertions, 11 deletions
diff --git a/games-engines/xzip/xzip-1.8.2-r2.ebuild b/games-engines/xzip/xzip-1.8.2-r2.ebuild
index a0418f8f6c22..8e12c372c02f 100644
--- a/games-engines/xzip/xzip-1.8.2-r2.ebuild
+++ b/games-engines/xzip/xzip-1.8.2-r2.ebuild
@@ -1,34 +1,36 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-engines/xzip/xzip-1.8.2-r2.ebuild,v 1.2 2004/02/20 06:27:48 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-engines/xzip/xzip-1.8.2-r2.ebuild,v 1.3 2004/03/02 14:18:47 vapier Exp $
-inherit games
+inherit games eutils
-S=${WORKDIR}/xzip
DESCRIPTION="X interface to Z-code based text games"
-SRC_URI="http://www.eblong.com/zarf/ftp/xzip182.tar.Z"
HOMEPAGE="http://www.eblong.com/zarf/xzip.html"
+SRC_URI="http://www.eblong.com/zarf/ftp/xzip182.tar.Z"
-KEYWORDS="x86 ppc"
LICENSE="GPL-2"
SLOT="0"
+KEYWORDS="x86 ppc"
+IUSE=""
RDEPEND="virtual/x11"
DEPEND="${RDEPEND}
>=sys-apps/sed-4"
+S=${WORKDIR}/xzip
+
src_unpack() {
unpack xzip182.tar.Z
cd ${S}
- patch -p0 < ${FILESDIR}/xzip-182-makefile.diff
+ epatch ${FILESDIR}/xzip-182-makefile.diff
sed -i \
- -e "s/-O/${CFLAGS}/" Makefile || \
- die "sed Makefile failed"
+ -e "s/-O/${CFLAGS}/" Makefile \
+ || die "sed Makefile failed"
}
-src_install () {
- doman xzip.1
- dogamesbin xzip
+src_install() {
+ dogamesbin xzip || die
dodoc README
+ doman xzip.1
prepgamesdirs
}