summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2005-10-31 01:25:52 +0000
committerMike Frysinger <vapier@gentoo.org>2005-10-31 01:25:52 +0000
commit3453cb23b40d48ed90d21ffedd3057ec59566b04 (patch)
tree432e8b43eeb82272aa39cf23bde6ae96143d411d /games-engines
parentAdded ~sparc keyword wrt bug #110858. (diff)
downloadgentoo-2-3453cb23b40d48ed90d21ffedd3057ec59566b04.tar.gz
gentoo-2-3453cb23b40d48ed90d21ffedd3057ec59566b04.tar.bz2
gentoo-2-3453cb23b40d48ed90d21ffedd3057ec59566b04.zip
Version bump #110930 by Robert Lundmark.
(Portage version: 2.0.53_rc6)
Diffstat (limited to 'games-engines')
-rw-r--r--games-engines/scummvm/ChangeLog8
-rw-r--r--games-engines/scummvm/files/digest-scummvm-0.8.01
-rw-r--r--games-engines/scummvm/files/scummvm-0.8.0-configure.patch8
-rw-r--r--games-engines/scummvm/scummvm-0.8.0.ebuild62
4 files changed, 78 insertions, 1 deletions
diff --git a/games-engines/scummvm/ChangeLog b/games-engines/scummvm/ChangeLog
index f6a123989aab..0f6734501af9 100644
--- a/games-engines/scummvm/ChangeLog
+++ b/games-engines/scummvm/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for games-engines/scummvm
# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-engines/scummvm/ChangeLog,v 1.26 2005/09/16 22:11:06 ciaranm Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-engines/scummvm/ChangeLog,v 1.27 2005/10/31 01:25:52 vapier Exp $
+
+*scummvm-0.8.0 (31 Oct 2005)
+
+ 31 Oct 2005; Mike Frysinger <vapier@gentoo.org>
+ +files/scummvm-0.8.0-configure.patch, +scummvm-0.8.0.ebuild:
+ Version bump #110930 by Robert Lundmark.
16 Sep 2005; Ciaran McCreesh <ciaranm@gentoo.org> ChangeLog:
Converted to UTF-8, fixed encoding screwups
diff --git a/games-engines/scummvm/files/digest-scummvm-0.8.0 b/games-engines/scummvm/files/digest-scummvm-0.8.0
new file mode 100644
index 000000000000..2e136862761c
--- /dev/null
+++ b/games-engines/scummvm/files/digest-scummvm-0.8.0
@@ -0,0 +1 @@
+MD5 56bfbcfbe5adde42a2a9e3d6dc3d9068 scummvm-0.8.0.tar.bz2 2654730
diff --git a/games-engines/scummvm/files/scummvm-0.8.0-configure.patch b/games-engines/scummvm/files/scummvm-0.8.0-configure.patch
new file mode 100644
index 000000000000..0b955c2b6ab2
--- /dev/null
+++ b/games-engines/scummvm/files/scummvm-0.8.0-configure.patch
@@ -0,0 +1,8 @@
+--- configure
++++ configure
+@@ -433,4 +433,5 @@
+ _backend=`echo $ac_option | cut -d '=' -f 2`
+ ;;
++ --enable-debug);;
+ --disable-debug)
+ DEBFLAGS=""
diff --git a/games-engines/scummvm/scummvm-0.8.0.ebuild b/games-engines/scummvm/scummvm-0.8.0.ebuild
new file mode 100644
index 000000000000..f0140d264069
--- /dev/null
+++ b/games-engines/scummvm/scummvm-0.8.0.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-engines/scummvm/scummvm-0.8.0.ebuild,v 1.1 2005/10/31 01:25:52 vapier Exp $
+
+inherit eutils games
+
+DESCRIPTION="Reimplementation of the SCUMM game engine used in Lucasarts adventures"
+HOMEPAGE="http://scummvm.sourceforge.net/"
+SRC_URI="mirror://sourceforge/scummvm/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ppc sparc x86"
+IUSE="alsa debug flac mp3 ogg vorbis sdl zlib"
+RESTRICT="test" # it only looks like there's a test there #77507
+
+RDEPEND=">=media-libs/libsdl-1.2.2
+ >media-libs/libmpeg2-0.3.1
+ ogg? ( media-libs/libogg media-libs/libvorbis )
+ vorbis? ( media-libs/libogg media-libs/libvorbis )
+ alsa? ( >=media-libs/alsa-lib-0.9 )
+ mp3? ( media-libs/libmad )
+ flac? ( media-libs/flac )
+ zlib? ( sys-libs/zlib )"
+DEPEND="${RDEPEND}
+ x86? ( dev-lang/nasm )"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/${P}-configure.patch
+}
+
+src_compile() {
+ local myconf="--backend=sdl" # x11 backend no worky (bug #83502)
+
+ (use vorbis || use ogg) \
+ && myconf="${myconf} --enable-vorbis" \
+ || myconf="${myconf} --disable-vorbis --disable-mpeg2"
+
+ # NOT AN AUTOCONF SCRIPT SO DONT CALL ECONF
+ # mpeg2 support needs vorbis (bug #79149) so turn it off if -oggvorbis
+ ./configure \
+ $(use_enable debug) \
+ $(use_enable alsa) \
+ $(use_enable mp3 mad) \
+ $(use_enable flac) \
+ $(use_enable zlib) \
+ $(use_enable x86 nasm) \
+ ${myconf} \
+ || die "configure failed"
+ emake || die "emake failed"
+}
+
+src_install() {
+ dogamesbin scummvm || die "dobin failed"
+ doman scummvm.6
+ dodoc NEWS README TODO
+ doicon scummvm.xpm
+ make_desktop_entry scummvm ScummVM
+ prepgamesdirs
+}