summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2012-07-10 21:06:40 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2012-07-10 21:06:40 +0000
commita40378815879eded8f90a12359211e63424853a1 (patch)
tree1b3b3a6d942b8157d7742f85d266c93de97d1c65 /games-engines
parentsci-biology/psipred: Version Bump (diff)
downloadgentoo-2-a40378815879eded8f90a12359211e63424853a1.tar.gz
gentoo-2-a40378815879eded8f90a12359211e63424853a1.tar.bz2
gentoo-2-a40378815879eded8f90a12359211e63424853a1.zip
use latest boost available
(Portage version: 2.1.10.65/cvs/Linux x86_64)
Diffstat (limited to 'games-engines')
-rw-r--r--games-engines/scummvm-tools/ChangeLog6
-rw-r--r--games-engines/scummvm-tools/scummvm-tools-1.4.0.ebuild19
2 files changed, 22 insertions, 3 deletions
diff --git a/games-engines/scummvm-tools/ChangeLog b/games-engines/scummvm-tools/ChangeLog
index 464692e74afa..f285a57cfc4d 100644
--- a/games-engines/scummvm-tools/ChangeLog
+++ b/games-engines/scummvm-tools/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for games-engines/scummvm-tools
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-engines/scummvm-tools/ChangeLog,v 1.54 2012/05/02 21:02:02 jdhore Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-engines/scummvm-tools/ChangeLog,v 1.55 2012/07/10 21:06:40 mr_bones_ Exp $
+
+ 10 Jul 2012; Michael Sterrett <mr_bones_@gentoo.org>
+ scummvm-tools-1.4.0.ebuild:
+ use latest boost available
02 May 2012; Jeff Horelick <jdhore@gentoo.org> scummvm-tools-1.3.0.ebuild,
scummvm-tools-1.4.0.ebuild:
diff --git a/games-engines/scummvm-tools/scummvm-tools-1.4.0.ebuild b/games-engines/scummvm-tools/scummvm-tools-1.4.0.ebuild
index 6d1427bd6179..e15654f8be87 100644
--- a/games-engines/scummvm-tools/scummvm-tools-1.4.0.ebuild
+++ b/games-engines/scummvm-tools/scummvm-tools-1.4.0.ebuild
@@ -1,10 +1,10 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-engines/scummvm-tools/scummvm-tools-1.4.0.ebuild,v 1.5 2012/05/02 21:02:01 jdhore Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-engines/scummvm-tools/scummvm-tools-1.4.0.ebuild,v 1.6 2012/07/10 21:06:40 mr_bones_ Exp $
EAPI=2
WX_GTK_VER=2.8
-inherit wxwidgets games
+inherit wxwidgets flag-o-matic games
DESCRIPTION="utilities for the SCUMM game engine"
HOMEPAGE="http://scummvm.sourceforge.net/"
@@ -22,6 +22,7 @@ RDEPEND="png? ( media-libs/libpng )
vorbis? ( media-libs/libvorbis )
iconv? ( virtual/libiconv media-libs/freetype:2 )
sys-libs/zlib
+ >=dev-libs/boost-1.32
x11-libs/wxGTK:2.8"
DEPEND="${RDEPEND}
virtual/pkgconfig"
@@ -37,6 +38,20 @@ src_prepare() {
sed -ri \
-e '/^(CC|CXX)\b/d' \
Makefile || die
+
+ local boost_ver=$(best_version ">=dev-libs/boost-1.32")
+
+ boost_ver=${boost_ver/*boost-/}
+ boost_ver=${boost_ver%.*}
+ boost_ver=${boost_ver/./_}
+
+ einfo "Using boost version ${boost_ver}"
+ append-cxxflags \
+ -I/usr/include/boost-${boost_ver}
+ append-ldflags \
+ -L/usr/$(get_libdir)/boost-${boost_ver}
+ export BOOST_INCLUDEDIR="/usr/include/boost-${boost_ver}"
+ export BOOST_LIBRARYDIR="/usr/$(get_libdir)/boost-${boost_ver}"
}
src_configure() {