summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2004-07-29 08:20:20 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2004-07-29 08:20:20 +0000
commita69ca0984cb58c6bb744850af1b88f3480487b8a (patch)
treed7dc28dbf5caadd24c69846ddd62455394da33d8 /games-engines
parentMarking stable since it really is. (Manifest recommit) (diff)
downloadgentoo-2-a69ca0984cb58c6bb744850af1b88f3480487b8a.tar.gz
gentoo-2-a69ca0984cb58c6bb744850af1b88f3480487b8a.tar.bz2
gentoo-2-a69ca0984cb58c6bb744850af1b88f3480487b8a.zip
version bump (bug #58542)
Diffstat (limited to 'games-engines')
-rw-r--r--games-engines/scummvm/ChangeLog7
-rw-r--r--games-engines/scummvm/Manifest2
-rw-r--r--games-engines/scummvm/files/digest-scummvm-0.6.11
-rw-r--r--games-engines/scummvm/scummvm-0.6.1.ebuild56
4 files changed, 65 insertions, 1 deletions
diff --git a/games-engines/scummvm/ChangeLog b/games-engines/scummvm/ChangeLog
index d207388fb7b1..767a22adf044 100644
--- a/games-engines/scummvm/ChangeLog
+++ b/games-engines/scummvm/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for games-engines/scummvm
# Copyright 2002-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-engines/scummvm/ChangeLog,v 1.10 2004/06/24 22:39:14 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-engines/scummvm/ChangeLog,v 1.11 2004/07/29 08:20:20 mr_bones_ Exp $
+
+*scummvm-0.6.1 (29 Jul 2004)
+
+ 29 Jul 2004; Michael Sterrett <mr_bones_@gentoo.org> +scummvm-0.6.1.ebuild:
+ version bump (bug #58542)
01 Jun 2004; Travis Tilley <lv@gentoo.org> scummvm-0.6.0.ebuild:
stable on amd64
diff --git a/games-engines/scummvm/Manifest b/games-engines/scummvm/Manifest
index 2b28c89c654b..385c1d42fe03 100644
--- a/games-engines/scummvm/Manifest
+++ b/games-engines/scummvm/Manifest
@@ -1,8 +1,10 @@
MD5 a8fbb93a6b7a88fc7355b3f314284380 ChangeLog 3412
MD5 5234b28a69ecec6de215054a3ad810f6 scummvm-0.5.1.ebuild 1432
MD5 f17b9b8fa07a38914fe1c03268f51678 metadata.xml 158
+MD5 79635c76b4710075cbb8799b9d1e9ff5 scummvm-0.6.1.ebuild 1418
MD5 9be8bc622b0d1df5f4deb49c936e463b scummvm-0.6.0.ebuild 1492
MD5 ece3781510db9d2d60fcabd88eb576a8 files/0.5.1-alsa.patch 777
MD5 a05cefcb4e86dbf7d1c4592029bf7195 files/digest-scummvm-0.5.1 67
MD5 11d226ec4661788cb3461a72f253cd63 files/digest-scummvm-0.6.0 67
MD5 376253699b8cb172b6b0ebd5b1761754 files/0.6.0-gcc34.patch 1435
+MD5 ba65f67b7aa6caf2de3218ad27234007 files/digest-scummvm-0.6.1 71
diff --git a/games-engines/scummvm/files/digest-scummvm-0.6.1 b/games-engines/scummvm/files/digest-scummvm-0.6.1
new file mode 100644
index 000000000000..8775b0886454
--- /dev/null
+++ b/games-engines/scummvm/files/digest-scummvm-0.6.1
@@ -0,0 +1 @@
+MD5 392bf788bb367258e5c34f77eced954d scummvm-0.6.1-src.tar.bz2 1612540
diff --git a/games-engines/scummvm/scummvm-0.6.1.ebuild b/games-engines/scummvm/scummvm-0.6.1.ebuild
new file mode 100644
index 000000000000..38f44c95aec1
--- /dev/null
+++ b/games-engines/scummvm/scummvm-0.6.1.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-engines/scummvm/scummvm-0.6.1.ebuild,v 1.1 2004/07/29 08:20:20 mr_bones_ Exp $
+
+inherit eutils games
+
+DESCRIPTION="Reimplementation of the SCUMM game engine used in Lucasarts adventures"
+HOMEPAGE="http://scummvm.sourceforge.net/"
+SRC_URI="mirror://sourceforge/scummvm/${P}-src.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="x86 ppc amd64 ~sparc"
+IUSE="alsa debug mad oggvorbis sdl zlib"
+
+DEPEND="virtual/libc
+ virtual/x11
+ >media-libs/libmpeg2-0.3.1
+ sdl? ( >=media-libs/libsdl-1.2.2 )
+ oggvorbis? (
+ media-libs/libogg
+ media-libs/libvorbis
+ )
+ alsa? ( >=media-libs/alsa-lib-0.9 )
+ mad? ( media-libs/libmad )
+ zlib? ( sys-libs/zlib )"
+
+src_compile() {
+ local myconf=
+
+ use sdl \
+ && myconf="${myconf} --backend=sdl" \
+ || myconf="${myconf} --backend=x11"
+ use debug \
+ || myconf="${myconf} --disable-debug"
+
+ # not an autoconf script so dont call econf
+ ./configure \
+ $(use_enable alsa) \
+ $(use_enable mad) \
+ $(use_enable oggvorbis vorbis) \
+ $(use_enable zlib) \
+ ${myconf} \
+ || die "configure failed"
+ emake || die "emake failed"
+}
+
+src_install() {
+ dogamesbin scummvm || die "dobin failed"
+ doman scummvm.6
+ dodoc NEWS README TODO
+ insinto /usr/share/pixmaps
+ doins scummvm.xpm || die "doins failed"
+ make_desktop_entry scummvm ScummVM
+ prepgamesdirs
+}