summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJulian Ospald <hasufell@gentoo.org>2013-03-29 16:06:54 +0000
committerJulian Ospald <hasufell@gentoo.org>2013-03-29 16:06:54 +0000
commit9ca057facc7e6f822c8717e34e628ee4f775eeeb (patch)
tree62c565fd9cc5b9dbc9b21e320a62e3709056d044 /games-fps/duke3d
parentVersion bump (diff)
downloadgentoo-2-9ca057facc7e6f822c8717e34e628ee4f775eeeb.tar.gz
gentoo-2-9ca057facc7e6f822c8717e34e628ee4f775eeeb.tar.bz2
gentoo-2-9ca057facc7e6f822c8717e34e628ee4f775eeeb.zip
use unpack_zip from unpacker.eclass instead of unzip
(Portage version: 2.2.0_alpha169/cvs/Linux x86_64, signed Manifest commit with key E73C35B3)
Diffstat (limited to 'games-fps/duke3d')
-rw-r--r--games-fps/duke3d/ChangeLog7
-rw-r--r--games-fps/duke3d/duke3d-20040817-r2.ebuild10
2 files changed, 10 insertions, 7 deletions
diff --git a/games-fps/duke3d/ChangeLog b/games-fps/duke3d/ChangeLog
index e7e98bd2dc30..e0ae6be735ec 100644
--- a/games-fps/duke3d/ChangeLog
+++ b/games-fps/duke3d/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for games-fps/duke3d
-# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-fps/duke3d/ChangeLog,v 1.36 2010/10/08 12:55:49 tupone Exp $
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/games-fps/duke3d/ChangeLog,v 1.37 2013/03/29 16:06:54 hasufell Exp $
+
+ 29 Mar 2013; Julian Ospald <hasufell@gentoo.org> duke3d-20040817-r2.ebuild:
+ use unpack_zip from unpacker.eclass instead of unzip
08 Oct 2010; Tupone Alfredo <tupone@gentoo.org> duke3d-20040817-r2.ebuild,
+files/duke3d-20040817-ldflags.patch:
diff --git a/games-fps/duke3d/duke3d-20040817-r2.ebuild b/games-fps/duke3d/duke3d-20040817-r2.ebuild
index 998b411dd2a7..f99d7aff3256 100644
--- a/games-fps/duke3d/duke3d-20040817-r2.ebuild
+++ b/games-fps/duke3d/duke3d-20040817-r2.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2010 Gentoo Foundation
+# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-fps/duke3d/duke3d-20040817-r2.ebuild,v 1.11 2010/10/08 12:55:49 tupone Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-fps/duke3d/duke3d-20040817-r2.ebuild,v 1.12 2013/03/29 16:06:54 hasufell Exp $
EAPI=2
fromcvs=0
@@ -8,9 +8,9 @@ ECVS_MODULE="duke3d"
if [[ ${fromcvs} -eq 1 ]] ; then
ECVS_PASS="anonymous"
ECVS_SERVER="icculus.org:/cvs/cvsroot"
- inherit cvs eutils flag-o-matic games
+ inherit unpacker cvs eutils flag-o-matic games
else
- inherit eutils flag-o-matic games
+ inherit unpacker eutils flag-o-matic games
fi
DEMO="3dduke13.zip"
@@ -53,7 +53,7 @@ src_unpack() {
fi
if use demo ; then
- unzip -qo DN3DSW13.SHR || die "unzip DN3DSW13.SHR failed"
+ unpack_zip DN3DSW13.SHR
fi
}