summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChris Gianelloni <wolf31o2@gentoo.org>2006-06-27 20:22:47 +0000
committerChris Gianelloni <wolf31o2@gentoo.org>2006-06-27 20:22:47 +0000
commitc2d9ada2e981e65a7abd34a6b8906862d00870cd (patch)
tree11e2c3b2a1584624006d20b19239a156c866fc1f /games-fps/quake2-textures/quake2-textures-0_beta8.ebuild
parentremove defunct USE flag mmx2 (bug #138232) (diff)
downloadgentoo-2-c2d9ada2e981e65a7abd34a6b8906862d00870cd.tar.gz
gentoo-2-c2d9ada2e981e65a7abd34a6b8906862d00870cd.tar.bz2
gentoo-2-c2d9ada2e981e65a7abd34a6b8906862d00870cd.zip
Initial import. Ebuild by Paul Bredbury <brebs@sent.com>. Closing bug #137529.
(Portage version: 2.1.1_pre1-r2)
Diffstat (limited to 'games-fps/quake2-textures/quake2-textures-0_beta8.ebuild')
-rw-r--r--games-fps/quake2-textures/quake2-textures-0_beta8.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/games-fps/quake2-textures/quake2-textures-0_beta8.ebuild b/games-fps/quake2-textures/quake2-textures-0_beta8.ebuild
new file mode 100644
index 000000000000..50a5809e84d8
--- /dev/null
+++ b/games-fps/quake2-textures/quake2-textures-0_beta8.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-fps/quake2-textures/quake2-textures-0_beta8.ebuild,v 1.1 2006/06/27 20:22:47 wolf31o2 Exp $
+
+inherit eutils versionator games
+
+MY_PV=$(get_version_component_range 2-2)
+MY_PV=${MY_PV/beta/}
+
+DESCRIPTION="High-resolution textures for Quake 2"
+HOMEPAGE="http://jdolan.dyndns.org/trac/wiki/Retexture"
+SRC_URI="http://jdolan.dyndns.org/jaydolan/tmp/retexture/pak${MY_PV}.zip"
+
+LICENSE="as-is"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE=""
+
+RDEPEND=""
+DEPEND="app-arch/unzip"
+
+S=${WORKDIR}
+dir=${GAMES_DATADIR}/quake2
+
+src_install() {
+ insinto "${dir}"/baseq2
+ doins *.pak || die "doins *.pak failed"
+
+ dodoc README
+
+ prepgamesdirs
+}
+
+pkg_postinst() {
+ games_pkg_postinst
+
+ einfo "Use a recent Quake 2 client to take advantage of"
+ einfo "these textures, e.g. qudos or quake2-icculus."
+ echo
+}