summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2005-03-11 01:47:50 +0000
committerMike Frysinger <vapier@gentoo.org>2005-03-11 01:47:50 +0000
commitc0c21d951f02cd9a34f741869a8ddcfeaaca2100 (patch)
treedc7e2e1a1a24addf2c1f221fcf95385c35bf2f67 /games-fps
parentFix quake2-icculus use flags (bug #84803); sort (diff)
downloadgentoo-2-c0c21d951f02cd9a34f741869a8ddcfeaaca2100.tar.gz
gentoo-2-c0c21d951f02cd9a34f741869a8ddcfeaaca2100.tar.bz2
gentoo-2-c0c21d951f02cd9a34f741869a8ddcfeaaca2100.zip
Version bumpage.
(Portage version: 2.0.51.19)
Diffstat (limited to 'games-fps')
-rw-r--r--games-fps/quake2-icculus/ChangeLog8
-rw-r--r--games-fps/quake2-icculus/files/digest-quake2-icculus-0.16.14
-rw-r--r--games-fps/quake2-icculus/quake2-icculus-0.16.1.ebuild155
3 files changed, 166 insertions, 1 deletions
diff --git a/games-fps/quake2-icculus/ChangeLog b/games-fps/quake2-icculus/ChangeLog
index 7aa03ddd1a77..d3e2168d9e8c 100644
--- a/games-fps/quake2-icculus/ChangeLog
+++ b/games-fps/quake2-icculus/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for games-fps/quake2-icculus
# Copyright 2002-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-fps/quake2-icculus/ChangeLog,v 1.11 2005/01/03 23:52:32 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-fps/quake2-icculus/ChangeLog,v 1.12 2005/03/11 01:47:50 vapier Exp $
+
+*quake2-icculus-0.16.1 (10 Mar 2005)
+
+ 10 Mar 2005; Mike Frysinger <vapier@gentoo.org>
+ +quake2-icculus-0.16.1.ebuild:
+ Version bumpage.
*quake2-icculus-0.16 (03 Jan 2005)
diff --git a/games-fps/quake2-icculus/files/digest-quake2-icculus-0.16.1 b/games-fps/quake2-icculus/files/digest-quake2-icculus-0.16.1
new file mode 100644
index 000000000000..c85d15d16e9b
--- /dev/null
+++ b/games-fps/quake2-icculus/files/digest-quake2-icculus-0.16.1
@@ -0,0 +1,4 @@
+MD5 6b0e3fff324a5db58a8f8309dcabb47a quake2-r0.16.1.tar.gz 1525384
+MD5 04d3f1fb7fb4dada7175a41f4595c7eb maxpak.pak 3282742
+MD5 7d5e052839c9e629bad0a6570aa70554 roguesrc320.shar.Z 626769
+MD5 41fc4ecc4f25c068e7d1f488bd4a1e1a xatrixsrc320.shar.Z 455917
diff --git a/games-fps/quake2-icculus/quake2-icculus-0.16.1.ebuild b/games-fps/quake2-icculus/quake2-icculus-0.16.1.ebuild
new file mode 100644
index 000000000000..08384ef88d1b
--- /dev/null
+++ b/games-fps/quake2-icculus/quake2-icculus-0.16.1.ebuild
@@ -0,0 +1,155 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-fps/quake2-icculus/quake2-icculus-0.16.1.ebuild,v 1.1 2005/03/11 01:47:50 vapier Exp $
+
+inherit eutils games
+
+MY_P="quake2-r${PV}"
+DESCRIPTION="The icculus.org linux port of iD's quake2 engine"
+HOMEPAGE="http://icculus.org/quake2/"
+SRC_URI="http://icculus.org/quake2/files/${MY_P}.tar.gz
+ !noqmax? ( http://icculus.org/quake2/files/maxpak.pak )
+ rogue? ( ftp://ftp.idsoftware.com/idstuff/quake2/source/roguesrc320.shar.Z )
+ xatrix? ( ftp://ftp.idsoftware.com/idstuff/quake2/source/xatrixsrc320.shar.Z )"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="alpha amd64 ppc sparc x86"
+IUSE="arts svga sdl aalib dedicated opengl noqmax rogue xatrix ipv6 joystick"
+
+# default to X11 if svga/opengl/sdl/aalib/dedicated are not in USE
+RDEPEND="opengl? ( virtual/opengl )
+ svga? ( media-libs/svgalib )
+ sdl? ( media-libs/libsdl )
+ aalib? ( media-libs/aalib )
+ !svga? ( !opengl? ( !sdl? ( !aalib? ( !dedicated? ( virtual/x11 ) ) ) ) )
+ arts? ( kde-base/arts )"
+DEPEND="${RDEPEND}
+ rogue? ( app-arch/sharutils )
+ xatrix? ( app-arch/sharutils )"
+
+S=${WORKDIR}/${MY_P}
+
+src_unpack() {
+ unpack ${MY_P}.tar.gz
+ cd "${S}"
+ epatch "${FILESDIR}"/0.16-Makefile-gentoo-opts.patch
+ epatch "${FILESDIR}"/0.16-gentoo-path.patch
+ cat << EOF > src/linux/gentoo-paths.h
+#define GENTOO_DATADIR "${GAMES_DATADIR}/quake2-data"
+#ifdef QMAX
+#define GENTOO_LIBDIR "${GAMES_LIBDIR}/${PN}-qmax"
+#else
+#define GENTOO_LIBDIR "${GAMES_LIBDIR}/${PN}"
+#endif
+EOF
+
+ # Now we deal with the silly rogue / xatrix addons ... this is ugly :/
+ ln -s $(which echo) "${T}"/more
+ for g in rogue xatrix ; do
+ use ${g} || continue
+ mkdir -p "${S}"/src/${g}
+ cd "${S}"/src/${g}
+ local shar=${g}src320.shar
+ unpack ${shar}.Z
+ sed -i \
+ -e 's:^read ans:ans=yes :' ${shar} \
+ || die "sed ${shar} failed"
+ echo ">>> Unpacking ${shar} to ${PWD}"
+ env PATH=${T}:${PATH} unshar ${shar} || die "unpacking ${shar} failed"
+ rm ${shar}
+ done
+ if use rogue ; then
+ cd "${S}"/src
+ epatch "${FILESDIR}"/0.16-rogue-nan.patch
+ fi
+}
+
+yesno() {
+ for f in "$@" ; do
+ if ! useq $f ; then
+ echo NO
+ return 1
+ fi
+ done
+ echo YES
+ return 0
+}
+
+src_compile() {
+ BUILD_X11=$(yesno X)
+ use sdl || use opengl || use svga || use aalib || BUILD_X11=YES
+
+ # xatrix fails to build
+ # rogue fails to build
+ for BUILD_QMAX in YES NO ; do
+ use noqmax && [[ ${BUILD_QMAX} == "YES" ]] && continue
+ make clean || die "cleaning failed"
+ emake -j1 build_release \
+ BUILD_SDLQUAKE2=$(yesno sdl) \
+ BUILD_SVGA=$(yesno svga) \
+ BUILD_X11=${BUILD_X11} \
+ BUILD_GLX=$(yesno opengl) \
+ BUILD_SDL=$(yesno sdl) \
+ BUILD_SDLGL=$(yesno sdl opengl) \
+ BUILD_CTFDLL=YES \
+ BUILD_XATRIX=$(yesno xatrix) \
+ BUILD_ROGUE=$(yesno rogue) \
+ BUILD_JOYSTICK=$(yesno joystick) \
+ BUILD_DEDICATED=YES \
+ BUILD_AA=$(yesno aalib) \
+ BUILD_QMAX=${BUILD_QMAX} \
+ HAVE_IPV6=$(yesno ipv6) \
+ BUILD_ARTS=$(yesno arts) \
+ SDLDIR=/usr/lib \
+ OPTCFLAGS="${CFLAGS}" \
+ || die "make failed"
+ # now we save the build dir ... except for the object files ...
+ rm release*/*/*.o
+ mv release* my-rel-${BUILD_QMAX}
+ cd my-rel-${BUILD_QMAX}
+ rm -rf ref_{gl,soft} ded game client ctf/*.o
+ mkdir baseq2
+ mv game*.so baseq2/
+ cd ..
+ done
+}
+
+src_install() {
+ local q2dir=${GAMES_LIBDIR}/${PN}
+ local q2maxdir=${GAMES_LIBDIR}/${PN}-qmax
+
+ dodoc readme.txt README TODO "${FILESDIR}"/README-postinstall
+
+ # regular q2 files
+ dodir "${q2dir}"
+ cp -rf my-rel-NO/* "${D}/${q2dir}"/
+ dogamesbin "${D}/${q2dir}"/{quake2,q2ded}
+ rm "${D}/${q2dir}"/{quake2,q2ded}
+ use sdl \
+ && dogamesbin "${D}/${q2dir}"/sdlquake2 \
+ && rm "${D}/${q2dir}"/sdlquake2
+
+ # q2max files
+ if ! use noqmax ; then
+ dodir "${q2maxdir}"
+ cp -rf my-rel-YES/* "${D}/${q2maxdir}"/
+ newgamesbin "${D}/${q2maxdir}"/quake2 quake2-qmax
+ newgamesbin "${D}/${q2maxdir}"/q2ded q2ded-qmax
+ rm "${D}/${q2maxdir}"/{quake2,q2ded}
+ use sdl \
+ && newgamesbin "${D}/${q2maxdir}"/sdlquake2 sdlquake2-qmax \
+ && rm "${D}/${q2maxdir}"/sdlquake2
+
+ insinto "${q2maxdir}"/baseq2
+ doins "${DISTDIR}"/maxpak.pak
+ fi
+ prepgamesdirs
+}
+
+pkg_postinst() {
+ games_pkg_postinst
+ einfo "Go read /usr/share/doc/${PF}/README-postinstall.gz right now!"
+ einfo "It's important- This install is just the engine, you still need"
+ einfo "the data paks. Go read."
+}