summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2010-03-10 05:04:03 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2010-03-10 05:04:03 +0000
commitc9509b85b1364d481dffa4fbd7fb1ea0dc6f18df (patch)
tree9f2c1df42196c1d0710efd07e7e64a02a70a3841 /games-fps
parent*portage-2.2_rc67 (10 Mar 2010) (diff)
downloadgentoo-2-c9509b85b1364d481dffa4fbd7fb1ea0dc6f18df.tar.gz
gentoo-2-c9509b85b1364d481dffa4fbd7fb1ea0dc6f18df.tar.bz2
gentoo-2-c9509b85b1364d481dffa4fbd7fb1ea0dc6f18df.zip
old
(Portage version: 2.1.7.17/cvs/Linux i686)
Diffstat (limited to 'games-fps')
-rw-r--r--games-fps/openarena/Manifest1
-rw-r--r--games-fps/openarena/openarena-0.8.1.ebuild83
2 files changed, 0 insertions, 84 deletions
diff --git a/games-fps/openarena/Manifest b/games-fps/openarena/Manifest
index 58302542636c..90ee5f690a08 100644
--- a/games-fps/openarena/Manifest
+++ b/games-fps/openarena/Manifest
@@ -3,6 +3,5 @@ AUX openarena-0.8.1-zlib.patch 3112 RMD160 dd8985f1b527c5a094656c897a37f3528ca5c
DIST oa081.zip 318927645 RMD160 9009eaf581ad0bf19296418da1a16e2d43daec16 SHA1 526c39e51d0b53177b02bd490bf830f622f35ad5 SHA256 c96282de8bc2ac5781df58c6adbce4265376e36190af50d7528f51dc739b6d7d
DIST openarena-engine-0.8.1-1.tar.bz2 2951703 RMD160 123e9f70621fd856385c6ca7ad0580b81454d687 SHA1 6de345c0bebd87e1406cb07189537db99a422808 SHA256 430ba9b691c8085b946e004f0cc890995c7f8295498bd8c8ce744293a87274d2
EBUILD openarena-0.8.1-r1.ebuild 2276 RMD160 e765fcc580ab4ddfe0fcd7ec11cc98acbff0c5fa SHA1 cc47f0604ba6e6d51bdc172bc2fa75a7486473df SHA256 6f3f75d302ace3ef6511e742a46ee9284e7a5bbce5d2cec4f9db1d59040a0bba
-EBUILD openarena-0.8.1.ebuild 2265 RMD160 8fc713b3f42a1ddc77bf4b572290e6309d2c98f0 SHA1 3f71fbec0226b159af47073202435e4418f0f9b4 SHA256 44477dc82585d209612efcb11ced179fd946b156a379f2c72b7bafa0764cda7a
MISC ChangeLog 2158 RMD160 59d573ada6088a548b37905c81d5371679ba00f4 SHA1 a574d4a94787c832bcdbb3f6fab4c9fe8b4ff121 SHA256 bf4f4f373cb57b35f421fe4f7b63e83fe4f271b2cc51fc67512a37963c7b8f66
MISC metadata.xml 158 RMD160 cbd9984bb6b426c8c9cee5022fe0a26261612fea SHA1 be5251fa1dacef5c41b74761bb1c8c54fb633b9e SHA256 1423a4fdd4a79b1728a2056d9e300f7e1074253095d82726218d9e9b953888a3
diff --git a/games-fps/openarena/openarena-0.8.1.ebuild b/games-fps/openarena/openarena-0.8.1.ebuild
deleted file mode 100644
index 2349492f0346..000000000000
--- a/games-fps/openarena/openarena-0.8.1.ebuild
+++ /dev/null
@@ -1,83 +0,0 @@
-# Copyright 1999-2009 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-fps/openarena/openarena-0.8.1.ebuild,v 1.6 2009/10/12 15:14:04 mr_bones_ Exp $
-
-EAPI=2
-inherit eutils flag-o-matic versionator games
-
-MY_PV=$(delete_all_version_separators)
-
-DESCRIPTION="Open-source replacement for Quake 3 Arena"
-HOMEPAGE="http://openarena.ws/"
-SRC_URI="http://download.tuxfamily.org/openarena/rel/${MY_PV}/oa${MY_PV}.zip
- http://openarena.ws/svn/source/${MY_PV}/${PN}-engine-${PV}-1.tar.bz2"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="+curl +openal +vorbis"
-
-RDEPEND="virtual/opengl
- media-libs/libsdl[joystick,opengl,video]
- x11-libs/libXext
- x11-libs/libX11
- x11-libs/libXau
- x11-libs/libXdmcp
- curl? ( net-misc/curl )
- openal? ( media-libs/openal )
- vorbis? ( media-libs/libvorbis )"
-DEPEND="${RDEPEND}
- app-arch/unzip"
-
-MY_S=${WORKDIR}/${PN}-engine-${PV}
-BUILD_DIR=${PN}-build
-DIR=${GAMES_DATADIR}/${PN}
-
-src_prepare() {
- cd "${WORKDIR}"
- epatch "${FILESDIR}"/${P}-makefile.patch
- append-cflags -fno-strict-aliasing # bug #268851
- sed -i \
- -e "s:%CFLAGS%:${CFLAGS}:g" \
- "${MY_S}"/Makefile \
- || die "sed failed"
- sed -i \
- -e '/ALDRIVER_DEFAULT/s/libopenal.so.0/libopenal.so/' \
- "${MY_S}"/code/client/snd_openal.c \
- || die "sed failed"
-}
-
-src_compile() {
- local myopts
-
- # use always internal speex and enable voip through it, disable mumble
- # also build always server and use smp by default
- myopts="USE_INTERNAL_SPEEX=1 USE_VOIP=1 USE_MUMBLE=0
- BUILD_SERVER=1 BUILD_CLIENT_SMP=1 USE_LOCAL_HEADERS=0"
- use curl || myopts="${myopts} USE_CURL=0"
- use openal || myopts="${myopts} USE_OPENAL=0"
- use vorbis || myopts="${myopts} USE_CODEC_VORBIS=0"
-
- cd "${MY_S}"
- emake \
- DEFAULT_BASEDIR="${DIR}" \
- BR="${BUILD_DIR}" \
- ${myopts} \
- || die "emake failed"
-}
-
-src_install() {
- cd "${MY_S}"/"${BUILD_DIR}"
- newgamesbin openarena-smp.* "${PN}" || die "binary install failed"
- newgamesbin oa_ded.* "${PN}-ded" || die "dedicated binary not found"
- cd "${S}"
-
- insinto "${DIR}"
- doins -r baseoa missionpack || die "doins -r failed"
-
- dodoc CHANGES CREDITS LINUXNOTES README
- newicon "${MY_S}"/misc/quake3.png ${PN}.png
- make_desktop_entry ${PN} "OpenArena"
-
- prepgamesdirs
-}