summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlfredo Tupone <tupone@gentoo.org>2015-02-02 17:24:16 +0000
committerAlfredo Tupone <tupone@gentoo.org>2015-02-02 17:24:16 +0000
commit3877817fe6679d4f23db7184077b2637b8f49192 (patch)
tree80f2baa0a4001b7fbcb575b81e958244102c44e0 /games-kids
parentStabilizing (diff)
downloadgentoo-2-3877817fe6679d4f23db7184077b2637b8f49192.tar.gz
gentoo-2-3877817fe6679d4f23db7184077b2637b8f49192.tar.bz2
gentoo-2-3877817fe6679d4f23db7184077b2637b8f49192.zip
migrate to python-single-r1
(Portage version: 2.2.14/cvs/Linux x86_64, signed Manifest commit with key 0145142D)
Diffstat (limited to 'games-kids')
-rw-r--r--games-kids/tuxmathscrabble/ChangeLog9
-rw-r--r--games-kids/tuxmathscrabble/tuxmathscrabble-7.4-r1.ebuild62
2 files changed, 69 insertions, 2 deletions
diff --git a/games-kids/tuxmathscrabble/ChangeLog b/games-kids/tuxmathscrabble/ChangeLog
index 1097f07bb774..c6cffecd5416 100644
--- a/games-kids/tuxmathscrabble/ChangeLog
+++ b/games-kids/tuxmathscrabble/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for games-kids/tuxmathscrabble
-# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-kids/tuxmathscrabble/ChangeLog,v 1.19 2011/03/04 12:58:07 ranger Exp $
+# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/games-kids/tuxmathscrabble/ChangeLog,v 1.20 2015/02/02 17:24:16 tupone Exp $
+
+*tuxmathscrabble-7.4-r1 (02 Feb 2015)
+
+ 02 Feb 2015; Tupone Alfredo <tupone@gentoo.org> +tuxmathscrabble-7.4-r1.ebuild:
+ Port to python-single-r1 class
04 Mar 2011; Brent Baude <ranger@gentoo.org> tuxmathscrabble-7.4.ebuild:
stable ppc, bug 353821
diff --git a/games-kids/tuxmathscrabble/tuxmathscrabble-7.4-r1.ebuild b/games-kids/tuxmathscrabble/tuxmathscrabble-7.4-r1.ebuild
new file mode 100644
index 000000000000..b673779217b5
--- /dev/null
+++ b/games-kids/tuxmathscrabble/tuxmathscrabble-7.4-r1.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-kids/tuxmathscrabble/tuxmathscrabble-7.4-r1.ebuild,v 1.1 2015/02/02 17:24:16 tupone Exp $
+
+EAPI=5
+PYTHON_COMPAT=( python2_7 )
+inherit eutils python-single-r1 multilib games
+
+MY_PN=TuxMathScrabble
+MY_P=${PN}-0.${PV}
+DESCRIPTION="math-version of the popular board game for children 4-10"
+HOMEPAGE="http://www.asymptopia.org/"
+SRC_URI="mirror://gentoo/${MY_P}.zip"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+
+CDEPEND="${PYTHON_DEPS}
+ dev-python/wxpython[${PYTHON_USEDEP}]"
+DEPEND="${CDEPEND}
+ app-arch/unzip"
+RDEPEND="${CDEPEND}
+ dev-python/pygame[${PYTHON_USEDEP}]"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+S=${WORKDIR}/${MY_P}
+
+pkg_setup() {
+ python-single-r1_pkg_setup
+ games_pkg_setup
+}
+
+src_prepare() {
+ rm -f $(find . -name '*.pyc')
+ epatch "${FILESDIR}"/${P}-gentoo.patch
+ sed -i \
+ -e "s:@GENTOO_DATADIR@:${GAMES_DATADIR}/${MY_PN}:" \
+ ${MY_PN}/tms.py \
+ .tms_config_master \
+ || die "sed failed"
+ python_fix_shebang .
+}
+
+src_install() {
+ newgamesbin ${PN}.py ${PN}
+
+ insinto $(python_get_sitedir)
+ doins -r ${MY_PN}
+
+ insinto "${GAMES_DATADIR}"/${MY_PN}
+ doins -r .tms_config_master Font
+
+ python_optimize
+
+ newicon tms.ico ${PN}.ico
+ make_desktop_entry ${PN} ${PN} /usr/share/pixmaps/${PN}.ico
+
+ dodoc CHANGES README
+ prepgamesdirs
+}