summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeremy Olexa <darkside@gentoo.org>2009-04-12 04:50:44 +0000
committerJeremy Olexa <darkside@gentoo.org>2009-04-12 04:50:44 +0000
commit92c48261f719e3d83faee4a77d0a5ef8b14a8c6c (patch)
treeabf3014a5436e634663c5505b27763dd26560613 /games-misc/cowsay
parentrevision bump to force installation of a new init script that is compatible w... (diff)
downloadgentoo-2-92c48261f719e3d83faee4a77d0a5ef8b14a8c6c.tar.gz
gentoo-2-92c48261f719e3d83faee4a77d0a5ef8b14a8c6c.tar.bz2
gentoo-2-92c48261f719e3d83faee4a77d0a5ef8b14a8c6c.zip
Revision bump to no longer install bash-completion module. A more up to date and maintained file is shipped with upstream >=bash-completion-1.0.
(Portage version: 2.1.6.11/cvs/Linux x86_64)
Diffstat (limited to 'games-misc/cowsay')
-rw-r--r--games-misc/cowsay/ChangeLog10
-rw-r--r--games-misc/cowsay/cowsay-3.03-r2.ebuild40
2 files changed, 48 insertions, 2 deletions
diff --git a/games-misc/cowsay/ChangeLog b/games-misc/cowsay/ChangeLog
index c850da7f0c93..acb88680c2a0 100644
--- a/games-misc/cowsay/ChangeLog
+++ b/games-misc/cowsay/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for games-misc/cowsay
-# Copyright 2002-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-misc/cowsay/ChangeLog,v 1.26 2008/08/08 20:47:10 mr_bones_ Exp $
+# Copyright 2002-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/games-misc/cowsay/ChangeLog,v 1.27 2009/04/12 04:50:44 darkside Exp $
+
+*cowsay-3.03-r2 (12 Apr 2009)
+
+ 12 Apr 2009; Jeremy Olexa <darkside@gentoo.org> +cowsay-3.03-r2.ebuild:
+ Revision bump to no longer install bash-completion module. A more up to date
+ and maintained file is shipped with upstream >=bash-completion-1.0.
08 Aug 2008; Michael Sterrett <mr_bones_@gentoo.org> -cowsay-3.03.ebuild:
drop old; mips to ~
diff --git a/games-misc/cowsay/cowsay-3.03-r2.ebuild b/games-misc/cowsay/cowsay-3.03-r2.ebuild
new file mode 100644
index 000000000000..ec0e311feb2c
--- /dev/null
+++ b/games-misc/cowsay/cowsay-3.03-r2.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-misc/cowsay/cowsay-3.03-r2.ebuild,v 1.1 2009/04/12 04:50:44 darkside Exp $
+
+inherit eutils
+
+DESCRIPTION="configurable talking ASCII cow (and other characters)"
+HOMEPAGE="http://www.nog.net/~tony/warez/cowsay.shtml"
+SRC_URI="http://www.nog.net/~tony/warez/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE=""
+
+RDEPEND=">=dev-lang/perl-5"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ sed -i \
+ -e '1 c\#!/usr/bin/perl'\
+ -e 's/\$version/\$VERSION/g'\
+ -e "s:%PREFIX%/share/cows:/usr/share/${P}/cows:" \
+ -e '/getopts/ i\$Getopt::Std::STANDARD_HELP_VERSION=1;' cowsay \
+ || die "sed cowsay failed"
+ sed -i \
+ -e "s|%PREFIX%/share/cows|/usr/share/${P}/cows|" cowsay.1 \
+ || die "sed cowsay.1 failed"
+ epatch "${FILESDIR}/${P}"-tongue.patch
+}
+
+src_install() {
+ dobin cowsay || die "dobin failed"
+ doman cowsay.1
+ dosym cowsay /usr/bin/cowthink
+ dosym cowsay.1 /usr/share/man/man1/cowthink.1
+ dodir /usr/share/${P}/cows
+ cp -r cows "${D}"/usr/share/${P}/ || die "cp failed"
+}