summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJulian Ospald <hasufell@gentoo.org>2014-08-06 20:27:07 +0000
committerJulian Ospald <hasufell@gentoo.org>2014-08-06 20:27:07 +0000
commitb94bf4eec28fc6ee8dcf5d34a29040beebfd416f (patch)
treea561efafa5e598d2ca50a4e008e847467742f7f5 /games-misc
parentarm stable, bug #515234 (diff)
downloadgentoo-2-b94bf4eec28fc6ee8dcf5d34a29040beebfd416f.tar.gz
gentoo-2-b94bf4eec28fc6ee8dcf5d34a29040beebfd416f.tar.bz2
gentoo-2-b94bf4eec28fc6ee8dcf5d34a29040beebfd416f.zip
version bump
(Portage version: 2.2.10/cvs/Linux x86_64, signed Manifest commit with key BDEED020)
Diffstat (limited to 'games-misc')
-rw-r--r--games-misc/dont-starve/ChangeLog9
-rw-r--r--games-misc/dont-starve/dont-starve-2.ebuild62
2 files changed, 69 insertions, 2 deletions
diff --git a/games-misc/dont-starve/ChangeLog b/games-misc/dont-starve/ChangeLog
index 5124372d59b3..92055a95e917 100644
--- a/games-misc/dont-starve/ChangeLog
+++ b/games-misc/dont-starve/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for games-misc/dont-starve
-# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-misc/dont-starve/ChangeLog,v 1.2 2013/12/01 23:08:40 hasufell Exp $
+# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/games-misc/dont-starve/ChangeLog,v 1.3 2014/08/06 20:27:07 hasufell Exp $
+
+*dont-starve-2 (06 Aug 2014)
+
+ 06 Aug 2014; Julian Ospald <hasufell@gentoo.org> +dont-starve-2.ebuild:
+ version bump
01 Dec 2013; Julian Ospald <hasufell@gentoo.org> dont-starve-1.ebuild:
fix QA_PREBUILT
diff --git a/games-misc/dont-starve/dont-starve-2.ebuild b/games-misc/dont-starve/dont-starve-2.ebuild
new file mode 100644
index 000000000000..e41031d12251
--- /dev/null
+++ b/games-misc/dont-starve/dont-starve-2.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-misc/dont-starve/dont-starve-2.ebuild,v 1.1 2014/08/06 20:27:07 hasufell Exp $
+
+EAPI=5
+
+inherit eutils games
+
+DESCRIPTION="Wilderness survival game full of science and magic"
+HOMEPAGE="http://www.dontstarvegame.com/"
+SRC_URI="amd64? ( dontstarve_x64_july21.tar.gz )
+ x86? ( dontstarve_x32_july21.tar.gz )"
+
+LICENSE="all-rights-reserved"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+RESTRICT="fetch bindist splitdebug"
+
+MYGAMEDIR=${GAMES_PREFIX_OPT}/${PN}
+QA_PREBUILT="${MYGAMEDIR#/}/bin/dontstarve"
+if [[ $ARCH == amd64 ]] ; then
+ QA_PREBUILT="${QA_PREBUILT}
+ ${MYGAMEDIR#/}/bin/lib64/*"
+elif [[ ${ARCH} == x86 ]] ; then
+ QA_PREBUILT="${QA_PREBUILT}
+ ${MYGAMEDIR#/}/bin/lib32/*"
+fi
+
+RDEPEND="net-misc/curl
+ virtual/opengl"
+
+S=${WORKDIR}/dontstarve
+
+pkg_nofetch() {
+ einfo
+ einfo "Please buy & download \"${SRC_URI}\" from:"
+ einfo " ${HOMEPAGE}"
+ einfo "and move/link it to \"${DISTDIR}\""
+ einfo
+}
+
+src_install() {
+ local libdir=lib$(usex amd64 "64" "32")
+
+ insinto "${MYGAMEDIR}"
+ doins -r data mods
+
+ exeinto "${MYGAMEDIR}"/bin
+ doexe bin/dontstarve
+ exeinto "${MYGAMEDIR}"/bin/${libdir}
+ doexe bin/${libdir}/libfmod*
+ # unbundling libsdl2 breaks the menu, so you cannot start the game
+ doexe bin/${libdir}/libSDL2*
+
+ games_make_wrapper ${PN} "./dontstarve" "${MYGAMEDIR}/bin" "${MYGAMEDIR}/bin/${libdir}"
+ make_desktop_entry ${PN}
+
+ doicon dontstarve.xpm
+
+ prepgamesdirs
+}