summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTristan Heaven <nyhm@gentoo.org>2006-10-10 17:03:56 +0000
committerTristan Heaven <nyhm@gentoo.org>2006-10-10 17:03:56 +0000
commit78bca17ffd73adbbfb830f2f1d20548cf7d6147d (patch)
treefd7eb4d81f7f2cb6f45f0c41ac72fd6bc8cbba16 /games-mud/gnome-mud
parentStable on sparc wrt #149970 (diff)
downloadgentoo-2-78bca17ffd73adbbfb830f2f1d20548cf7d6147d.tar.gz
gentoo-2-78bca17ffd73adbbfb830f2f1d20548cf7d6147d.tar.bz2
gentoo-2-78bca17ffd73adbbfb830f2f1d20548cf7d6147d.zip
Fix gettext dependency
(Portage version: 2.1.2_pre2-r7)
Diffstat (limited to 'games-mud/gnome-mud')
-rw-r--r--games-mud/gnome-mud/ChangeLog7
-rw-r--r--games-mud/gnome-mud/files/digest-gnome-mud-0.10.72
-rw-r--r--games-mud/gnome-mud/gnome-mud-0.10.7.ebuild34
3 files changed, 23 insertions, 20 deletions
diff --git a/games-mud/gnome-mud/ChangeLog b/games-mud/gnome-mud/ChangeLog
index 454edb05ce8f..2e9ac4365137 100644
--- a/games-mud/gnome-mud/ChangeLog
+++ b/games-mud/gnome-mud/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for games-mud/gnome-mud
-# Copyright 2002-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-mud/gnome-mud/ChangeLog,v 1.19 2005/08/20 14:20:02 metalgod Exp $
+# Copyright 2002-2006 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/games-mud/gnome-mud/ChangeLog,v 1.20 2006/10/10 17:03:56 nyhm Exp $
+
+ 10 Oct 2006; Tristan Heaven <nyhm@gentoo.org> gnome-mud-0.10.7.ebuild:
+ Fix gettext dependency
20 Aug 2005; Luis Medinas <metalgod@gentoo.org> gnome-mud-0.10.7.ebuild:
Added ~amd64 keywords.
diff --git a/games-mud/gnome-mud/files/digest-gnome-mud-0.10.7 b/games-mud/gnome-mud/files/digest-gnome-mud-0.10.7
index 099f5f90193e..39309b0a323e 100644
--- a/games-mud/gnome-mud/files/digest-gnome-mud-0.10.7
+++ b/games-mud/gnome-mud/files/digest-gnome-mud-0.10.7
@@ -1 +1,3 @@
MD5 1198ab9466435a5cd30f1e47bbf6f8fe gnome-mud-0.10.7.tar.bz2 560320
+RMD160 50bfc55e3550775906e77d67c33ba4070781bc7d gnome-mud-0.10.7.tar.bz2 560320
+SHA256 0380959be9f06a36945ee0fe55741f8d7b5f4ce541d7e2f791f74c098704a490 gnome-mud-0.10.7.tar.bz2 560320
diff --git a/games-mud/gnome-mud/gnome-mud-0.10.7.ebuild b/games-mud/gnome-mud/gnome-mud-0.10.7.ebuild
index df53f5b88b53..4f078cc49304 100644
--- a/games-mud/gnome-mud/gnome-mud-0.10.7.ebuild
+++ b/games-mud/gnome-mud/gnome-mud-0.10.7.ebuild
@@ -1,17 +1,15 @@
-# Copyright 1999-2005 Gentoo Foundation
+# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-mud/gnome-mud/gnome-mud-0.10.7.ebuild,v 1.2 2005/08/20 14:20:02 metalgod Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-mud/gnome-mud/gnome-mud-0.10.7.ebuild,v 1.3 2006/10/10 17:03:56 nyhm Exp $
-inherit games gnome2
+inherit gnome2 games
DESCRIPTION="GNOME MUD client"
HOMEPAGE="http://amcl.sourceforge.net/"
-SRC_URI="mirror://gnome/sources/${PN}/0.10/${P}.tar.bz2"
LICENSE="GPL-2"
-KEYWORDS="~amd64 ~ppc x86"
SLOT="0"
-
+KEYWORDS="~amd64 ~ppc x86"
IUSE="python zlib"
RDEPEND="=x11-libs/gtk+-2*
@@ -20,23 +18,23 @@ RDEPEND="=x11-libs/gtk+-2*
>=gnome-base/libglade-2.0.1
>=x11-libs/vte-0.10.26
dev-perl/XML-Parser
- python? ( >=dev-python/pygtk-1.99.13 )
- zlib? ( sys-libs/zlib )"
-
+ virtual/libintl
+ python? ( >=dev-python/pygtk-1.99.13 )"
DEPEND="${RDEPEND}
dev-util/pkgconfig
>=dev-util/intltool-0.23
>=sys-devel/gettext-0.11.5
app-text/scrollkeeper"
-pkg_setup() {
- use python || G2CONF="${G2CONF} --without-python"
- G2CONF="${G2CONF} `use_enable zlib mccp`"
-
- DOCS="AUTHORS BUGS ChangeLog NEWS PLUGIN.API README ROADMAP"
+src_compile() {
+ gnome2_src_compile \
+ --enable-mapper \
+ $(use_with python) \
+ $(use_enable zlib mccp)
}
src_install() {
+ DOCS="AUTHORS ChangeLog NEWS PLUGIN.API README ROADMAP" \
gnome2_src_install
# plugin directory
@@ -52,9 +50,9 @@ pkg_postinst() {
gnome2_pkg_postinst
games_pkg_postinst
echo
- einfo "For proper plugin operation, please create ~/.gnome-mud/plugins/"
- einfo "if that directory doesn't already exist."
- einfo "The command to do that is:"
- einfo " mkdir -p ~/.gnome-mud/plugins/"
+ elog "For proper plugin operation, please create ~/.gnome-mud/plugins/"
+ elog "if that directory doesn't already exist."
+ elog "The command to do that is:"
+ elog " mkdir -p ~/.gnome-mud/plugins/"
echo
}