summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2009-02-28 22:46:04 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2009-02-28 22:46:04 +0000
commitdabd3bba679d13eb82a7c60cd87e199c3277d21f (patch)
tree999c0d6285b2a48ea817d38836485df5ab311ba4 /games-mud
parentBug #259977: apply the automake patch so that older 4.1 still compiles. (diff)
downloadgentoo-2-dabd3bba679d13eb82a7c60cd87e199c3277d21f.tar.gz
gentoo-2-dabd3bba679d13eb82a7c60cd87e199c3277d21f.tar.bz2
gentoo-2-dabd3bba679d13eb82a7c60cd87e199c3277d21f.zip
version bump
(Portage version: 2.1.6.7/cvs/Linux i686)
Diffstat (limited to 'games-mud')
-rw-r--r--games-mud/gnome-mud/ChangeLog8
-rw-r--r--games-mud/gnome-mud/gnome-mud-0.11.2.ebuild57
2 files changed, 64 insertions, 1 deletions
diff --git a/games-mud/gnome-mud/ChangeLog b/games-mud/gnome-mud/ChangeLog
index 64a4bb049bb8..1f4a0917f9c7 100644
--- a/games-mud/gnome-mud/ChangeLog
+++ b/games-mud/gnome-mud/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for games-mud/gnome-mud
# Copyright 2002-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-mud/gnome-mud/ChangeLog,v 1.23 2009/02/17 16:53:59 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-mud/gnome-mud/ChangeLog,v 1.24 2009/02/28 22:46:04 mr_bones_ Exp $
+
+*gnome-mud-0.11.2 (28 Feb 2009)
+
+ 28 Feb 2009; Michael Sterrett <mr_bones_@gentoo.org>
+ +gnome-mud-0.11.2.ebuild:
+ version bump
*gnome-mud-0.11.1 (17 Feb 2009)
diff --git a/games-mud/gnome-mud/gnome-mud-0.11.2.ebuild b/games-mud/gnome-mud/gnome-mud-0.11.2.ebuild
new file mode 100644
index 000000000000..854b3a1ecc5c
--- /dev/null
+++ b/games-mud/gnome-mud/gnome-mud-0.11.2.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-mud/gnome-mud/gnome-mud-0.11.2.ebuild,v 1.1 2009/02/28 22:46:04 mr_bones_ Exp $
+
+EAPI=2
+inherit gnome2 games
+
+DESCRIPTION="GNOME MUD client"
+HOMEPAGE="http://live.gnome.org/GnomeMud"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="gstreamer"
+
+RDEPEND="x11-libs/gtk+:2
+ >=gnome-base/libglade-2.0.1:2.0
+ >=x11-libs/vte-0.11
+ gstreamer? ( media-libs/gstreamer )
+ dev-perl/XML-Parser
+ dev-libs/libpcre
+ net-libs/gnet:2
+ virtual/libintl"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig
+ >=dev-util/intltool-0.23
+ >=sys-devel/gettext-0.11.5
+ app-text/scrollkeeper"
+
+src_configure() {
+ gnome2_src_configure \
+ --disable-dependency-tracking \
+ --bindir="${GAMES_BINDIR}" \
+ $(use_enable gstreamer)
+}
+
+src_install() {
+ DOCS="AUTHORS BUGS ChangeLog NEWS PLUGIN.API README ROADMAP" \
+ gnome2_src_install
+ prepgamesdirs
+}
+
+pkg_preinst() {
+ gnome2_pkg_preinst
+ games_pkg_preinst
+}
+
+pkg_postinst() {
+ gnome2_pkg_postinst
+ games_pkg_postinst
+ echo
+ elog "For proper plugin operation, please create ~/.gnome-mud/plugins/"
+ elog "if that directory doesn't already exist."
+ elog "The command to do that is:"
+ elog " mkdir -p ~/.gnome-mud/plugins/"
+ echo
+}