summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTristan Heaven <nyhm@gentoo.org>2007-03-15 14:07:57 +0000
committerTristan Heaven <nyhm@gentoo.org>2007-03-15 14:07:57 +0000
commitc58078d2abee802509f7cbecd44ef224cdb90bf0 (patch)
treedcc6626114630b1f26d2ada55bf897ef3ec1ca3e /games-puzzle/4stattack
parentSome general clean-ups (see bug #170919). (diff)
downloadgentoo-2-c58078d2abee802509f7cbecd44ef224cdb90bf0.tar.gz
gentoo-2-c58078d2abee802509f7cbecd44ef224cdb90bf0.tar.bz2
gentoo-2-c58078d2abee802509f7cbecd44ef224cdb90bf0.zip
Install menu entry, bug #159770
(Portage version: 2.1.2.2)
Diffstat (limited to 'games-puzzle/4stattack')
-rw-r--r--games-puzzle/4stattack/4stattack-2.1.4.ebuild32
-rw-r--r--games-puzzle/4stattack/ChangeLog5
-rw-r--r--games-puzzle/4stattack/files/4stattack3
-rw-r--r--games-puzzle/4stattack/files/4stattack-2.1.4-gentoo.diff46
4 files changed, 25 insertions, 61 deletions
diff --git a/games-puzzle/4stattack/4stattack-2.1.4.ebuild b/games-puzzle/4stattack/4stattack-2.1.4.ebuild
index f89e16d49268..3f4fa773851f 100644
--- a/games-puzzle/4stattack/4stattack-2.1.4.ebuild
+++ b/games-puzzle/4stattack/4stattack-2.1.4.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2005 Gentoo Foundation
+# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-puzzle/4stattack/4stattack-2.1.4.ebuild,v 1.8 2005/09/26 18:13:01 wolf31o2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-puzzle/4stattack/4stattack-2.1.4.ebuild,v 1.9 2007/03/15 14:07:57 nyhm Exp $
inherit eutils games
@@ -10,33 +10,31 @@ SRC_URI="mirror://sourceforge/forcedattack/4stAttack-${PV}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
-KEYWORDS="x86 hppa ~amd64 ppc"
+KEYWORDS="~amd64 hppa ppc x86"
IUSE=""
-DEPEND=">=dev-python/pygame-1.5"
+RDEPEND="dev-python/pygame"
-S="${WORKDIR}/4stAttack-${PV}"
+S=${WORKDIR}/4stAttack-${PV}
src_unpack() {
unpack ${A}
- cd ${S}
+ cd "${S}"
# move the doc files aside so it's easier to install the game files
mv README.txt credits.txt changelog.txt ..
- rm GPL version~
+ rm -f GPL version~
- #This patch makes the game save settings in $HOME instead
- # of in /usr/share/games
- epatch ${FILESDIR}/${P}-gentoo.diff
+ # This patch makes the game save settings in $HOME
+ epatch "${FILESDIR}"/${P}-gentoo.diff
}
src_install() {
- dogamesbin ${FILESDIR}/4stattack
- dosed "s:GENTOO_DIR:${GAMES_DATADIR}/${PN}:" ${GAMES_BINDIR}/4stattack
- dodoc ../README.txt ../credits.txt ../changelog.txt
-
- dodir ${GAMES_DATADIR}/4stattack
- cp -R * ${D}/${GAMES_DATADIR}/4stattack/
-
+ games_make_wrapper ${PN} "python ${PN}.py" "${GAMES_DATADIR}"/${PN}
+ insinto "${GAMES_DATADIR}"/${PN}
+ doins -r * || die "doins failed"
+ newicon kde/icons/48x48/forcedattack2.png ${PN}.png
+ make_desktop_entry ${PN} "4st Attack 2"
+ dodoc ../{README.txt,credits.txt,changelog.txt}
prepgamesdirs
}
diff --git a/games-puzzle/4stattack/ChangeLog b/games-puzzle/4stattack/ChangeLog
index db3d8a04da8e..a6f3168dc0e9 100644
--- a/games-puzzle/4stattack/ChangeLog
+++ b/games-puzzle/4stattack/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for games-puzzle/4stattack
# Copyright 2000-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-puzzle/4stattack/ChangeLog,v 1.7 2007/02/08 21:17:48 wolf31o2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-puzzle/4stattack/ChangeLog,v 1.8 2007/03/15 14:07:57 nyhm Exp $
+
+ 15 Mar 2007; Tristan Heaven <nyhm@gentoo.org> 4stattack-2.1.4.ebuild:
+ Install menu entry, bug #159770
08 Feb 2007; Chris Gianelloni <wolf31o2@gentoo.org> ChangeLog:
Regenerate digest in Manifest2 format.
diff --git a/games-puzzle/4stattack/files/4stattack b/games-puzzle/4stattack/files/4stattack
deleted file mode 100644
index c0b761b3b44c..000000000000
--- a/games-puzzle/4stattack/files/4stattack
+++ /dev/null
@@ -1,3 +0,0 @@
-#!/bin/sh
-cd GENTOO_DIR
-exec /usr/bin/env python GENTOO_DIR/4stattack.py "${@}"
diff --git a/games-puzzle/4stattack/files/4stattack-2.1.4-gentoo.diff b/games-puzzle/4stattack/files/4stattack-2.1.4-gentoo.diff
index a6b77993dc00..be7d32ed3ff2 100644
--- a/games-puzzle/4stattack/files/4stattack-2.1.4-gentoo.diff
+++ b/games-puzzle/4stattack/files/4stattack-2.1.4-gentoo.diff
@@ -1,55 +1,21 @@
---- 4stAttack-2.1.4/4stattack.py 2002-10-01 07:38:03.000000000 -0700
-+++ new/4stattack.py 2003-07-24 22:11:34.000000000 -0700
+--- 4stattack.py
++++ 4stattack.py
@@ -28,6 +28,9 @@
images = None
screen = None
+f = os.path.expanduser('~/.4stattackrc')
+if not os.path.exists(f):
-+ os.system('cp /usr/share/games/4stattack/settings.ini %s' % f)
++ os.system('cp settings.ini %s' % f)
def playMusic(datadir):
if pygame.mixer.get_init():
-@@ -49,11 +52,11 @@
- screen = pygame.display.set_mode(resolution, FULLSCREEN)
- else:
- screen = pygame.display.set_mode(resolution)
--
-+
- pygame.display.set_caption('4st Attack 2')
- pygame.mouse.set_visible(1)
- pygame.display.init()
--
-+
- pygame.display.Info()
- return screen
-
-@@ -72,21 +75,21 @@
- pygame.quit()
- os._exit(0)
-
--def main():
-+def main():
- options = getOptions(sys.argv)
--
-+
+@@ -78,7 +81,7 @@
if options.has_key('-ini'):
ini_settings = IniSettings(options['-ini'])
else:
- ini_settings = IniSettings('settings.ini')
--
+ ini_settings = IniSettings(os.path.expanduser('~/.4stattackrc'))
-+
+
settings = ini_settings.settings
--
-+
- datadir = settings['path']['data']
--
-+
- if settings['sound']['music'] == 'yes':
- playMusic(datadir)
--
-+
- resolution = settings['video']['resolution']
- res = string.split(resolution, 'x')
- screen = setDisplay((int(res[0]), int(res[1])), settings['video']['fullscreen'])
+