summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2009-02-13 19:04:18 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2009-02-13 19:04:18 +0000
commit07e9a09ee3a1dc80321412dd4debf1a7c2ad219e (patch)
tree2c699303e391cd4f38b01c8c15d2734a4d7c4994 /games-puzzle/fish-fillets
parentChange glibc mask comment. Crikey we have a lot of whiners. (diff)
downloadgentoo-2-07e9a09ee3a1dc80321412dd4debf1a7c2ad219e.tar.gz
gentoo-2-07e9a09ee3a1dc80321412dd4debf1a7c2ad219e.tar.bz2
gentoo-2-07e9a09ee3a1dc80321412dd4debf1a7c2ad219e.zip
version bump (bug #258868)
(Portage version: 2.1.6.4/cvs/Linux 2.6.28.1 i686)
Diffstat (limited to 'games-puzzle/fish-fillets')
-rw-r--r--games-puzzle/fish-fillets/ChangeLog10
-rw-r--r--games-puzzle/fish-fillets/files/fish-fillets-0.8.1-gcc43.patch38
-rw-r--r--games-puzzle/fish-fillets/fish-fillets-0.8.1.ebuild58
3 files changed, 104 insertions, 2 deletions
diff --git a/games-puzzle/fish-fillets/ChangeLog b/games-puzzle/fish-fillets/ChangeLog
index cf8f5feeb55f..cf49b5e45b1a 100644
--- a/games-puzzle/fish-fillets/ChangeLog
+++ b/games-puzzle/fish-fillets/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for games-puzzle/fish-fillets
-# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-puzzle/fish-fillets/ChangeLog,v 1.33 2008/06/25 19:07:15 nixnut Exp $
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/games-puzzle/fish-fillets/ChangeLog,v 1.34 2009/02/13 19:04:18 mr_bones_ Exp $
+
+*fish-fillets-0.8.1 (13 Feb 2009)
+
+ 13 Feb 2009; Michael Sterrett <mr_bones_@gentoo.org>
+ +files/fish-fillets-0.8.1-gcc43.patch, +fish-fillets-0.8.1.ebuild:
+ version bump (bug #258868)
25 Jun 2008; nixnut <nixnut@gentoo.org> fish-fillets-0.8.0.ebuild:
Stable on ppc wrt bug 229141
diff --git a/games-puzzle/fish-fillets/files/fish-fillets-0.8.1-gcc43.patch b/games-puzzle/fish-fillets/files/fish-fillets-0.8.1-gcc43.patch
new file mode 100644
index 000000000000..19b7ab86c895
--- /dev/null
+++ b/games-puzzle/fish-fillets/files/fish-fillets-0.8.1-gcc43.patch
@@ -0,0 +1,38 @@
+diff -ru fillets-ng-0.8.1.orig/src/gengine/OptionAgent.cpp fillets-ng-0.8.1/src/gengine/OptionAgent.cpp
+--- fillets-ng-0.8.1.orig/src/gengine/OptionAgent.cpp 2008-12-29 05:43:40.000000000 -0500
++++ fillets-ng-0.8.1/src/gengine/OptionAgent.cpp 2009-02-13 13:35:13.000000000 -0500
+@@ -23,8 +23,8 @@
+ #include "UnknownMsgException.h"
+ #include "minmax.h"
+
+-#include <stdlib.h> //getenv
+-#include <string.h> //strlen
++#include <cstdlib> //getenv
++#include <cstring> //strlen
+ #include <locale.h> //setlocale
+
+ #ifndef LC_MESSAGES
+diff -ru fillets-ng-0.8.1.orig/src/gengine/StringTool.cpp fillets-ng-0.8.1/src/gengine/StringTool.cpp
+--- fillets-ng-0.8.1.orig/src/gengine/StringTool.cpp 2008-08-10 06:00:15.000000000 -0400
++++ fillets-ng-0.8.1/src/gengine/StringTool.cpp 2009-02-13 13:35:29.000000000 -0500
+@@ -8,7 +8,7 @@
+ */
+ #include "StringTool.h"
+
+-#include <stdlib.h>
++#include <cstdlib>
+ #include <sstream>
+
+ //-----------------------------------------------------------------
+diff -ru fillets-ng-0.8.1.orig/src/level/Landslip.cpp fillets-ng-0.8.1/src/level/Landslip.cpp
+--- fillets-ng-0.8.1.orig/src/level/Landslip.cpp 2008-08-10 06:00:29.000000000 -0400
++++ fillets-ng-0.8.1/src/level/Landslip.cpp 2009-02-13 13:36:06.000000000 -0500
+@@ -11,7 +11,7 @@
+ #include "Rules.h"
+ #include "minmax.h"
+
+-#include <string.h>
++#include <cstring>
+
+ //-----------------------------------------------------------------
+ Landslip::Landslip(const ModelList &models)
diff --git a/games-puzzle/fish-fillets/fish-fillets-0.8.1.ebuild b/games-puzzle/fish-fillets/fish-fillets-0.8.1.ebuild
new file mode 100644
index 000000000000..78fc9a56c34d
--- /dev/null
+++ b/games-puzzle/fish-fillets/fish-fillets-0.8.1.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-puzzle/fish-fillets/fish-fillets-0.8.1.ebuild,v 1.1 2009/02/13 19:04:18 mr_bones_ Exp $
+
+EAPI=2
+inherit autotools eutils games
+
+DATA_PV="0.8.1"
+DESCRIPTION="Underwater puzzle game - find a safe way out"
+HOMEPAGE="http://fillets.sourceforge.net/"
+SRC_URI="mirror://sourceforge/fillets/fillets-ng-${PV}.tar.gz
+ mirror://sourceforge/fillets/fillets-ng-data-${DATA_PV}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+
+RDEPEND=">=media-libs/libsdl-1.2
+ >=media-libs/sdl-mixer-1.2.5[vorbis]
+ >=media-libs/sdl-image-1.2.2[png]
+ x11-libs/libX11
+ media-libs/sdl-ttf
+ dev-libs/fribidi
+ >=dev-lang/lua-5"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig"
+
+S=${WORKDIR}/fillets-ng-${PV}
+
+src_prepare() {
+ epatch "${FILESDIR}/${P}-gcc43.patch"
+
+ #.mod was renamed to .fmod in lua 5.1.3 - bug #223271
+ sed -i \
+ -e 's/\.mod(/.fmod(/' \
+ $(grep -rl "\.mod\>" "${WORKDIR}"/fillets-ng-data-${DATA_PV}) \
+ || die "sed failed"
+ eautoreconf
+}
+
+src_configure() {
+ egamesconf \
+ --disable-dependency-tracking \
+ --datadir="${GAMES_DATADIR}/${PN}"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+ dodoc AUTHORS ChangeLog NEWS README TODO
+ insinto "${GAMES_DATADIR}/${PN}"
+ cd "${WORKDIR}"/fillets-ng-data-${DATA_PV} || die
+ rm -f COPYING
+ doins -r * || die "doins failed"
+ newicon images/icon.png fillets.png
+ make_desktop_entry fillets FishFillets fillets
+ prepgamesdirs
+}