summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2009-10-31 21:36:48 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2009-10-31 21:36:48 +0000
commit094b9de4a59333ead03b84bf589eb98f8a006c57 (patch)
treef5f3d1dbcc03f592d41359eceda4e0ef1206b094 /games-puzzle
parentVersion bump wrt #260016, thanks to BeteNoire for reporting. (diff)
downloadgentoo-2-094b9de4a59333ead03b84bf589eb98f8a006c57.tar.gz
gentoo-2-094b9de4a59333ead03b84bf589eb98f8a006c57.tar.bz2
gentoo-2-094b9de4a59333ead03b84bf589eb98f8a006c57.zip
respect my FLAGS
(Portage version: 2.1.6.13/cvs/Linux i686)
Diffstat (limited to 'games-puzzle')
-rw-r--r--games-puzzle/colorcode/colorcode-0.5.5.ebuild10
1 files changed, 9 insertions, 1 deletions
diff --git a/games-puzzle/colorcode/colorcode-0.5.5.ebuild b/games-puzzle/colorcode/colorcode-0.5.5.ebuild
index 9765a49954da..0452a2cab307 100644
--- a/games-puzzle/colorcode/colorcode-0.5.5.ebuild
+++ b/games-puzzle/colorcode/colorcode-0.5.5.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-puzzle/colorcode/colorcode-0.5.5.ebuild,v 1.1 2009/10/31 21:21:14 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-puzzle/colorcode/colorcode-0.5.5.ebuild,v 1.2 2009/10/31 21:36:48 mr_bones_ Exp $
EAPI=2
inherit eutils qt4 games
@@ -25,6 +25,14 @@ pkg_setup() {
qt4_pkg_setup
}
+src_prepare() {
+ sed -i \
+ -e '/FLAGS/d' \
+ ColorCode.pro \
+ || die "sed failed"
+ qt4_src_prepare
+}
+
src_configure() {
eqmake4 ${MY_PN}.pro
}