summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2009-08-10 21:23:49 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2009-08-10 21:23:49 +0000
commit68df41e1233cec9ae2c2b4c91ce338396da55f97 (patch)
tree3b3955da65d82287e61b29d7a23c04314bb8b6d1 /games-puzzle
parentMove from dev-perl to perl-core (diff)
downloadgentoo-2-68df41e1233cec9ae2c2b4c91ce338396da55f97.tar.gz
gentoo-2-68df41e1233cec9ae2c2b4c91ce338396da55f97.tar.bz2
gentoo-2-68df41e1233cec9ae2c2b4c91ce338396da55f97.zip
EAPI=2; build with gcc43
(Portage version: 2.1.6.13/cvs/Linux i686)
Diffstat (limited to 'games-puzzle')
-rw-r--r--games-puzzle/torrent/ChangeLog7
-rw-r--r--games-puzzle/torrent/torrent-0.8.2.ebuild12
2 files changed, 15 insertions, 4 deletions
diff --git a/games-puzzle/torrent/ChangeLog b/games-puzzle/torrent/ChangeLog
index 9ec428302324..5e0d05399009 100644
--- a/games-puzzle/torrent/ChangeLog
+++ b/games-puzzle/torrent/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for games-puzzle/torrent
-# Copyright 2000-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-puzzle/torrent/ChangeLog,v 1.7 2006/08/15 15:06:23 tcort Exp $
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/games-puzzle/torrent/ChangeLog,v 1.8 2009/08/10 21:23:49 mr_bones_ Exp $
+
+ 10 Aug 2009; Michael Sterrett <mr_bones_@gentoo.org> torrent-0.8.2.ebuild:
+ EAPI=2; build with gcc43
15 Aug 2006; Thomas Cort <tcort@gentoo.org> torrent-0.8.2.ebuild:
Stable on amd64 wrt Bug #143961
diff --git a/games-puzzle/torrent/torrent-0.8.2.ebuild b/games-puzzle/torrent/torrent-0.8.2.ebuild
index fcc78d8cd6bf..0b1de2df34e1 100644
--- a/games-puzzle/torrent/torrent-0.8.2.ebuild
+++ b/games-puzzle/torrent/torrent-0.8.2.ebuild
@@ -1,7 +1,8 @@
-# Copyright 1999-2006 Gentoo Foundation
+# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-puzzle/torrent/torrent-0.8.2.ebuild,v 1.5 2006/08/15 15:06:23 tcort Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-puzzle/torrent/torrent-0.8.2.ebuild,v 1.6 2009/08/10 21:23:49 mr_bones_ Exp $
+EAPI=2
inherit games
DESCRIPTION="Match rising tiles to score as many points as possible before the tiles touch the top of the board"
@@ -18,6 +19,13 @@ DEPEND=">=media-libs/libsdl-1.2.4
>=media-libs/sdl-image-1.2
media-libs/sdl-ttf"
+src_prepare() {
+ sed -i \
+ -e 's/inline void SE_CheckEvents/void SE_CheckEvents/' \
+ src/torrent.c \
+ || die "sed failed"
+}
+
src_install() {
make DESTDIR="${D}" install || die "make install failed"
dodoc ChangeLog