summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2004-06-10 05:34:19 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2004-06-10 05:34:19 +0000
commitb75a8fac0c1cedf2c629d4bbb43018c8782d2f5d (patch)
treeea57450e6b2149f3914c7b7e422616fd0b12c326 /games-puzzle
parentturn off typo #53483 (diff)
downloadgentoo-2-b75a8fac0c1cedf2c629d4bbb43018c8782d2f5d.tar.gz
gentoo-2-b75a8fac0c1cedf2c629d4bbb43018c8782d2f5d.tar.bz2
gentoo-2-b75a8fac0c1cedf2c629d4bbb43018c8782d2f5d.zip
integrated gcc 3.4 patch from Felix Riemann (bug #53435); added nls support
Diffstat (limited to 'games-puzzle')
-rw-r--r--games-puzzle/pingus/ChangeLog8
-rw-r--r--games-puzzle/pingus/files/0.6.0-gcc3.patch3
-rw-r--r--games-puzzle/pingus/pingus-0.6.0-r1.ebuild7
3 files changed, 12 insertions, 6 deletions
diff --git a/games-puzzle/pingus/ChangeLog b/games-puzzle/pingus/ChangeLog
index a993fd708a50..3370f248523f 100644
--- a/games-puzzle/pingus/ChangeLog
+++ b/games-puzzle/pingus/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for games-puzzle/pingus
-# Copyright 2000-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-puzzle/pingus/ChangeLog,v 1.2 2003/09/10 15:48:01 vapier Exp $
+# Copyright 2000-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/games-puzzle/pingus/ChangeLog,v 1.3 2004/06/10 05:34:19 mr_bones_ Exp $
+
+ 09 Jun 2004; Michael Sterrett <mr_bones_@gentoo.org> pingus-0.6.0-r1.ebuild,
+ files/0.6.0-gcc3.patch:
+ integrated gcc 3.4 patch from Felix Riemann (bug #53435); added nls support
*pingus-0.6.0-r1 (16 Jul 2003)
diff --git a/games-puzzle/pingus/files/0.6.0-gcc3.patch b/games-puzzle/pingus/files/0.6.0-gcc3.patch
index 73c49513006e..cb1b56615447 100644
--- a/games-puzzle/pingus/files/0.6.0-gcc3.patch
+++ b/games-puzzle/pingus/files/0.6.0-gcc3.patch
@@ -100,11 +100,12 @@ diff -ur -x '*Po' pingus-0.6.0.orig/src/worldmap/dot.cxx pingus-0.6.0/src/worldm
diff -ur -x '*Po' pingus-0.6.0.orig/src/worldmap/graph.hxx pingus-0.6.0/src/worldmap/graph.hxx
--- pingus-0.6.0.orig/src/worldmap/graph.hxx 2003-09-10 01:01:17.037126232 -0400
+++ pingus-0.6.0/src/worldmap/graph.hxx 2003-09-10 01:07:31.004274584 -0400
-@@ -20,6 +20,7 @@
+@@ -20,6 +20,8 @@
#ifndef HEADER_GRAPH_HXX
#define HEADER_GRAPH_HXX
+#include <assert.h>
#include <algorithm>
#include <vector>
++#include <iostream>
diff --git a/games-puzzle/pingus/pingus-0.6.0-r1.ebuild b/games-puzzle/pingus/pingus-0.6.0-r1.ebuild
index a76cdb38352e..041e6ea1d7b9 100644
--- a/games-puzzle/pingus/pingus-0.6.0-r1.ebuild
+++ b/games-puzzle/pingus/pingus-0.6.0-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-puzzle/pingus/pingus-0.6.0-r1.ebuild,v 1.4 2004/05/12 09:02:46 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-puzzle/pingus/pingus-0.6.0-r1.ebuild,v 1.5 2004/06/10 05:34:19 mr_bones_ Exp $
inherit eutils games
@@ -11,7 +11,7 @@ SRC_URI="http://pingus.seul.org/files/${P}.tar.bz2"
KEYWORDS="x86"
LICENSE="GPL-2"
SLOT="0"
-IUSE="opengl"
+IUSE="nls opengl"
DEPEND=">=media-libs/hermes-1.3.2-r2
=dev-games/clanlib-0.6.5*
@@ -31,6 +31,7 @@ src_compile() {
egamesconf \
--with-bindir="${GAMES_BINDIR}" \
--with-datadir="${GAMES_DATADIR_BASE}" \
+ $(use_enable nls) \
$(use_with opengl clanGL) \
|| die
emake || die "emake failed"
@@ -41,7 +42,7 @@ src_install() {
# pos install process ... FIXME
mv ${D}/usr/games/{games,bin}
cd ${D}/usr/share/games
- mv locale ../
+ use nls && mv locale ../
mv games/pingus .
rm -rf games
# end pos install process