summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTristan Heaven <nyhm@gentoo.org>2008-01-15 10:27:47 +0000
committerTristan Heaven <nyhm@gentoo.org>2008-01-15 10:27:47 +0000
commitc6ffa8fb40c740d8181292a1e4784722bf9a1ee3 (patch)
tree2c115d216e02a495e83392fe032ed4eb698c963e /games-puzzle
parentstable x86, bug 205925 (diff)
downloadgentoo-2-c6ffa8fb40c740d8181292a1e4784722bf9a1ee3.tar.gz
gentoo-2-c6ffa8fb40c740d8181292a1e4784722bf9a1ee3.tar.bz2
gentoo-2-c6ffa8fb40c740d8181292a1e4784722bf9a1ee3.zip
USE=-ipv6 compilation fix by Andrew Church, bug #203514
(Portage version: 2.1.4)
Diffstat (limited to 'games-puzzle')
-rw-r--r--games-puzzle/tetrinet/ChangeLog8
-rw-r--r--games-puzzle/tetrinet/files/tetrinet-0.11-no-ipv6.patch11
-rw-r--r--games-puzzle/tetrinet/tetrinet-0.11.ebuild11
3 files changed, 22 insertions, 8 deletions
diff --git a/games-puzzle/tetrinet/ChangeLog b/games-puzzle/tetrinet/ChangeLog
index 46c8a8bb96c3..a895e48acfb3 100644
--- a/games-puzzle/tetrinet/ChangeLog
+++ b/games-puzzle/tetrinet/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for games-puzzle/tetrinet
-# Copyright 2000-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-puzzle/tetrinet/ChangeLog,v 1.7 2007/02/22 01:16:54 peper Exp $
+# Copyright 2000-2008 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/games-puzzle/tetrinet/ChangeLog,v 1.8 2008/01/15 10:27:47 nyhm Exp $
+
+ 15 Jan 2008; Tristan Heaven <nyhm@gentoo.org>
+ +files/tetrinet-0.11-no-ipv6.patch, tetrinet-0.11.ebuild:
+ USE=-ipv6 compilation fix by Andrew Church, bug #203514
22 Feb 2007; Piotr Jaroszyński <peper@gentoo.org> ChangeLog:
Transition to Manifest2.
diff --git a/games-puzzle/tetrinet/files/tetrinet-0.11-no-ipv6.patch b/games-puzzle/tetrinet/files/tetrinet-0.11-no-ipv6.patch
new file mode 100644
index 000000000000..5b0cb82f75c0
--- /dev/null
+++ b/games-puzzle/tetrinet/files/tetrinet-0.11-no-ipv6.patch
@@ -0,0 +1,11 @@
+--- sockets.c
++++ sockets.c
+@@ -188,7 +188,7 @@
+ return -1;
+ }
+ if (ipbuf)
+- memcpy(retbuf, &sa.sin_addr, 4);
++ memcpy(ipbuf, &sa.sin_addr, 4);
+ #endif
+
+ return sock;
diff --git a/games-puzzle/tetrinet/tetrinet-0.11.ebuild b/games-puzzle/tetrinet/tetrinet-0.11.ebuild
index 9b4d3e26923c..508b2690f45d 100644
--- a/games-puzzle/tetrinet/tetrinet-0.11.ebuild
+++ b/games-puzzle/tetrinet/tetrinet-0.11.ebuild
@@ -1,8 +1,8 @@
-# Copyright 1999-2006 Gentoo Foundation
+# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-puzzle/tetrinet/tetrinet-0.11.ebuild,v 1.10 2006/12/06 17:27:19 wolf31o2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-puzzle/tetrinet/tetrinet-0.11.ebuild,v 1.11 2008/01/15 10:27:47 nyhm Exp $
-inherit flag-o-matic games
+inherit eutils flag-o-matic games
DESCRIPTION="console based tetrinet inc. standalone server"
HOMEPAGE="http://tetrinet.or.cz/"
@@ -10,17 +10,16 @@ SRC_URI="http://tetrinet.or.cz/download/${P}.tar.bz2"
LICENSE="as-is"
SLOT="0"
-KEYWORDS="x86 ~amd64 ppc"
+KEYWORDS="~amd64 ppc x86"
IUSE="ipv6"
RDEPEND=">=sys-libs/ncurses-5"
src_unpack() {
unpack ${A}
- return 0
cd "${S}"
+ epatch "${FILESDIR}"/${P}-no-ipv6.patch
- # for now, make sure IPv6 is always on #32860
use ipv6 && append-flags -DHAVE_IPV6
sed -i \
-e 's/-DHAVE_IPV6//' \