summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTristan Heaven <nyhm@gentoo.org>2009-06-13 18:13:11 +0000
committerTristan Heaven <nyhm@gentoo.org>2009-06-13 18:13:11 +0000
commitdb0f45b348906261bea9bc6989f5776b22386fe5 (patch)
treee23cff41e261663ee62b420e0b56e675facd76b9 /games-puzzle
parentFix building with glibc-2.10, bug #273494 (diff)
downloadgentoo-2-db0f45b348906261bea9bc6989f5776b22386fe5.tar.gz
gentoo-2-db0f45b348906261bea9bc6989f5776b22386fe5.tar.bz2
gentoo-2-db0f45b348906261bea9bc6989f5776b22386fe5.zip
Fix building with glibc-2.10, bug #273501
(Portage version: 2.2_rc33/cvs/Linux i686)
Diffstat (limited to 'games-puzzle')
-rw-r--r--games-puzzle/amoebax/ChangeLog8
-rw-r--r--games-puzzle/amoebax/amoebax-0.2.0.ebuild13
-rw-r--r--games-puzzle/amoebax/files/amoebax-0.2.0-glibc2.10.patch11
3 files changed, 24 insertions, 8 deletions
diff --git a/games-puzzle/amoebax/ChangeLog b/games-puzzle/amoebax/ChangeLog
index a281cbe6d834..d2781d24a58d 100644
--- a/games-puzzle/amoebax/ChangeLog
+++ b/games-puzzle/amoebax/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for games-puzzle/amoebax
-# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-puzzle/amoebax/ChangeLog,v 1.5 2008/06/26 10:05:37 coldwind Exp $
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/games-puzzle/amoebax/ChangeLog,v 1.6 2009/06/13 18:13:11 nyhm Exp $
+
+ 13 Jun 2009; Tristan Heaven <nyhm@gentoo.org> amoebax-0.2.0.ebuild,
+ +files/amoebax-0.2.0-glibc2.10.patch:
+ Fix building with glibc-2.10, bug #273501
26 Jun 2008; Santiago M. Mola <coldwind@gentoo.org> amoebax-0.2.0.ebuild:
amd64 stable wrt bug #229497
diff --git a/games-puzzle/amoebax/amoebax-0.2.0.ebuild b/games-puzzle/amoebax/amoebax-0.2.0.ebuild
index 0e8006680bcf..da22ddbd53d6 100644
--- a/games-puzzle/amoebax/amoebax-0.2.0.ebuild
+++ b/games-puzzle/amoebax/amoebax-0.2.0.ebuild
@@ -1,7 +1,8 @@
-# Copyright 1999-2008 Gentoo Foundation
+# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-puzzle/amoebax/amoebax-0.2.0.ebuild,v 1.5 2008/06/26 10:05:37 coldwind Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-puzzle/amoebax/amoebax-0.2.0.ebuild,v 1.6 2009/06/13 18:13:11 nyhm Exp $
+EAPI=2
inherit autotools eutils games
DESCRIPTION="a cute and addictive action-puzzle game, similar to tetris"
@@ -17,10 +18,10 @@ DEPEND="media-libs/libsdl
media-libs/sdl-image
media-libs/sdl-mixer"
-src_unpack() {
- unpack ${A}
- cd "${S}"
- epatch "${FILESDIR}"/${P}-gcc43.patch
+src_prepare() {
+ epatch \
+ "${FILESDIR}"/${P}-gcc43.patch \
+ "${FILESDIR}"/${P}-glibc2.10.patch
sed -i \
-e "/^SUBDIRS/s:doc ::" \
Makefile.am \
diff --git a/games-puzzle/amoebax/files/amoebax-0.2.0-glibc2.10.patch b/games-puzzle/amoebax/files/amoebax-0.2.0-glibc2.10.patch
new file mode 100644
index 000000000000..4dae207f418c
--- /dev/null
+++ b/games-puzzle/amoebax/files/amoebax-0.2.0-glibc2.10.patch
@@ -0,0 +1,11 @@
+--- src/binreloc.cxx
++++ src/binreloc.cxx
+@@ -744,7 +744,7 @@
+ if (path == (const char *) NULL)
+ return (char *) NULL;
+
+- end = strrchr (path, '/');
++ end = strrchr ((char *)path, '/');
+ if (end == (const char *) NULL)
+ return strdup (".");
+