summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChris Gianelloni <wolf31o2@gentoo.org>2006-01-24 20:35:43 +0000
committerChris Gianelloni <wolf31o2@gentoo.org>2006-01-24 20:35:43 +0000
commit3d5d610615bbf66c62b126d2d2d4beeabc33a226 (patch)
tree7c788a5a302d2cd682e7e29f7211c1bde1f0081e /games-roguelike/crossfire-client
parentWhitespace fix. (diff)
downloadgentoo-2-3d5d610615bbf66c62b126d2d2d4beeabc33a226.tar.gz
gentoo-2-3d5d610615bbf66c62b126d2d2d4beeabc33a226.tar.bz2
gentoo-2-3d5d610615bbf66c62b126d2d2d4beeabc33a226.zip
Fixed dependencies in 1.8.0 and allowed for no sound if USE is -alsa -oss on request in bug #96633.
(Portage version: 2.1_pre3-r1)
Diffstat (limited to 'games-roguelike/crossfire-client')
-rw-r--r--games-roguelike/crossfire-client/ChangeLog7
-rw-r--r--games-roguelike/crossfire-client/crossfire-client-1.7.1.ebuild7
-rw-r--r--games-roguelike/crossfire-client/crossfire-client-1.8.0.ebuild13
3 files changed, 18 insertions, 9 deletions
diff --git a/games-roguelike/crossfire-client/ChangeLog b/games-roguelike/crossfire-client/ChangeLog
index eb6eb9f5876b..b014b4b90bfb 100644
--- a/games-roguelike/crossfire-client/ChangeLog
+++ b/games-roguelike/crossfire-client/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for games-roguelike/crossfire-client
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-roguelike/crossfire-client/ChangeLog,v 1.12 2006/01/24 20:09:10 wolf31o2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-roguelike/crossfire-client/ChangeLog,v 1.13 2006/01/24 20:35:43 wolf31o2 Exp $
+
+ 24 Jan 2006; Chris Gianelloni <wolf31o2@gentoo.org>
+ crossfire-client-1.7.1.ebuild, crossfire-client-1.8.0.ebuild:
+ Fixed dependencies in 1.8.0 and allowed for no sound if USE is -alsa -oss on
+ request in bug #96633.
24 Jan 2006; Chris Gianelloni <wolf31o2@gentoo.org>
-files/1.5.0-errno.patch, -files/1.6.0-errno.patch,
diff --git a/games-roguelike/crossfire-client/crossfire-client-1.7.1.ebuild b/games-roguelike/crossfire-client/crossfire-client-1.7.1.ebuild
index e38bd702ad83..62a51be2c24a 100644
--- a/games-roguelike/crossfire-client/crossfire-client-1.7.1.ebuild
+++ b/games-roguelike/crossfire-client/crossfire-client-1.7.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-roguelike/crossfire-client/crossfire-client-1.7.1.ebuild,v 1.2 2006/01/24 20:09:10 wolf31o2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-roguelike/crossfire-client/crossfire-client-1.7.1.ebuild,v 1.3 2006/01/24 20:35:43 wolf31o2 Exp $
inherit games
@@ -11,7 +11,7 @@ SRC_URI="mirror://sourceforge/crossfire/${P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="ppc x86"
-IUSE="alsa gtk sdl"
+IUSE="alsa gtk oss sdl"
DEPEND="alsa? ( media-libs/alsa-lib )
gtk? ( =x11-libs/gtk+-1.2*
@@ -43,6 +43,9 @@ src_compile() {
if ! use alsa ; then
myconf="${myconf} --disable-alsa9 --disable-alsa"
fi
+ if ! use alsa && ! use oss ; then
+ myconf="${myconf} --disable-sound"
+ fi
egamesconf ${myconf} || die
emake -j1 -C sound-src || die "sound building failed"
emake || die "emake failed"
diff --git a/games-roguelike/crossfire-client/crossfire-client-1.8.0.ebuild b/games-roguelike/crossfire-client/crossfire-client-1.8.0.ebuild
index c945a106fc46..1f9294ab2925 100644
--- a/games-roguelike/crossfire-client/crossfire-client-1.8.0.ebuild
+++ b/games-roguelike/crossfire-client/crossfire-client-1.8.0.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-roguelike/crossfire-client/crossfire-client-1.8.0.ebuild,v 1.2 2006/01/24 20:09:10 wolf31o2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-roguelike/crossfire-client/crossfire-client-1.8.0.ebuild,v 1.3 2006/01/24 20:35:43 wolf31o2 Exp $
inherit games
@@ -11,15 +11,13 @@ SRC_URI="mirror://sourceforge/crossfire/${P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~ppc ~x86"
-IUSE="alsa gtk sdl"
+IUSE="alsa gtk oss sdl"
-DEPEND="virtual/x11
- alsa? ( media-libs/alsa-lib )
+DEPEND="alsa? ( media-libs/alsa-lib )
gtk? ( =x11-libs/gtk+-1.2*
dev-libs/glib
sdl? ( media-libs/libsdl
- media-libs/sdl-image )
- )
+ media-libs/sdl-image ) )
media-libs/libpng
sys-libs/zlib"
@@ -44,6 +42,9 @@ src_compile() {
if ! use alsa ; then
myconf="${myconf} --disable-alsa9 --disable-alsa"
fi
+ if ! use alsa && ! use oss ; then
+ myconf="${myconf} --disable-sound"
+ fi
egamesconf ${myconf} || die
emake -j1 -C sound-src || die "sound building failed"
emake || die "emake failed"