summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2004-02-01 18:46:03 +0000
committerMike Frysinger <vapier@gentoo.org>2004-02-01 18:46:03 +0000
commit3ebe4bfd9446f62c88aa4532f2715374099388a3 (patch)
tree1d32e26dccb88de0bf090b4bf1e70f83df73cc92 /games-roguelike/crossfire-client
parentAdded metadata. (Manifest recommit) (diff)
downloadgentoo-2-3ebe4bfd9446f62c88aa4532f2715374099388a3.tar.gz
gentoo-2-3ebe4bfd9446f62c88aa4532f2715374099388a3.tar.bz2
gentoo-2-3ebe4bfd9446f62c88aa4532f2715374099388a3.zip
ver bump
Diffstat (limited to 'games-roguelike/crossfire-client')
-rw-r--r--games-roguelike/crossfire-client/ChangeLog5
-rw-r--r--games-roguelike/crossfire-client/crossfire-client-1.6.1.ebuild44
-rw-r--r--games-roguelike/crossfire-client/files/digest-crossfire-client-1.6.11
3 files changed, 50 insertions, 0 deletions
diff --git a/games-roguelike/crossfire-client/ChangeLog b/games-roguelike/crossfire-client/ChangeLog
index 9da28e95fa21..c72ef6407a56 100644
--- a/games-roguelike/crossfire-client/ChangeLog
+++ b/games-roguelike/crossfire-client/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for games-roguelike/crossfire-client
# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
+*crossfire-client-1.6.1 (01 Feb 2004)
+
+ 01 Feb 2004; Mike Frysinger <vapier@gentoo.org> :
+ Version bump.
+
*crossfire-client-1.6.0 (25 Oct 2003)
25 Oct 2003; Mike Frysinger <vapier@gentoo.org> :
diff --git a/games-roguelike/crossfire-client/crossfire-client-1.6.1.ebuild b/games-roguelike/crossfire-client/crossfire-client-1.6.1.ebuild
new file mode 100644
index 000000000000..2d03a0568d8c
--- /dev/null
+++ b/games-roguelike/crossfire-client/crossfire-client-1.6.1.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-roguelike/crossfire-client/crossfire-client-1.6.1.ebuild,v 1.1 2004/02/01 18:46:03 vapier Exp $
+
+inherit games eutils
+
+DESCRIPTION="Client for the nethack-style but more in the line of UO"
+HOMEPAGE="http://crossfire.real-time.com/"
+SRC_URI="mirror://sourceforge/crossfire/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="x86 ppc"
+IUSE="sdl gnome gtk alsa"
+
+DEPEND="virtual/x11
+ sdl? ( media-libs/libsdl
+ media-libs/sdl-image )
+ gnome? ( gnome-base/gnome-libs
+ media-libs/gdk-pixbuf )
+ gtk? ( =x11-libs/gtk+-1* )
+ alsa? ( media-libs/alsa-lib )
+ media-libs/libpng"
+
+src_compile() {
+ # bugs in configure script so we cant use `use_enable`
+ local myconf=""
+ use gtk || myconf="${myconf} --disable-gtk"
+ use sdl || myconf="${myconf} --disable-sdl"
+ use alsa || myconf="${myconf} --disable-alsa"
+ has_version '>=media-libs/alsa-lib-0.9' && myconf="${myconf} --disable-alsa --disable-sound"
+# use gnome || myconf="${myconf} --disable-gnome"
+ egamesconf ${myconf} || die
+ make || die
+}
+
+src_install() {
+ egamesinstall mandir=${T} || die
+ use gtk && newman gtk/gcfclient.man gcfclient.6
+ use gnome && newman gnome/gnome-cfclient.man gnome-cfclient.6
+ newman x11/cfclient.man cfclient.6
+ dodoc CHANGES NOTES README TODO
+ prepgamesdirs
+}
diff --git a/games-roguelike/crossfire-client/files/digest-crossfire-client-1.6.1 b/games-roguelike/crossfire-client/files/digest-crossfire-client-1.6.1
new file mode 100644
index 000000000000..6e4c68cc48f8
--- /dev/null
+++ b/games-roguelike/crossfire-client/files/digest-crossfire-client-1.6.1
@@ -0,0 +1 @@
+MD5 609a44e079803bc48c966b1766a02863 crossfire-client-1.6.1.tar.gz 512603