summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJulian Ospald <hasufell@gentoo.org>2014-04-05 17:57:24 +0000
committerJulian Ospald <hasufell@gentoo.org>2014-04-05 17:57:24 +0000
commit049efa9a4d5bfd166666f09aa565e9b9f7ca9540 (patch)
tree52abd2972e4bf05fe4cc5b1b15e2f61e31fa41b8 /games-roguelike
parentRemove ree18 and ruby18 target. (diff)
downloadgentoo-2-049efa9a4d5bfd166666f09aa565e9b9f7ca9540.tar.gz
gentoo-2-049efa9a4d5bfd166666f09aa565e9b9f7ca9540.tar.bz2
gentoo-2-049efa9a4d5bfd166666f09aa565e9b9f7ca9540.zip
version bump
(Portage version: 2.2.10/cvs/Linux x86_64, signed Manifest commit with key BDEED020)
Diffstat (limited to 'games-roguelike')
-rw-r--r--games-roguelike/FTL/ChangeLog9
-rw-r--r--games-roguelike/FTL/FTL-1.5.4.ebuild66
2 files changed, 73 insertions, 2 deletions
diff --git a/games-roguelike/FTL/ChangeLog b/games-roguelike/FTL/ChangeLog
index 85403f84e224..807293be8309 100644
--- a/games-roguelike/FTL/ChangeLog
+++ b/games-roguelike/FTL/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for games-roguelike/FTL
-# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-roguelike/FTL/ChangeLog,v 1.14 2013/11/22 15:19:10 hasufell Exp $
+# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/games-roguelike/FTL/ChangeLog,v 1.15 2014/04/05 17:57:24 hasufell Exp $
+
+*FTL-1.5.4 (05 Apr 2014)
+
+ 05 Apr 2014; Julian Ospald <hasufell@gentoo.org> +FTL-1.5.4.ebuild:
+ version bump
22 Nov 2013; Julian Ospald <hasufell@gentoo.org> -FTL-1.03.1.ebuild,
FTL-1.03.3.ebuild:
diff --git a/games-roguelike/FTL/FTL-1.5.4.ebuild b/games-roguelike/FTL/FTL-1.5.4.ebuild
new file mode 100644
index 000000000000..6db7f99d7424
--- /dev/null
+++ b/games-roguelike/FTL/FTL-1.5.4.ebuild
@@ -0,0 +1,66 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-roguelike/FTL/FTL-1.5.4.ebuild,v 1.1 2014/04/05 17:57:24 hasufell Exp $
+
+EAPI=5
+
+inherit eutils games
+
+DESCRIPTION="Faster Than Light: A spaceship simulation real-time roguelike-like game"
+HOMEPAGE="http://www.ftlgame.com/"
+SRC_URI="FTL.${PV}.tar.gz"
+
+LICENSE="all-rights-reserved Boost-1.0 free-noncomm MIT bundled-libs? ( FTL LGPL-2.1 ZLIB libpng )"
+SLOT="0"
+KEYWORDS="-* ~amd64 ~x86"
+IUSE="bundled-libs"
+RESTRICT="fetch bindist splitdebug"
+
+RDEPEND="
+ sys-devel/gcc[cxx]
+ virtual/opengl
+ !bundled-libs? (
+ media-libs/devil[png,opengl]
+ media-libs/freetype:2
+ media-libs/libsdl[X,audio,joystick,opengl,video]
+ sys-libs/zlib
+ )"
+
+QA_PREBUILT="${GAMES_PREFIX_OPT#/}/${PN}/bin/${PN}
+ ${GAMES_PREFIX_OPT#/}/${PN}/lib/*"
+
+S=${WORKDIR}/${PN}
+
+pkg_nofetch() {
+ einfo "Please buy & download ${SRC_URI} from:"
+ einfo " ${HOMEPAGE}"
+ einfo "and move it to ${DISTDIR}"
+ einfo
+}
+
+src_prepare() {
+ if ! use bundled-libs ; then
+ # no system lib for libbass available
+ find data/${ARCH}/lib -type f \! -name "libbass*" -delete || die
+ fi
+}
+
+src_install() {
+ local dir=${GAMES_PREFIX_OPT}/${PN}
+
+ insinto "${dir}"
+ doins -r data/resources
+
+ exeinto "${dir}"/bin
+ doexe data/${ARCH}/bin/${PN}
+ exeinto "${dir}"/lib
+ doexe data/${ARCH}/lib/*.so*
+
+ games_make_wrapper ${PN} "${dir}/bin/${PN}" "${dir}" "${dir}/lib"
+ make_desktop_entry ${PN} "Faster Than Light" "/usr/share/pixmaps/FTL.bmp"
+
+ newicon data/resources/exe_icon.bmp FTL.bmp
+ dohtml ${PN}_README.html
+
+ prepgamesdirs
+}