summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2008-02-11 06:08:25 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2008-02-11 06:08:25 +0000
commit59ec86048f0b816b0c4b3801929010705689ea79 (patch)
tree5e85376cc6aaebdf80898e909ff926aac6a548c3 /games-roguelike
parentMarked stable on amd64 as per security bug 208343. (diff)
downloadgentoo-2-59ec86048f0b816b0c4b3801929010705689ea79.tar.gz
gentoo-2-59ec86048f0b816b0c4b3801929010705689ea79.tar.bz2
gentoo-2-59ec86048f0b816b0c4b3801929010705689ea79.zip
version bump
(Portage version: 2.1.3.19)
Diffstat (limited to 'games-roguelike')
-rw-r--r--games-roguelike/crossfire-client/ChangeLog10
-rw-r--r--games-roguelike/crossfire-client/crossfire-client-1.11.0.ebuild62
2 files changed, 70 insertions, 2 deletions
diff --git a/games-roguelike/crossfire-client/ChangeLog b/games-roguelike/crossfire-client/ChangeLog
index 286364b07a67..491b0115ad5c 100644
--- a/games-roguelike/crossfire-client/ChangeLog
+++ b/games-roguelike/crossfire-client/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for games-roguelike/crossfire-client
-# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-roguelike/crossfire-client/ChangeLog,v 1.18 2007/08/25 23:12:45 tupone Exp $
+# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/games-roguelike/crossfire-client/ChangeLog,v 1.19 2008/02/11 06:08:25 mr_bones_ Exp $
+
+*crossfire-client-1.11.0 (11 Feb 2008)
+
+ 11 Feb 2008; Michael Sterrett <mr_bones_@gentoo.org>
+ +crossfire-client-1.11.0.ebuild:
+ version bump
*crossfire-client-1.10.0 (25 Aug 2007)
diff --git a/games-roguelike/crossfire-client/crossfire-client-1.11.0.ebuild b/games-roguelike/crossfire-client/crossfire-client-1.11.0.ebuild
new file mode 100644
index 000000000000..76459d422b24
--- /dev/null
+++ b/games-roguelike/crossfire-client/crossfire-client-1.11.0.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-roguelike/crossfire-client/crossfire-client-1.11.0.ebuild,v 1.1 2008/02/11 06:08:25 mr_bones_ Exp $
+
+inherit games
+
+DESCRIPTION="Client for the nethack-style but more in the line of UO"
+HOMEPAGE="http://crossfire.real-time.com/"
+SRC_URI="mirror://sourceforge/crossfire/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="alsa gtk oss sdl"
+
+RDEPEND="alsa? ( media-libs/alsa-lib )
+ gtk? ( >=x11-libs/gtk+-2
+ sdl? ( media-libs/libsdl
+ media-libs/sdl-image ) )
+ virtual/glut
+ media-libs/libpng
+ sys-libs/zlib"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ sed -i \
+ -r 's:TH (g?)cfclient:TH \1cfclient 6:' \
+ {gtk,x11}/*cfclient.man \
+ || die "sed failed"
+}
+
+src_compile() {
+ # bugs in configure script so we cant use $(use_enable ...)
+ local myconf="--disable-dependency-tracking"
+
+ if use gtk ; then
+ use sdl || myconf="${myconf} --disable-sdl"
+ else
+ myconf="${myconf} --disable-gtk"
+ fi
+ if ! use alsa ; then
+ myconf="${myconf} --disable-alsa9 --disable-alsa"
+ fi
+ if ! use alsa && ! use oss ; then
+ myconf="${myconf} --disable-sound"
+ fi
+ egamesconf ${myconf} || die
+ # bug 139785
+ if use alsa || use oss ; then
+ emake -j1 -C sound-src || die "sound building failed"
+ fi
+ emake || die "emake failed"
+}
+
+src_install() {
+ make DESTDIR="${D}" install || die "make install failed"
+ dodoc AUTHORS ChangeLog README TODO
+ prepgamesdirs
+}