summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2009-12-22 01:05:51 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2009-12-22 01:05:51 +0000
commit7451f7bdfafd6c48ea9103958ccad25b91167dc9 (patch)
tree044d02060e157feac46bc3c3a32860471df2ad1c /games-roguelike
parentFixing stop sequence in init script, patch thanks to Lars Wendler (Polynomial... (diff)
downloadgentoo-2-7451f7bdfafd6c48ea9103958ccad25b91167dc9.tar.gz
gentoo-2-7451f7bdfafd6c48ea9103958ccad25b91167dc9.tar.bz2
gentoo-2-7451f7bdfafd6c48ea9103958ccad25b91167dc9.zip
add patch from Tim Hentenaar to fix compile warning from lua (bug #296697)
(Portage version: 2.1.6.13/cvs/Linux i686)
Diffstat (limited to 'games-roguelike')
-rw-r--r--games-roguelike/crossfire-client/ChangeLog6
-rw-r--r--games-roguelike/crossfire-client/crossfire-client-1.12.0.ebuild7
-rw-r--r--games-roguelike/crossfire-client/files/crossfire-client-1.12.0-lua.patch17
3 files changed, 26 insertions, 4 deletions
diff --git a/games-roguelike/crossfire-client/ChangeLog b/games-roguelike/crossfire-client/ChangeLog
index f2804aab2c67..e6adf46be551 100644
--- a/games-roguelike/crossfire-client/ChangeLog
+++ b/games-roguelike/crossfire-client/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for games-roguelike/crossfire-client
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-roguelike/crossfire-client/ChangeLog,v 1.20 2009/10/15 06:16:20 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-roguelike/crossfire-client/ChangeLog,v 1.21 2009/12/22 01:05:51 mr_bones_ Exp $
+
+ 22 Dec 2009; Michael Sterrett <mr_bones_@gentoo.org>
+ crossfire-client-1.12.0.ebuild, +files/crossfire-client-1.12.0-lua.patch:
+ add patch from Tim Hentenaar to fix compile warning from lua (bug #296697)
*crossfire-client-1.12.0 (15 Oct 2009)
diff --git a/games-roguelike/crossfire-client/crossfire-client-1.12.0.ebuild b/games-roguelike/crossfire-client/crossfire-client-1.12.0.ebuild
index 7c968dcc0732..f246d1175598 100644
--- a/games-roguelike/crossfire-client/crossfire-client-1.12.0.ebuild
+++ b/games-roguelike/crossfire-client/crossfire-client-1.12.0.ebuild
@@ -1,9 +1,9 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-roguelike/crossfire-client/crossfire-client-1.12.0.ebuild,v 1.1 2009/10/15 06:16:20 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-roguelike/crossfire-client/crossfire-client-1.12.0.ebuild,v 1.2 2009/12/22 01:05:51 mr_bones_ Exp $
EAPI=2
-inherit games
+inherit eutils games
DESCRIPTION="Client for the nethack-style but more in the line of UO"
HOMEPAGE="http://crossfire.real-time.com/"
@@ -16,7 +16,7 @@ IUSE="alsa gtk oss sdl"
RDEPEND="alsa? ( media-libs/alsa-lib )
gtk? ( x11-libs/gtk+:2
- sdl? ( media-libs/libsdl
+ sdl? ( media-libs/libsdl[video]
media-libs/sdl-image ) )
virtual/glut
media-libs/libpng
@@ -29,6 +29,7 @@ src_prepare() {
-r '/^.TH/s:$: 6:' \
$(find . -name "*man") \
|| die "sed failed"
+ epatch "${FILESDIR}/${P}-lua.patch"
}
src_configure() {
diff --git a/games-roguelike/crossfire-client/files/crossfire-client-1.12.0-lua.patch b/games-roguelike/crossfire-client/files/crossfire-client-1.12.0-lua.patch
new file mode 100644
index 000000000000..ebd6eb27150c
--- /dev/null
+++ b/games-roguelike/crossfire-client/files/crossfire-client-1.12.0-lua.patch
@@ -0,0 +1,17 @@
+diff -ru crossfire-client-1.12.0-old/common/script_lua.c crossfire-client-1.12.0/common/script_lua.c
+--- crossfire-client-1.12.0-old/common/script_lua.c 2009-04-04 13:43:43.000000000 -0400
++++ crossfire-client-1.12.0/common/script_lua.c 2009-12-13 00:45:32.020011661 -0500
+@@ -44,6 +44,13 @@
+ #include <lua.h>
+ #include <lualib.h>
+
++/* luaL_newstate() is declared in lauxlib.h in Lua >= 5.1
++ * and is needed to correct "implicit declaration" warnings.
++ */
++#if LUA_VERSION_NUM >= 501
++#include <lauxlib.h>
++#endif
++
+ struct script_state
+ {
+ lua_State* state;