summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJulian Ospald <hasufell@gentoo.org>2014-07-04 20:13:41 +0000
committerJulian Ospald <hasufell@gentoo.org>2014-07-04 20:13:41 +0000
commitb723f738bbaac7ee3bb0fcddb260faf9a7018c15 (patch)
treefae04d2242bc3c061a2d44c7402e1e5b2cbd1b1b /games-rpg/vendetta-online-bin
parentupdate icon cache and fix deps wrt #508148 (diff)
downloadgentoo-2-b723f738bbaac7ee3bb0fcddb260faf9a7018c15.tar.gz
gentoo-2-b723f738bbaac7ee3bb0fcddb260faf9a7018c15.tar.bz2
gentoo-2-b723f738bbaac7ee3bb0fcddb260faf9a7018c15.zip
version bump wrt #514470
(Portage version: 2.2.10/cvs/Linux x86_64, signed Manifest commit with key BDEED020)
Diffstat (limited to 'games-rpg/vendetta-online-bin')
-rw-r--r--games-rpg/vendetta-online-bin/ChangeLog11
-rw-r--r--games-rpg/vendetta-online-bin/vendetta-online-bin-1.8.296.ebuild52
2 files changed, 60 insertions, 3 deletions
diff --git a/games-rpg/vendetta-online-bin/ChangeLog b/games-rpg/vendetta-online-bin/ChangeLog
index 58b5ba3f5dab..ed269d85277b 100644
--- a/games-rpg/vendetta-online-bin/ChangeLog
+++ b/games-rpg/vendetta-online-bin/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for games-rpg/vendetta-online-bin
-# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-rpg/vendetta-online-bin/ChangeLog,v 1.9 2012/02/08 21:34:13 vapier Exp $
+# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/games-rpg/vendetta-online-bin/ChangeLog,v 1.10 2014/07/04 20:13:41 hasufell Exp $
+
+*vendetta-online-bin-1.8.296 (04 Jul 2014)
+
+ 04 Jul 2014; Julian Ospald <hasufell@gentoo.org>
+ +vendetta-online-bin-1.8.296.ebuild:
+ version bump wrt #514470
08 Feb 2012; Mike Frysinger <vapier@gentoo.org>
vendetta-online-bin-1.8.82.ebuild:
@@ -73,4 +79,3 @@
30 Nov 2004; Joshua Charles Campbell <warpzero@gentoo.org> vendetta-online-bin1.ebuild:
initial commit, ebuild submitted by yoosty69@netzero.net and
Roguelazer@gmail.com
-
diff --git a/games-rpg/vendetta-online-bin/vendetta-online-bin-1.8.296.ebuild b/games-rpg/vendetta-online-bin/vendetta-online-bin-1.8.296.ebuild
new file mode 100644
index 000000000000..3193e85f5243
--- /dev/null
+++ b/games-rpg/vendetta-online-bin/vendetta-online-bin-1.8.296.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-rpg/vendetta-online-bin/vendetta-online-bin-1.8.296.ebuild,v 1.1 2014/07/04 20:13:41 hasufell Exp $
+
+EAPI=5
+inherit eutils unpacker games
+
+DESCRIPTION="Space-based MMORPG"
+HOMEPAGE="http://www.vendetta-online.com/"
+SRC_URI="amd64? (
+ http://mirror.cle.vendetta-online.com/vendetta-linux-amd64-installer.sh
+ -> ${P}-amd64.sh
+ )
+ x86? (
+ http://mirror.cle.vendetta-online.com/vendetta-linux-ia32-installer.sh
+ -> ${P}-x86.sh
+ )"
+
+LICENSE="guild"
+SLOT="0"
+KEYWORDS="-* ~amd64 ~x86"
+IUSE=""
+RESTRICT="mirror strip"
+
+RDEPEND="virtual/opengl
+ x11-libs/gtk+:2"
+
+S=${WORKDIR}
+
+src_unpack() {
+ unpack_makeself
+}
+
+src_install() {
+ local dir=${GAMES_PREFIX_OPT}/${PN}
+
+ insinto "${dir}"
+ doins -r * || die "doins failed"
+ fperms +x "${dir}"/{vendetta,install/{media.rlb,update.rlb,vendetta}} \
+ || die "fperms failed"
+
+ sed \
+ -e "s:DATADIR:${dir}:" \
+ "${FILESDIR}"/vendetta > "${T}"/vendetta \
+ || die "sed failed"
+
+ dogamesbin "${T}"/vendetta
+ newicon install/manual/images/ships.valkyrie.jpg ${PN}.jpg
+ make_desktop_entry vendetta "Vendetta Online" /usr/share/pixmaps/${PN}.jpg
+
+ prepgamesdirs
+}