summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2015-06-12 14:33:22 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2015-06-12 14:33:22 +0000
commit85a45888d8b52e295639a95e20b1ae66b6c4c81c (patch)
treeb9eb6a52eb487a3d2c3eab2872bbb2ee547ab0da /games-rpg
parentNeed gnome-common, gobject-introspection-common for eautoreconf (bug #551886,... (diff)
downloadgentoo-2-85a45888d8b52e295639a95e20b1ae66b6c4c81c.tar.gz
gentoo-2-85a45888d8b52e295639a95e20b1ae66b6c4c81c.tar.bz2
gentoo-2-85a45888d8b52e295639a95e20b1ae66b6c4c81c.zip
version bump
(Portage version: 2.2.18/cvs/Linux x86_64, unsigned Manifest commit)
Diffstat (limited to 'games-rpg')
-rw-r--r--games-rpg/manaplus/ChangeLog7
-rw-r--r--games-rpg/manaplus/manaplus-1.5.6.6.ebuild75
2 files changed, 81 insertions, 1 deletions
diff --git a/games-rpg/manaplus/ChangeLog b/games-rpg/manaplus/ChangeLog
index d60d42f76e53..231f5f547487 100644
--- a/games-rpg/manaplus/ChangeLog
+++ b/games-rpg/manaplus/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for games-rpg/manaplus
# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-rpg/manaplus/ChangeLog,v 1.17 2015/05/13 04:10:35 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-rpg/manaplus/ChangeLog,v 1.18 2015/06/12 14:33:22 mr_bones_ Exp $
+
+*manaplus-1.5.6.6 (12 Jun 2015)
+
+ 12 Jun 2015; Michael Sterrett <mr_bones_@gentoo.org> +manaplus-1.5.6.6.ebuild:
+ version bump
*manaplus-1.5.5.9 (13 May 2015)
diff --git a/games-rpg/manaplus/manaplus-1.5.6.6.ebuild b/games-rpg/manaplus/manaplus-1.5.6.6.ebuild
new file mode 100644
index 000000000000..c574b87c9c36
--- /dev/null
+++ b/games-rpg/manaplus/manaplus-1.5.6.6.ebuild
@@ -0,0 +1,75 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-rpg/manaplus/manaplus-1.5.6.6.ebuild,v 1.1 2015/06/12 14:33:22 mr_bones_ Exp $
+
+EAPI=5
+inherit games
+
+DESCRIPTION="OpenSource 2D MMORPG client for Evol Online and The Mana World"
+HOMEPAGE="http://manaplus.evolonline.org"
+SRC_URI="http://download.evolonline.org/manaplus/download/${PV}/manaplus-${PV}.tar.xz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="nls opengl"
+
+RDEPEND="
+ >=dev-games/physfs-1.0.0
+ dev-libs/libxml2
+ media-libs/libpng:0=
+ media-libs/libsdl2[X,opengl?,video]
+ media-libs/sdl2-gfx
+ media-libs/sdl2-image[png]
+ media-libs/sdl2-mixer[vorbis]
+ media-libs/sdl2-net
+ media-libs/sdl2-ttf
+ net-misc/curl
+ sys-libs/zlib
+ x11-libs/libX11
+ x11-misc/xdg-utils
+ x11-apps/xmessage
+ media-fonts/dejavu
+ media-fonts/wqy-microhei
+ media-fonts/liberation-fonts
+ media-fonts/mplus-outline-fonts
+ nls? ( virtual/libintl )
+ opengl? ( virtual/opengl )"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ nls? ( sys-devel/gettext )"
+
+src_prepare() {
+ sed -i \
+ -e '/^SUBDIRS/s/fonts//' \
+ data/Makefile.in || die
+}
+
+src_configure() {
+ CONFIG_SHELL=/bin/bash \
+ egamesconf \
+ --with-sdl2 \
+ --without-internalsdlgfx \
+ --localedir=/usr/share/locale \
+ --prefix="/usr" \
+ --bindir="${GAMES_BINDIR}" \
+ $(use_with opengl) \
+ $(use_enable nls)
+}
+
+src_install() {
+ default
+ dosym /usr/share/fonts/dejavu/DejaVuSans-Bold.ttf "${GAMES_DATADIR}"/${PN}/data/fonts/dejavusans-bold.ttf
+ dosym /usr/share/fonts/dejavu/DejaVuSansMono-Bold.ttf "${GAMES_DATADIR}"/${PN}/data/fonts/dejavusansmono-bold.ttf
+ dosym /usr/share/fonts/dejavu/DejaVuSansMono.ttf "${GAMES_DATADIR}"/${PN}/data/fonts/dejavusansmono.ttf
+ dosym /usr/share/fonts/dejavu/DejaVuSans.ttf "${GAMES_DATADIR}"/${PN}/data/fonts/dejavusans.ttf
+ dosym /usr/share/fonts/liberation-fonts/LiberationSans-Bold.ttf "${GAMES_DATADIR}"/${PN}/data/fonts/liberationsans-bold.ttf
+ dosym /usr/share/fonts/liberation-fonts/LiberationMono-Bold.ttf "${GAMES_DATADIR}"/${PN}/data/fonts/liberationsansmono-bold.ttf
+ dosym /usr/share/fonts/liberation-fonts/LiberationMono-Regular.ttf "${GAMES_DATADIR}"/${PN}/data/fonts/liberationsansmono.ttf
+ dosym /usr/share/fonts/liberation-fonts/LiberationSans-Regular.ttf "${GAMES_DATADIR}"/${PN}/data/fonts/liberationsans.ttf
+ dosym /usr/share/fonts/wqy-microhei/wqy-microhei.ttc "${GAMES_DATADIR}"/${PN}/data/fonts/wqy-microhei.ttf
+ dosym /usr/share/fonts/mplus-outline-fonts/mplus-1p-bold.ttf "${GAMES_DATADIR}"/${PN}/data/fonts/mplus-1p-bold.ttf
+ dosym /usr/share/fonts/mplus-outline-fonts/mplus-1p-regular.ttf "${GAMES_DATADIR}"/${PN}/data/fonts/mplus-1p-regular.ttf
+
+ prepgamesdirs
+}