summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2003-09-10 05:51:11 +0000
committerMike Frysinger <vapier@gentoo.org>2003-09-10 05:51:11 +0000
commitedbc06b08e95c97e2012a831adcf93b9652b0be0 (patch)
treedebef26d9299fcdb4a69696d45a8fc8d27d36722 /games-server/halflife-adminmod/halflife-adminmod-2.50.52.ebuild
parentgames-server (diff)
downloadgentoo-2-edbc06b08e95c97e2012a831adcf93b9652b0be0.tar.gz
gentoo-2-edbc06b08e95c97e2012a831adcf93b9652b0be0.tar.bz2
gentoo-2-edbc06b08e95c97e2012a831adcf93b9652b0be0.zip
games-servers !
Diffstat (limited to 'games-server/halflife-adminmod/halflife-adminmod-2.50.52.ebuild')
-rw-r--r--games-server/halflife-adminmod/halflife-adminmod-2.50.52.ebuild43
1 files changed, 43 insertions, 0 deletions
diff --git a/games-server/halflife-adminmod/halflife-adminmod-2.50.52.ebuild b/games-server/halflife-adminmod/halflife-adminmod-2.50.52.ebuild
new file mode 100644
index 000000000000..23a0dbc1777f
--- /dev/null
+++ b/games-server/halflife-adminmod/halflife-adminmod-2.50.52.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-server/halflife-adminmod/halflife-adminmod-2.50.52.ebuild,v 1.1 2003/09/10 05:51:10 vapier Exp $
+
+inherit games eutils
+
+MY_P=${P/mod/}
+DESCRIPTION="give people admin access (and a looooooot more)"
+HOMEPAGE="http://www.adminmod.org/"
+SRC_URI="mirror://sourceforge/halflifeadmin/${MY_P}.tgz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="-* x86"
+
+RDEPEND="app-games/halflife-metamod"
+PDEPEND="app-games/halflife-modsetup"
+
+S=${WORKDIR}/Adminmod
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ # fix default values
+ sed -i "s:addons:../addons:" config/{metamod,plugin}.ini
+ sed -i "/^[^/]/s:^://:" config/Samples/{ips,users}.ini
+ sed -i "/^[^/h]/s:^://:" config/Samples/models.ini
+ epatch ${FILESDIR}/${PV}-adminmod.cfg
+}
+
+src_install() {
+ local dir=${GAMES_PREFIX_OPT}/halflife/addons/adminmod
+
+ dodoc CHANGES README docs/*
+ dohtml -r docs/html/*
+ rm -rf LICENSE CHANGES README docs dlls/metamod_i386.so
+
+ dodir ${dir}
+ cp -rf ${S}/* ${FILESDIR}/modsetup ${D}/${dir}/
+ dosym /usr/share/doc/${PF} ${dir}/docs
+
+ prepgamesdirs
+}