summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2005-03-11 18:12:11 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2005-03-11 18:12:11 +0000
commit2aa7d244cdc9390594162a860b9247430b9f917a (patch)
tree4eedce84a14ec7f71006bf53d24e68e76bdfd3e2 /games-server
parentDrop IPv6 patches. (diff)
downloadgentoo-2-2aa7d244cdc9390594162a860b9247430b9f917a.tar.gz
gentoo-2-2aa7d244cdc9390594162a860b9247430b9f917a.tar.bz2
gentoo-2-2aa7d244cdc9390594162a860b9247430b9f917a.zip
version bump (bug #84878)
(Portage version: 2.0.51.19)
Diffstat (limited to 'games-server')
-rw-r--r--games-server/hlstats/ChangeLog7
-rw-r--r--games-server/hlstats/Manifest4
-rw-r--r--games-server/hlstats/files/digest-hlstats-1.311
-rw-r--r--games-server/hlstats/hlstats-1.31.ebuild78
4 files changed, 88 insertions, 2 deletions
diff --git a/games-server/hlstats/ChangeLog b/games-server/hlstats/ChangeLog
index 1ce044de30f6..d6d92f39069b 100644
--- a/games-server/hlstats/ChangeLog
+++ b/games-server/hlstats/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for games-server/hlstats
# Copyright 2000-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-server/hlstats/ChangeLog,v 1.7 2005/02/12 01:42:01 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-server/hlstats/ChangeLog,v 1.8 2005/03/11 18:12:11 mr_bones_ Exp $
+
+*hlstats-1.31 (11 Mar 2005)
+
+ 11 Mar 2005; Michael Sterrett <mr_bones_@gentoo.org> +hlstats-1.31.ebuild:
+ version bump (bug #84878)
*hlstats-1.30 (11 Feb 2005)
diff --git a/games-server/hlstats/Manifest b/games-server/hlstats/Manifest
index 2819a9f4f4d2..a9e0e368fd60 100644
--- a/games-server/hlstats/Manifest
+++ b/games-server/hlstats/Manifest
@@ -1,6 +1,8 @@
MD5 c23e6b3add89853a215e99e8dae6db00 ChangeLog 834
+MD5 163ae26bf22ced93de3a173176acf446 hlstats-1.31.ebuild 2473
MD5 f17b9b8fa07a38914fe1c03268f51678 metadata.xml 158
MD5 163ae26bf22ced93de3a173176acf446 hlstats-1.30.ebuild 2473
+MD5 b567904c6912530d9091ddfc12435f6e files/digest-hlstats-1.30 65
MD5 819787fd7ea1413af32af58c51ede1a5 files/hlstats 120
MD5 abc69f8fd2ab9151ef7106998a231151 files/hlstats.rc 502
-MD5 b567904c6912530d9091ddfc12435f6e files/digest-hlstats-1.30 65
+MD5 8073404119b020b10d1705e241f8b9f5 files/digest-hlstats-1.31 65
diff --git a/games-server/hlstats/files/digest-hlstats-1.31 b/games-server/hlstats/files/digest-hlstats-1.31
new file mode 100644
index 000000000000..cf1b8b118f5d
--- /dev/null
+++ b/games-server/hlstats/files/digest-hlstats-1.31
@@ -0,0 +1 @@
+MD5 ba85e479ded94cc265f4cc08be1100df hlstats-1.31.tar.gz 1302645
diff --git a/games-server/hlstats/hlstats-1.31.ebuild b/games-server/hlstats/hlstats-1.31.ebuild
new file mode 100644
index 000000000000..790ee324956f
--- /dev/null
+++ b/games-server/hlstats/hlstats-1.31.ebuild
@@ -0,0 +1,78 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-server/hlstats/hlstats-1.31.ebuild,v 1.1 2005/03/11 18:12:11 mr_bones_ Exp $
+
+inherit games webapp
+
+DESCRIPTION="real-time player rankings/statistics for half-life"
+HOMEPAGE="http://www.hlstats.org/"
+SRC_URI="mirror://sourceforge/hlstats/${P}.tar.gz"
+
+LICENSE="GPL-2"
+KEYWORDS="amd64 x86"
+IUSE=""
+
+DEPEND=">=sys-apps/sed-4"
+RDEPEND="dev-lang/perl
+ dev-db/mysql
+ net-www/apache
+ dev-php/mod_php"
+
+pkg_setup() {
+ webapp_pkg_setup
+ games_pkg_setup
+}
+
+src_install() {
+ webapp_src_preinst
+
+ dodoc ChangeLog
+
+ insinto ${GAMES_LIBDIR}/${PN}
+ doins *.{pm,plib}
+ insinto ${GAMES_DATADIR}/${PN}
+ doins *.sql
+
+ sed -i \
+ -e "s:\./hlstats\.conf:${GAMES_SYSCONFDIR}/hlstats.conf:" \
+ -e "/^\$opt_libdir =/s:=.*:=\"${GAMES_LIBDIR}/${PN}/\";:" \
+ *.pl || die "sed pl failed"
+ dogamesbin *.pl || die "dogamesbin failed"
+ dobin ${FILESDIR}/hlstats
+ dosed "s:GENTOO_DIR:${GAMES_BINDIR}:" /usr/bin/hlstats
+ newinitd ${FILESDIR}/hlstats.rc hlstats
+
+ insinto ${GAMES_SYSCONFDIR}
+ doins hlstats.conf
+
+ dodir ${MY_HTDOCSDIR}
+ cp -r hlstats.php hlstatsimg hlstatsinc ${D}/${MY_HTDOCSDIR}/
+ webapp_serverowned ${MY_HTDOCSDIR}
+
+ webapp_src_install
+}
+
+pkg_postinst() {
+ games_pkg_postinst
+ einfo "To setup:"
+ einfo " 1. \`mysqladmin create hlstats\`"
+ einfo " 2. \`mysql hlstats < ${GAMES_DATADIR}/${PN}/hlstats.sql\`"
+ einfo " 3. \`mysql hlstats < ${GAMES_DATADIR}/${PN}/gamesupport_GAME.sql\`"
+ einfo " so if you want cstrike support, replace 'GAME' with 'cstrike'"
+ einfo " 4. Edit ${GAMES_SYSCONFDIR}/hlstats.conf"
+ einfo " 5. Edit ${MY_HTDOCSDIR}/hlstats.php"
+ einfo " 6. \`rc-update add hlstats default\`"
+ einfo " 7. \`/etc/init.d/hlstats start\`"
+ einfo " 8. Edit the cfg files of the game servers you want to track ..."
+ einfo " add these lines to your config file:"
+ einfo " log on"
+ einfo " logaddress 1.2.3.4 27500"
+ einfo " (replace 1.2.3.4 with the IP of the server hlstats is running on)"
+ einfo " 9. If you want daily awards, setup a cronjob to run hlstats-awards.pl"
+ einfo " for example, run \`crontab -e\` and add this entry:"
+ einfo " 30 00 * * * ${GAMES_BINDIR}/hlstats-awards.pl"
+ einfo " 10. Finally ! Start up the server and after a while goto"
+ einfo " http://1.2.3.4/hlstats.php"
+ einfo " (replace 1.2.3.4 with the IP of the server hlstats is running on)"
+ webapp_pkg_postinst
+}