summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlfredo Tupone <tupone@gentoo.org>2012-01-28 21:15:48 +0000
committerAlfredo Tupone <tupone@gentoo.org>2012-01-28 21:15:48 +0000
commit3bdafc97fc29103ee91e38c581e87fe21f943359 (patch)
treefbcf6f27d5b3751c04167310421d59a6c19b00b1 /games-server
parentUpdated -9999.build (thanks Shark, bug 401205), remove old version (diff)
downloadgentoo-2-3bdafc97fc29103ee91e38c581e87fe21f943359.tar.gz
gentoo-2-3bdafc97fc29103ee91e38c581e87fe21f943359.tar.bz2
gentoo-2-3bdafc97fc29103ee91e38c581e87fe21f943359.zip
Version bump to 0.5.26. Bug #383415
(Portage version: 2.1.10.44/cvs/Linux i686)
Diffstat (limited to 'games-server')
-rw-r--r--games-server/cyphesis/ChangeLog10
-rw-r--r--games-server/cyphesis/cyphesis-0.5.26.ebuild52
-rw-r--r--games-server/cyphesis/files/cyphesis-0.5.26-gentoo.patch41
3 files changed, 101 insertions, 2 deletions
diff --git a/games-server/cyphesis/ChangeLog b/games-server/cyphesis/ChangeLog
index 5f633e2b13ab..e9cb3eb31f6c 100644
--- a/games-server/cyphesis/ChangeLog
+++ b/games-server/cyphesis/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for games-server/cyphesis
-# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-server/cyphesis/ChangeLog,v 1.20 2011/01/15 15:23:25 maekke Exp $
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/games-server/cyphesis/ChangeLog,v 1.21 2012/01/28 21:15:47 tupone Exp $
+
+*cyphesis-0.5.26 (28 Jan 2012)
+
+ 28 Jan 2012; Tupone Alfredo <tupone@gentoo.org> +cyphesis-0.5.26.ebuild,
+ +files/cyphesis-0.5.26-gentoo.patch:
+ Version bump to 0.5.26. Bug #383415 by Mr. Anderson
15 Jan 2011; Markus Meier <maekke@gentoo.org> cyphesis-0.5.25.ebuild:
x86 stable, bug #350780
diff --git a/games-server/cyphesis/cyphesis-0.5.26.ebuild b/games-server/cyphesis/cyphesis-0.5.26.ebuild
new file mode 100644
index 000000000000..886b755c50b4
--- /dev/null
+++ b/games-server/cyphesis/cyphesis-0.5.26.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-server/cyphesis/cyphesis-0.5.26.ebuild,v 1.1 2012/01/28 21:15:47 tupone Exp $
+
+EAPI=2
+PYTHON_DEPEND=2
+inherit autotools python eutils games
+
+DESCRIPTION="WorldForge server running small games"
+HOMEPAGE="http://worldforge.org/dev/eng/servers/cyphesis"
+SRC_URI="mirror://sourceforge/worldforge/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND=">=media-libs/skstream-0.3.6
+ >=dev-games/wfmath-0.3.11
+ >=dev-games/mercator-0.3.0
+ dev-libs/libgcrypt
+ dev-libs/libsigc++:2
+ sys-libs/ncurses
+ sys-libs/readline
+ =media-libs/atlas-c++-0.6*
+ >=media-libs/varconf-0.6.4
+ dev-db/postgresql-base"
+DEPEND="${RDEPEND}
+ dev-libs/libxml2
+ dev-util/pkgconfig"
+
+pkg_setup() {
+ python_set_active_version 2
+ games_pkg_setup
+}
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-gentoo.patch
+ eautoreconf
+}
+
+src_configure() {
+ egamesconf \
+ --localstatedir=/var
+}
+
+src_install() {
+ emake DESTDIR="${D}" confbackupdir="/usr/share/doc/${PF}/conf" \
+ install || die "emake install failed"
+ dodoc AUTHORS ChangeLog FIXME NEWS README THANKS TODO
+ prepgamesdirs
+}
diff --git a/games-server/cyphesis/files/cyphesis-0.5.26-gentoo.patch b/games-server/cyphesis/files/cyphesis-0.5.26-gentoo.patch
new file mode 100644
index 000000000000..73e65966fe94
--- /dev/null
+++ b/games-server/cyphesis/files/cyphesis-0.5.26-gentoo.patch
@@ -0,0 +1,41 @@
+diff -ur cyphesis-0.5.20.orig/configure.ac cyphesis-0.5.20/configure.ac
+--- cyphesis-0.5.20.orig/configure.ac 2009-05-11 15:23:20.000000000 +0300
++++ cyphesis-0.5.20/configure.ac 2009-08-15 12:33:01.000000000 +0300
+@@ -342,26 +342,6 @@
+ libraries required and where to obtain them.])
+ ])
+
+-PKG_CHECK_MODULES(AVAHI, avahi-client,
+- [
+- CPPFLAGS="$CPPFLAGS $AVAHI_CFLAGS"
+- MDNS_LIBS="$MDNS_LIBS $AVAHI_LIBS"
+- AC_DEFINE(HAVE_AVAHI, 1, [Define to 1 if you have avahi libs.])
+- ],
+- [
+- AC_MSG_RESULT([no])
+- PKG_CHECK_MODULES(HOWL, howl,
+- [
+- CPPFLAGS="$CPPFLAGS $HOWL_CFLAGS"
+- MDNS_LIBS="$MDNS_LIBS $HOWL_LIBS"
+- AC_DEFINE(HAVE_LIBHOWL, 1, [Define to 1 if you have howl libs.])
+- ],
+- [
+- AC_MSG_RESULT([no])
+- AC_MSG_NOTICE([Ommiting DNS-SD functionality.])
+- ])
+- ])
+-
+ AM_PATH_PSQL(7.1.0,
+ [
+ if test "$PG_CFLAGS" != "-I/usr/include"; then
+diff -ur cyphesis-0.5.20.orig/Makefile.am cyphesis-0.5.20/Makefile.am
+--- cyphesis-0.5.20.orig/Makefile.am 2009-05-11 15:23:20.000000000 +0300
++++ cyphesis-0.5.20/Makefile.am 2009-08-15 12:33:45.000000000 +0300
+@@ -3,7 +3,6 @@
+ tools tests man dox
+
+ docdir = $(datadir)/doc/cyphesis-$(VERSION)
+-dist_doc_DATA = README COPYING AUTHORS THANKS NEWS FIXME
+
+ rulesetdir = $(datadir)/cyphesis/rulesets
+