summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTristan Heaven <nyhm@gentoo.org>2009-09-03 12:37:39 +0000
committerTristan Heaven <nyhm@gentoo.org>2009-09-03 12:37:39 +0000
commitb3ecee4c1597baa56a8cac3e0ad72a5e45535988 (patch)
treed57c506737bc958af7b67e4c210a4db987a00adf /games-server
parentSmall set of fixes, thanks to RB. Closes #277811 (diff)
downloadgentoo-2-b3ecee4c1597baa56a8cac3e0ad72a5e45535988.tar.gz
gentoo-2-b3ecee4c1597baa56a8cac3e0ad72a5e45535988.tar.bz2
gentoo-2-b3ecee4c1597baa56a8cac3e0ad72a5e45535988.zip
Apply patch to fix remote DOS, bug #239557; new init script, bug #161019
(Portage version: 2.2_rc40/cvs/Linux x86_64)
Diffstat (limited to 'games-server')
-rw-r--r--games-server/ut2004-ded/ChangeLog10
-rw-r--r--games-server/ut2004-ded/files/ut2004-ded.confd6
-rw-r--r--games-server/ut2004-ded/files/ut2004-ded.initd23
-rw-r--r--games-server/ut2004-ded/ut2004-ded-3369.3.ebuild84
4 files changed, 121 insertions, 2 deletions
diff --git a/games-server/ut2004-ded/ChangeLog b/games-server/ut2004-ded/ChangeLog
index 7134874fadbd..3caf582f364e 100644
--- a/games-server/ut2004-ded/ChangeLog
+++ b/games-server/ut2004-ded/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for games-server/ut2004-ded
-# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-server/ut2004-ded/ChangeLog,v 1.21 2007/04/28 16:06:50 tove Exp $
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/games-server/ut2004-ded/ChangeLog,v 1.22 2009/09/03 12:37:38 nyhm Exp $
+
+*ut2004-ded-3369.3 (03 Sep 2009)
+
+ 03 Sep 2009; Tristan Heaven <nyhm@gentoo.org> +files/ut2004-ded.confd,
+ +ut2004-ded-3369.3.ebuild, +files/ut2004-ded.initd:
+ Apply patch to fix remote DOS, bug #239557; new init script, bug #161019
28 Apr 2007; Torsten Veller <tove@gentoo.org> ut2004-ded-3369.ebuild:
Use newinitd
diff --git a/games-server/ut2004-ded/files/ut2004-ded.confd b/games-server/ut2004-ded/files/ut2004-ded.confd
new file mode 100644
index 000000000000..5ae995e94ddc
--- /dev/null
+++ b/games-server/ut2004-ded/files/ut2004-ded.confd
@@ -0,0 +1,6 @@
+# User and group the server should run as
+UT2004_DED_USER="@USER@"
+UT2004_DED_GROUP="@GROUP@"
+
+# Any extra options you want to pass to the server
+UT2004_DED_OPTS="DM-Deck17 -nohomedir -ini=Default.ini -log=/dev/null"
diff --git a/games-server/ut2004-ded/files/ut2004-ded.initd b/games-server/ut2004-ded/files/ut2004-ded.initd
new file mode 100644
index 000000000000..c7c08fa0d1fb
--- /dev/null
+++ b/games-server/ut2004-ded/files/ut2004-ded.initd
@@ -0,0 +1,23 @@
+#!/sbin/runscript
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-server/ut2004-ded/files/ut2004-ded.initd,v 1.1 2009/09/03 12:37:39 nyhm Exp $
+
+depend() {
+ need net
+}
+
+start() {
+ ebegin "Starting ut2004-ded"
+ start-stop-daemon --start --quiet --background \
+ --chuid ${UT2004_DED_USER}:${UT2004_DED_GROUP} \
+ --chdir "@DIR@" --exec "@DIR@/ucc-bin" -- \
+ server ${UT2004_DED_OPTS}
+ eend $?
+}
+
+stop() {
+ ebegin "Stopping ut2004-ded"
+ start-stop-daemon --stop --quiet --exec "@DIR@/ucc-bin"
+ eend $?
+}
diff --git a/games-server/ut2004-ded/ut2004-ded-3369.3.ebuild b/games-server/ut2004-ded/ut2004-ded-3369.3.ebuild
new file mode 100644
index 000000000000..d9325f0930c0
--- /dev/null
+++ b/games-server/ut2004-ded/ut2004-ded-3369.3.ebuild
@@ -0,0 +1,84 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-server/ut2004-ded/ut2004-ded-3369.3.ebuild,v 1.1 2009/09/03 12:37:38 nyhm Exp $
+
+inherit games
+
+BONUSPACK_P="dedicatedserver3339-bonuspack.zip"
+PATCH_P="ut2004-lnxpatch${PV%.*}-2.tar.bz2"
+DESCRIPTION="Unreal Tournament 2004 Linux Dedicated Server"
+HOMEPAGE="http://www.unrealtournament.com/"
+SRC_URI="mirror://3dgamers/unrealtourn2k4/${BONUSPACK_P}
+ http://downloads.unrealadmin.org/UT2004/Patches/Linux/${BONUSPACK_P}
+ http://sonic-lux.net/data/mirror/ut2004/${BONUSPACK_P}
+ mirror://3dgamers/unrealtourn2k4/${PATCH_P}
+ http://downloads.unrealadmin.org/UT2004/Server/${PATCH_P}
+ http://sonic-lux.net/data/mirror/ut2004/${PATCH_P}
+ mirror://gentoo/ut2004-v${PV/./-}-linux-dedicated.7z"
+
+LICENSE="ut2003"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+RESTRICT="mirror strip"
+PROPERTIES="interactive"
+
+DEPEND="app-arch/unzip
+ app-arch/p7zip"
+RDEPEND="sys-libs/glibc"
+
+S=${WORKDIR}
+
+GAMES_CHECK_LICENSE="yes"
+dir=${GAMES_PREFIX_OPT}/${PN}
+
+src_unpack() {
+ unpack ${A}
+ cp -rf UT2004-Patch/* . || die
+ rm -rf System/{ucc-bin*,ut2004-bin*,*.dll,*.exe} UT2004-Patch
+ if use amd64 ; then
+ mv -f ut2004-ucc-bin-09192008/ucc-bin-linux-amd64 System/ucc-bin || die
+ else
+ mv -f ut2004-ucc-bin-09192008/ucc-bin System/ || die
+ fi
+ rm -rf ut2004-ucc-bin-09192008
+}
+
+src_install() {
+ einfo "This will take a while... go get a pizza or something"
+
+ insinto "${dir}"
+ doins -r * || die "doins failed"
+ fperms +x "${dir}"/System/ucc-bin || die "fperms failed"
+
+ sed \
+ -e "s:@USER@:${GAMES_USER_DED}:" \
+ -e "s:@GROUP@:${GAMES_GROUP}:" \
+ "${FILESDIR}"/${PN}.confd > "${T}"/${PN}.confd \
+ || die "sed confd failed"
+ newconfd "${T}"/${PN}.confd ${PN} || die "newconfd failed"
+
+ sed \
+ -e "s:@DIR@:${dir}/System:g" \
+ "${FILESDIR}"/${PN}.initd > "${T}"/${PN}.initd \
+ || die "sed initd failed"
+ newinitd "${T}"/${PN}.initd ${PN} || die "initd failed"
+
+ prepgamesdirs
+}
+
+pkg_postinst() {
+ games_pkg_postinst
+ elog "The server can be started using the /etc/init.d/ut2004-ded script."
+ ewarn "You should take the time to edit the default server INI."
+ ewarn "Consult the INI Reference at http://unrealadmin.org/"
+ ewarn "for assistance in adjusting the following file:"
+ ewarn "${dir}/System/Default.ini"
+ ewarn
+ ewarn "To have your server authenticate properly to the"
+ ewarn "central server, you MUST visit the following site"
+ ewarn "and request a key. This is not required if you"
+ ewarn "want an unfindable private server. [DoUplink=False]"
+ ewarn
+ ewarn "http://unreal.epicgames.com/ut2004server/cdkey.php"
+}