summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2012-05-31 16:34:39 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2012-05-31 16:34:39 +0000
commit0e0248e5d3a17712e22a0e33f37bd6342cd65d0d (patch)
treee09c6f9bdca0e469a7a0a7fe7354bcf548290eee /games-simulation/openttd
parentKeyword ~mips (diff)
downloadgentoo-2-0e0248e5d3a17712e22a0e33f37bd6342cd65d0d.tar.gz
gentoo-2-0e0248e5d3a17712e22a0e33f37bd6342cd65d0d.tar.bz2
gentoo-2-0e0248e5d3a17712e22a0e33f37bd6342cd65d0d.zip
clean old; tidy
(Portage version: 2.1.10.49/cvs/Linux x86_64)
Diffstat (limited to 'games-simulation/openttd')
-rw-r--r--games-simulation/openttd/ChangeLog7
-rw-r--r--games-simulation/openttd/files/openttd-1.2.0-cflags.patch (renamed from games-simulation/openttd/files/openttd-1.1.3-cflags.patch)4
-rw-r--r--games-simulation/openttd/openttd-1.1.3.ebuild165
-rw-r--r--games-simulation/openttd/openttd-1.2.0.ebuild4
4 files changed, 10 insertions, 170 deletions
diff --git a/games-simulation/openttd/ChangeLog b/games-simulation/openttd/ChangeLog
index 4f8eb9ddeb2a..8096cd82ec2e 100644
--- a/games-simulation/openttd/ChangeLog
+++ b/games-simulation/openttd/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for games-simulation/openttd
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-simulation/openttd/ChangeLog,v 1.124 2012/05/06 19:29:52 halcy0n Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-simulation/openttd/ChangeLog,v 1.125 2012/05/31 16:34:39 mr_bones_ Exp $
+
+ 31 May 2012; Michael Sterrett <mr_bones_@gentoo.org>
+ +files/openttd-1.2.0-cflags.patch, -files/openttd-1.1.3-cflags.patch,
+ -openttd-1.1.3.ebuild, openttd-1.2.0.ebuild:
+ clean old; tidy
06 May 2012; Mark Loeser <halcy0n@gentoo.org> openttd-1.1.3.ebuild:
Drop to ~ppc; bug #398161
diff --git a/games-simulation/openttd/files/openttd-1.1.3-cflags.patch b/games-simulation/openttd/files/openttd-1.2.0-cflags.patch
index 60a9056a6634..f79915ecf600 100644
--- a/games-simulation/openttd/files/openttd-1.1.3-cflags.patch
+++ b/games-simulation/openttd/files/openttd-1.2.0-cflags.patch
@@ -1,5 +1,5 @@
---- config.lib.orig 2011-08-08 11:40:21.641085825 -0400
-+++ config.lib 2011-08-08 11:44:19.655285851 -0400
+--- config.lib.orig
++++ config.lib
@@ -1357,14 +1357,12 @@
CFLAGS="-I/gg/os-include -noixemul -fstrict-aliasing -fexpensive-optimizations -mcpu=604 -fno-inline -mstring -mmultiple $CFLAGS"
LDFLAGS="$LDFLAGS -noixemul"
diff --git a/games-simulation/openttd/openttd-1.1.3.ebuild b/games-simulation/openttd/openttd-1.1.3.ebuild
deleted file mode 100644
index e16ac77ef5a0..000000000000
--- a/games-simulation/openttd/openttd-1.1.3.ebuild
+++ /dev/null
@@ -1,165 +0,0 @@
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-simulation/openttd/openttd-1.1.3.ebuild,v 1.5 2012/05/06 19:29:52 halcy0n Exp $
-
-EAPI=2
-inherit eutils games
-
-DESCRIPTION="OpenTTD is a clone of Transport Tycoon Deluxe"
-HOMEPAGE="http://www.openttd.org/"
-SRC_URI="http://binaries.openttd.org/releases/${PV}/${P}-source.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="amd64 ~arm ~ppc ~ppc64 x86"
-IUSE="aplaymidi debug dedicated iconv icu lzo +openmedia +png +timidity +truetype zlib"
-
-DEPEND="
- !dedicated? (
- media-libs/libsdl[audio,X,video]
- icu? ( dev-libs/icu )
- truetype? (
- media-libs/fontconfig
- media-libs/freetype:2
- sys-libs/zlib
- )
- )
- lzo? ( dev-libs/lzo:2 )
- iconv? ( virtual/libiconv )
- png? ( media-libs/libpng )
- zlib? ( sys-libs/zlib )"
-PDEPEND="
- !dedicated? (
- openmedia? (
- games-misc/openmsx
- games-misc/opensfx
- )
- aplaymidi? ( media-sound/alsa-utils )
- !aplaymidi? ( timidity? ( media-sound/timidity++ ) )
- )
- openmedia? ( games-misc/opengfx )
- "
-PATCHES=( "${FILESDIR}"/${P}-cflags.patch )
-
-src_configure() {
- # there is an allegro interface available as well as sdl, but
- # the configure for it looks broken so the sdl interface is
- # always built instead.
- local myopts="${myopts} --without-allegro"
-
- # libtimidity not needed except for some embedded platform
- # nevertheless, it will be automagically linked if it is
- # installed. Hence, we disable it.
- myopts="${myopts} --without-libtimidity"
-
- use debug && myopts="${myopts} --enable-debug=3"
-
- if use dedicated ; then
- myopts="${myopts} --enable-dedicated"
- else
- use aplaymidi && myopts="${myopts} --with-midi='/usr/bin/aplaymidi'"
- myopts="${myopts}
- $(use_with truetype freetype)
- $(use_with icu)
- --with-sdl"
- fi
- if use png || { use !dedicated && use truetype; } || use zlib ; then
- myopts="${myopts} --with-zlib"
- else
- myopts="${myopts} --without-zlib"
- fi
-
- # configure is a hand-written bash-script, so econf will not work.
- # It's all built as C++, upstream uses CFLAGS internally.
- CFLAGS="" ./configure \
- --disable-strip \
- --prefix-dir="${EPREFIX}" \
- --binary-dir="${GAMES_BINDIR}" \
- --data-dir="${GAMES_DATADIR}/${PN}" \
- --install-dir="${D}" \
- --icon-dir=/usr/share/pixmaps \
- --menu-dir=/usr/share/applications \
- --icon-theme-dir=/usr/share/icons/hicolor \
- --man-dir=/usr/share/man/man6 \
- --doc-dir=/usr/share/doc/${PF} \
- --menu-group="Game;Simulation;" \
- ${myopts} \
- $(use_with iconv) \
- $(use_with png) \
- $(use_with lzo liblzo2) \
- || die "configure failed"
-}
-
-src_compile() {
- emake VERBOSE=1 || die
-}
-
-src_test() {
- vecho ">>> Test phase [test]: ${CATEGORY}/${PF}"
- emake -j1 test || die "Make test failed. See above for details."
-}
-
-src_install() {
- emake DESTDIR="${D}" install || die "emake install failed"
- if use dedicated ; then
- newinitd "${FILESDIR}"/${PN}.initd ${PN}
- rm -rf "${D}"/usr/share/{applications,icons,pixmaps}
- fi
- rm -f "${D}"/usr/share/doc/${PF}/COPYING
- prepalldocs
- prepgamesdirs
-}
-
-pkg_postinst() {
- games_pkg_postinst
-
- if ! use lzo ; then
- elog "OpenTTD was built without 'lzo' in USE. While 'lzo' is not"
- elog "required, disabling it does mean that loading old savegames"
- elog "or scenarios from ancient versions (~0.2) will fail."
- elog
- fi
-
- if use dedicated ; then
- ewarn "Warning: The init script will kill all running openttd"
- ewarn "processes when triggered, including any running client sessions!"
- else
- if use aplaymidi ; then
- elog "You have emerged with 'aplaymidi' for playing MIDI."
- elog "This option is for those with a hardware midi device,"
- elog "or who have set up ALSA to handle midi ports."
- elog "You must set the environment variable ALSA_OUTPUT_PORTS."
- elog "Available ports can be listed by using 'aplaymidi -l'."
- else
- if ! use timidity ; then
- elog "OpenTTD was built with neither 'aplaymidi' nor 'timidity'"
- elog "in USE. Music may or may not work in-game. If you happen"
- elog "to have timidity++ installed, music will work so long"
- elog "as it remains installed, but OpenTTD will not depend on it."
- fi
- fi
- if ! use openmedia ; then
- elog
- elog "OpenTTD was compiled without the 'openmedia' USE flag."
- elog
- elog "In order to play, you must at least install:"
- elog "games-misc/opengfx, and games-misc/opensfx, or copy the "
- elog "following 6 files from a version of Transport Tycoon Deluxe"
- elog "(windows or DOS) to ~/.openttd/data/ or"
- elog "${GAMES_DATADIR}/${PN}/data/."
- elog
- elog "From the WINDOWS version you need: "
- elog "sample.cat trg1r.grf trgcr.grf trghr.grf trgir.grf trgtr.grf"
- elog "OR from the DOS version you need: "
- elog "SAMPLE.CAT TRG1.GRF TRGC.GRF TRGH.GRF TRGI.GRF TRGT.GRF"
- elog
- elog "File names are case sensitive, but should work either with"
- elog "all upper or all lower case names"
- elog
- elog "In addition, in-game music will be unavailable: for music,"
- elog "install games-misc/openmsx, or use the in-game download"
- elog "functionality to get a music set"
- elog
- fi
- fi
-}
diff --git a/games-simulation/openttd/openttd-1.2.0.ebuild b/games-simulation/openttd/openttd-1.2.0.ebuild
index 24032d45652d..4f5373294f95 100644
--- a/games-simulation/openttd/openttd-1.2.0.ebuild
+++ b/games-simulation/openttd/openttd-1.2.0.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-simulation/openttd/openttd-1.2.0.ebuild,v 1.6 2012/04/19 11:53:53 ago Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-simulation/openttd/openttd-1.2.0.ebuild,v 1.7 2012/05/31 16:34:39 mr_bones_ Exp $
EAPI=3
inherit eutils games
@@ -38,7 +38,7 @@ PDEPEND="
)
openmedia? ( >=games-misc/opengfx-0.4.4 )"
-PATCHES=( "${FILESDIR}"/${PN}-1.1.3-cflags.patch )
+PATCHES=( "${FILESDIR}"/${P}-cflags.patch )
src_configure() {
# there is an allegro interface available as well as sdl, but