summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Holm <dholm@gentoo.org>2005-05-23 07:15:02 +0000
committerDavid Holm <dholm@gentoo.org>2005-05-23 07:15:02 +0000
commit03270407e6789605b0bd86f67401bb077651d6af (patch)
tree679f7782a6ee7d09b5ae6a40c26f87575c264767 /games-simulation
parentOpenGL compile fix (diff)
downloadgentoo-2-03270407e6789605b0bd86f67401bb077651d6af.tar.gz
gentoo-2-03270407e6789605b0bd86f67401bb077651d6af.tar.bz2
gentoo-2-03270407e6789605b0bd86f67401bb077651d6af.zip
Version bumped
(Portage version: 2.0.51.22-r1)
Diffstat (limited to 'games-simulation')
-rw-r--r--games-simulation/openttd/ChangeLog8
-rw-r--r--games-simulation/openttd/Manifest4
-rw-r--r--games-simulation/openttd/files/digest-openttd-0.4.0.11
-rw-r--r--games-simulation/openttd/openttd-0.4.0.1.ebuild131
4 files changed, 142 insertions, 2 deletions
diff --git a/games-simulation/openttd/ChangeLog b/games-simulation/openttd/ChangeLog
index 49a915b5e945..0da23f795e66 100644
--- a/games-simulation/openttd/ChangeLog
+++ b/games-simulation/openttd/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for games-simulation/openttd
# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-simulation/openttd/ChangeLog,v 1.13 2005/05/16 15:09:34 dholm Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-simulation/openttd/ChangeLog,v 1.14 2005/05/23 07:15:02 dholm Exp $
+
+*openttd-0.4.0.1 (23 May 2005)
+
+ 23 May 2005; David Holm <dholm@gentoo.org> +openttd-0.4.0.1.ebuild:
+ Version bumped, and added fixes for dedicated mode submitted by Luca Spiller
+ <thelucster (at) gmail (dot) com> (Bug #93486)
*openttd-0.4.0 (16 May 2005)
diff --git a/games-simulation/openttd/Manifest b/games-simulation/openttd/Manifest
index 62c178301f0a..86df993989f7 100644
--- a/games-simulation/openttd/Manifest
+++ b/games-simulation/openttd/Manifest
@@ -1,7 +1,9 @@
MD5 7efefbbe81a05cbc5d4e96203f047fda metadata.xml 245
-MD5 42a02542c8510607711648f8a06c6cbf ChangeLog 2362
+MD5 b972b923c5365ae3911ca2392f3f9c3b ChangeLog 2593
MD5 b4920ba6225a18cedcb6887038f11a7d openttd-0.3.6-r1.ebuild 4180
+MD5 9c717096cec0f476fbc109ded022acb0 openttd-0.4.0.1.ebuild 4113
MD5 0545a9ceee2db438f49045bfdb8098ce openttd-0.4.0.ebuild 4229
MD5 a169eb5c8572ee01be52c4accf2608a2 files/openttd.initd 529
MD5 706c1f4a051e6472683d79b75f3def11 files/digest-openttd-0.3.6-r1 73
MD5 ebb13a7591c4ec12f1bb5e25fb8aff18 files/digest-openttd-0.4.0 70
+MD5 58b6f8b5a58925f558524fcb4c2711fc files/digest-openttd-0.4.0.1 75
diff --git a/games-simulation/openttd/files/digest-openttd-0.4.0.1 b/games-simulation/openttd/files/digest-openttd-0.4.0.1
new file mode 100644
index 000000000000..1272ae79fcdd
--- /dev/null
+++ b/games-simulation/openttd/files/digest-openttd-0.4.0.1
@@ -0,0 +1 @@
+MD5 ddd9790c86b7ccc68f60761704cbcf81 openttd-0.4.0.1-source.tar.gz 2950778
diff --git a/games-simulation/openttd/openttd-0.4.0.1.ebuild b/games-simulation/openttd/openttd-0.4.0.1.ebuild
new file mode 100644
index 000000000000..3e6255d5e679
--- /dev/null
+++ b/games-simulation/openttd/openttd-0.4.0.1.ebuild
@@ -0,0 +1,131 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-simulation/openttd/openttd-0.4.0.1.ebuild,v 1.1 2005/05/23 07:15:02 dholm Exp $
+
+inherit eutils games
+
+DESCRIPTION="OpenTTD is a clone of Transport Tycoon Deluxe"
+HOMEPAGE="http://www.openttd.com/"
+SRC_URI="mirror://sourceforge/openttd/${P}-source.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~ppc ~amd64"
+IUSE="debug png zlib timidity alsa dedicated"
+
+DEPEND="media-libs/libsdl
+ png? ( media-libs/libpng )
+ zlib? ( sys-libs/zlib )"
+RDEPEND="${DEPEND}
+ !dedicated? (
+ timidity? ( media-sound/timidity++ )
+ !timidity? ( alsa? ( media-sound/alsa-utils ) )
+ )"
+
+src_compile() {
+ local myopts="MANUAL_CONFIG=1 UNIX=1 WITH_NETWORK=1 INSTALL=1 RELEASE=${PV} USE_HOMEDIR=1 PERSONAL_DIR=.openttd PREFIX=/usr DATA_DIR=share/games/${PN}"
+ use debug && myopts="${myopts} DEBUG=1"
+ use dedicated && myopts="${myopts} DEDICATED=1"
+ use png && myopts="${myopts} WITH_PNG=1"
+ use zlib && myopts="${myopts} WITH_ZLIB=1"
+ if ! use dedicated; then
+ myopts="${myopts} WITH_SDL=1"
+ if ! use timidity; then
+ use alsa && myopts="${myopts} MIDI=/usr/bin/aplaymidi"
+ fi
+ fi
+
+ emake -j1 ${myopts} || die "emake failed"
+}
+
+src_install() {
+ dogamesbin openttd || die "dogamesbin failed"
+
+ insinto "${GAMES_DATADIR}/${PN}/data"
+ doins data/* || die "doins failed (data)"
+
+ insinto "${GAMES_DATADIR}/${PN}/lang"
+ doins lang/*.lng || die "doins failed (lang)"
+
+ insinto "${GAMES_DATADIR}/${PN}/scenario"
+ doins scenario/* || die "doins failed (scenario)"
+
+ insinto "${GAMES_DATADIR}/${PN}/scripts"
+ doins scripts/*.example || die "doins failed (scripts)"
+
+ doicon media/openttd.*.png
+
+ if ! use dedicated; then
+ if use timidity || use alsa; then
+ make_desktop_entry "openttd -m extmidi" "OpenTTD" openttd.64.png
+ else
+ make_desktop_entry openttd "OpenTTD" openttd.64.png
+ fi
+ else
+ exeinto /etc/init.d
+ newexe ${FILESDIR}/openttd.initd openttd
+ fi
+
+ dodoc readme.txt changelog.txt docs/Manual.txt docs/console.txt \
+ docs/multiplayer.txt
+ newdoc scripts/readme.txt readme_scripts.txt
+ doman docs/openttd.6
+ prepgamesdirs
+}
+
+pkg_postinst() {
+ games_pkg_postinst
+
+ echo
+ einfo "In order to play, you must copy the following 6 files from "
+ einfo "a version of TTD to ${GAMES_DATADIR}/${PN}/data/."
+ echo
+ einfo "From the WINDOWS version you need: "
+ einfo " sample.cat trg1r.grf trgcr.grf trghr.grf trgir.grf trgtr.grf"
+ einfo "OR from the DOS version you need: "
+ einfo " SAMPLE.CAT TRG1.GRF TRGC.GRF TRGH.GRF TRGI.GRF TRGT.GRF"
+ echo
+ einfo "Scenarios are installed to ${GAMES_DATADIR}/${PN}/scenario,"
+ einfo "you will have to symlink them to ~/.openttd/scenario in order"
+ einfo "to use them."
+ einfo "Example:"
+ einfo " mkdir -p ~/.openttd/scenario"
+ einfo " ln -s ${GAMES_DATADIR}/${PN}/scenario/* ~/.openttd/scenario/"
+ echo
+ einfo "File names are case sensitive so make sure they are "
+ einfo "correct for whichever version you have."
+ echo
+
+ if use dedicated; then
+ einfo "You have chosen the dedicated USE flag which builds a "
+ einfo "version of OpenTTD to be used as a game server which "
+ einfo "does not require SDL. You will not be able to play the "
+ einfo "game, but if you don't pass this flag you can still use "
+ einfo "it as a server in the same way, but SDL will be required."
+ echo
+ ewarn "Warning: The init script will kill all running openttd"
+ ewarn "processes when run, including any running client sessions!"
+ echo
+ else
+ if use timidity || use alsa; then
+ einfo "If you want music, you must copy the gm/ directory"
+ einfo "to ${GAMES_DATADIR}/${PN}/"
+ einfo "You can enable MIDI by running:"
+ einfo " openttd -m extmidi"
+ echo
+ if use timidity; then
+ einfo "You also need soundfonts for timidity, if you don't"
+ einfo "know what that is, do:"
+ echo
+ einfo "emerge media-sound/timidity-eawpatches"
+ else
+ einfo "You have emerged with 'aplaymidi' for playing MIDI."
+ einfo "You have to set the environment variable ALSA_OUTPUT_PORTS."
+ einfo "Available ports can be listed by using 'aplaymidi -l'."
+ fi
+ else
+ einfo "timidity and/or alsa not in USE so music will not be played during the game."
+ fi
+ echo
+ fi
+}