summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2009-11-04 06:29:39 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2009-11-04 06:29:39 +0000
commit77d7e2ab54d3a8238cfb29753ffffdb217133dc9 (patch)
tree37fb101516d1035fdb1e2eccf4d3a8d68863acca /games-simulation
parentVersion bump. Updated all patches, added icon and fix for tcl-8.5 (bug #267558) (diff)
downloadgentoo-2-77d7e2ab54d3a8238cfb29753ffffdb217133dc9.tar.gz
gentoo-2-77d7e2ab54d3a8238cfb29753ffffdb217133dc9.tar.bz2
gentoo-2-77d7e2ab54d3a8238cfb29753ffffdb217133dc9.zip
EAPI=2
(Portage version: 2.1.6.13/cvs/Linux i686)
Diffstat (limited to 'games-simulation')
-rw-r--r--games-simulation/cannonsmash/ChangeLog8
-rw-r--r--games-simulation/cannonsmash/cannonsmash-0.6.6.ebuild25
2 files changed, 21 insertions, 12 deletions
diff --git a/games-simulation/cannonsmash/ChangeLog b/games-simulation/cannonsmash/ChangeLog
index ce550b639601..3d625293693b 100644
--- a/games-simulation/cannonsmash/ChangeLog
+++ b/games-simulation/cannonsmash/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for games-simulation/cannonsmash
-# Copyright 2002-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-simulation/cannonsmash/ChangeLog,v 1.18 2008/04/08 01:38:29 mr_bones_ Exp $
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/games-simulation/cannonsmash/ChangeLog,v 1.19 2009/11/04 06:29:39 mr_bones_ Exp $
+
+ 04 Nov 2009; Michael Sterrett <mr_bones_@gentoo.org>
+ cannonsmash-0.6.6.ebuild:
+ EAPI=2
08 Apr 2008; Michael Sterrett <mr_bones_@gentoo.org>
cannonsmash-0.6.6.ebuild:
diff --git a/games-simulation/cannonsmash/cannonsmash-0.6.6.ebuild b/games-simulation/cannonsmash/cannonsmash-0.6.6.ebuild
index f6beb931c241..5aae608b2495 100644
--- a/games-simulation/cannonsmash/cannonsmash-0.6.6.ebuild
+++ b/games-simulation/cannonsmash/cannonsmash-0.6.6.ebuild
@@ -1,7 +1,8 @@
-# Copyright 1999-2008 Gentoo Foundation
+# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-simulation/cannonsmash/cannonsmash-0.6.6.ebuild,v 1.14 2008/04/08 01:38:29 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-simulation/cannonsmash/cannonsmash-0.6.6.ebuild,v 1.15 2009/11/04 06:29:39 mr_bones_ Exp $
+EAPI=2
inherit eutils games
MY_OGG=danslatristesse2-48.ogg
@@ -17,10 +18,10 @@ IUSE="vorbis nls"
RDEPEND="virtual/opengl
virtual/glu
- media-libs/libsdl
- media-libs/sdl-mixer
- media-libs/sdl-image
- =x11-libs/gtk+-2*
+ media-libs/libsdl[audio,video]
+ media-libs/sdl-mixer[vorbis?]
+ media-libs/sdl-image[jpeg,png]
+ x11-libs/gtk+:2
nls? ( virtual/libintl )"
DEPEND="${RDEPEND}
dev-util/pkgconfig
@@ -30,7 +31,9 @@ S=${WORKDIR}/csmash-${PV}
src_unpack() {
unpack csmash-${PV}.tar.gz
- cd "${S}"
+}
+
+src_prepare() {
epatch \
"${FILESDIR}"/${P}-x-inc.patch \
"${FILESDIR}"/${P}-sizeof-cast.patch \
@@ -42,11 +45,13 @@ src_unpack() {
fi
}
-src_compile() {
+src_configure() {
egamesconf \
$(use_enable nls) \
- --datadir="${GAMES_DATADIR_BASE}" \
- || die
+ --datadir="${GAMES_DATADIR_BASE}"
+}
+
+src_compile() {
emake \
localedir="/usr/share" \
|| die "emake failed"