summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlfredo Tupone <tupone@gentoo.org>2009-09-04 08:24:33 +0000
committerAlfredo Tupone <tupone@gentoo.org>2009-09-04 08:24:33 +0000
commit79e980608eef3ccd1b72e2c2e67935f8be627b2e (patch)
treeeed1a3cd8f37f09da1ee723557c0f3b103b184ed /games-simulation
parentFix building with GLIBC 2.10+ wrt #273274, thanks to Petr Behan. (diff)
downloadgentoo-2-79e980608eef3ccd1b72e2c2e67935f8be627b2e.tar.gz
gentoo-2-79e980608eef3ccd1b72e2c2e67935f8be627b2e.tar.bz2
gentoo-2-79e980608eef3ccd1b72e2c2e67935f8be627b2e.zip
Enable parallel compilation
(Portage version: 2.1.6.13/cvs/Linux i686)
Diffstat (limited to 'games-simulation')
-rw-r--r--games-simulation/searchandrescue/ChangeLog7
-rw-r--r--games-simulation/searchandrescue/files/searchandrescue-0.8.2-makejs.patch9
-rw-r--r--games-simulation/searchandrescue/searchandrescue-0.8.2-r1.ebuild9
3 files changed, 18 insertions, 7 deletions
diff --git a/games-simulation/searchandrescue/ChangeLog b/games-simulation/searchandrescue/ChangeLog
index 73446d0b5649..6d3442ba1cf4 100644
--- a/games-simulation/searchandrescue/ChangeLog
+++ b/games-simulation/searchandrescue/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for games-simulation/searchandrescue
# Copyright 2000-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-simulation/searchandrescue/ChangeLog,v 1.17 2009/09/04 07:25:00 tupone Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-simulation/searchandrescue/ChangeLog,v 1.18 2009/09/04 08:24:32 tupone Exp $
+
+ 04 Sep 2009; Tupone Alfredo <tupone@gentoo.org>
+ +files/searchandrescue-0.8.2-makejs.patch,
+ searchandrescue-0.8.2-r1.ebuild:
+ Enable parallel compilation
04 Sep 2009; Tupone Alfredo <tupone@gentoo.org>
+files/searchandrescue-0.8.2-gcc441.patch,
diff --git a/games-simulation/searchandrescue/files/searchandrescue-0.8.2-makejs.patch b/games-simulation/searchandrescue/files/searchandrescue-0.8.2-makejs.patch
new file mode 100644
index 000000000000..650aa0bedb99
--- /dev/null
+++ b/games-simulation/searchandrescue/files/searchandrescue-0.8.2-makejs.patch
@@ -0,0 +1,9 @@
+--- Makefile.old 2009-09-04 10:13:22.000000000 +0200
++++ Makefile 2009-09-04 10:16:43.000000000 +0200
+@@ -1,5 +1,5 @@
+ ALL_SRC_DIRS=sar
+ all install clean:
+ @for subdir in $(ALL_SRC_DIRS); do \
+- make -s -C $$subdir -f Makefile $@; \
++ $(MAKE) -s -C $$subdir -f Makefile $@; \
+ done
diff --git a/games-simulation/searchandrescue/searchandrescue-0.8.2-r1.ebuild b/games-simulation/searchandrescue/searchandrescue-0.8.2-r1.ebuild
index 71ebecb8dfe2..945cc0b51ca4 100644
--- a/games-simulation/searchandrescue/searchandrescue-0.8.2-r1.ebuild
+++ b/games-simulation/searchandrescue/searchandrescue-0.8.2-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-simulation/searchandrescue/searchandrescue-0.8.2-r1.ebuild,v 1.5 2009/09/04 07:25:00 tupone Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-simulation/searchandrescue/searchandrescue-0.8.2-r1.ebuild,v 1.6 2009/09/04 08:24:32 tupone Exp $
EAPI=2
inherit eutils games
@@ -40,7 +40,8 @@ src_prepare() {
epatch "${FILESDIR}"/${P}-gcc33.patch \
"${FILESDIR}"/${P}-gcc41.patch \
"${FILESDIR}"/${P}-gcc412.patch \
- "${FILESDIR}"/${P}-gcc441.patch
+ "${FILESDIR}"/${P}-gcc441.patch \
+ "${FILESDIR}"/${P}-makejs.patch
bunzip2 sar/man/${MY_PN}.6.bz2
sed -i \
-e '/FeatureCFLAGS.*march/s:=.*:=:g' sar/platforms.ini \
@@ -65,10 +66,6 @@ src_configure() {
|| die
}
-src_compile() {
- emake -j1 || die "emake failed"
-}
-
src_install() {
dogamesbin sar/${MY_PN} || die "dogamesbin failed"
doman sar/man/${MY_PN}.6