summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2015-01-01 01:49:51 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2015-01-01 01:49:51 +0000
commita86a3810ce005785262a50d687b8c78f90fbfcb9 (patch)
tree738893049064e7cc110a0d4467b8294a2cd874dd /games-simulation
parentbump; drop pypy support due to failing testsuites, set border to version of s... (diff)
downloadgentoo-2-a86a3810ce005785262a50d687b8c78f90fbfcb9.tar.gz
gentoo-2-a86a3810ce005785262a50d687b8c78f90fbfcb9.tar.bz2
gentoo-2-a86a3810ce005785262a50d687b8c78f90fbfcb9.zip
convert to python-single-r1; EAPI=5
(Portage version: 2.2.14/cvs/Linux x86_64, unsigned Manifest commit)
Diffstat (limited to 'games-simulation')
-rw-r--r--games-simulation/qct/ChangeLog10
-rw-r--r--games-simulation/qct/qct-0.7-r1.ebuild49
2 files changed, 56 insertions, 3 deletions
diff --git a/games-simulation/qct/ChangeLog b/games-simulation/qct/ChangeLog
index f890da60d08a..7159db4406f1 100644
--- a/games-simulation/qct/ChangeLog
+++ b/games-simulation/qct/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for games-simulation/qct
-# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-simulation/qct/ChangeLog,v 1.8 2010/04/08 08:48:11 tupone Exp $
+# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/games-simulation/qct/ChangeLog,v 1.9 2015/01/01 01:49:51 mr_bones_ Exp $
+
+*qct-0.7-r1 (01 Jan 2015)
+
+ 01 Jan 2015; Michael Sterrett <mr_bones_@gentoo.org> +qct-0.7-r1.ebuild:
+ convert to python-single-r1; EAPI=5
08 Apr 2010; Tupone Alfredo <tupone@gentoo.org> qct-0.7.ebuild:
Force use of python2 . Bug #312281 by arfrever@gentoo.org
@@ -26,4 +31,3 @@
01 Apr 2004; Michael Sterrett <mr_bones_@gentoo.org> metadata.xml,
qct-0.7.ebuild:
initial commit; ebuild submitted by Alexandru Toma via bug #46472
-
diff --git a/games-simulation/qct/qct-0.7-r1.ebuild b/games-simulation/qct/qct-0.7-r1.ebuild
new file mode 100644
index 000000000000..ed36fc4c937b
--- /dev/null
+++ b/games-simulation/qct/qct-0.7-r1.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-simulation/qct/qct-0.7-r1.ebuild,v 1.1 2015/01/01 01:49:51 mr_bones_ Exp $
+
+EAPI=5
+PYTHON_COMPAT=( python2_7 )
+inherit eutils python-single-r1 games
+
+DESCRIPTION="Quiet Console Town puts you in the place of the mayor of a budding new console RPG city"
+HOMEPAGE="http://packages.gentoo.org/package/games-simulation/qct"
+SRC_URI="http://www.sourcefiles.org/Games/Role_Play/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+
+DEPEND=">=dev-python/pygame-1.5.5[${PYTHON_USEDEP}]"
+RDEPEND=${RDEPEND}
+REQUIRED_USE=${PYTHON_REQUIRED_USE}
+
+S=${WORKDIR}/${PN}
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-constant.patch
+ python_fix_shebang .
+}
+
+src_install() {
+ # Ug. Someone fix this to install in $(games_get_libdir)/${PN} instead
+ local destdir="${GAMES_DATADIR}/${PN}"
+ insinto "${destdir}"
+ exeinto "${destdir}"
+
+ dodoc README
+ doins *.py *.png
+ doexe qct.py
+
+ python_optimize "${D}${GAMES_DATADIR}/${PN}"
+
+ games_make_wrapper qct "./qct.py" "${destdir}"
+
+ prepgamesdirs
+}
+
+pkg_setup() {
+ python-single-r1_pkg_setup
+ games_pkg_setup
+}