summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2012-06-12 18:15:12 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2012-06-12 18:15:12 +0000
commit299094b5d83987cca736090ab090c352caf362a2 (patch)
tree33a3f4a41f65e02991c90dc8758d0ddbb9b7bb8d /games-sports
parentFix zheet use flag description in metadata (diff)
downloadgentoo-2-299094b5d83987cca736090ab090c352caf362a2.tar.gz
gentoo-2-299094b5d83987cca736090ab090c352caf362a2.tar.bz2
gentoo-2-299094b5d83987cca736090ab090c352caf362a2.zip
Add patch to build with gcc47 submitted by Philipp Middendorf via bug #420799
(Portage version: 2.1.10.49/cvs/Linux x86_64)
Diffstat (limited to 'games-sports')
-rw-r--r--games-sports/xmoto/ChangeLog6
-rw-r--r--games-sports/xmoto/files/xmoto-0.5.9-gcc47.patch10
-rw-r--r--games-sports/xmoto/xmoto-0.5.9.ebuild5
3 files changed, 18 insertions, 3 deletions
diff --git a/games-sports/xmoto/ChangeLog b/games-sports/xmoto/ChangeLog
index 1744f717c7a4..86f8cedc4360 100644
--- a/games-sports/xmoto/ChangeLog
+++ b/games-sports/xmoto/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for games-sports/xmoto
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-sports/xmoto/ChangeLog,v 1.63 2012/05/17 06:20:02 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-sports/xmoto/ChangeLog,v 1.64 2012/06/12 18:15:12 mr_bones_ Exp $
+
+ 12 Jun 2012; Michael Sterrett <mr_bones_@gentoo.org> xmoto-0.5.9.ebuild,
+ +files/xmoto-0.5.9-gcc47.patch:
+ Add patch to build with gcc47 submitted by Philipp Middendorf via bug #420799
17 May 2012; Michael Sterrett <mr_bones_@gentoo.org>
-files/0.5.7-libpng.patch, -xmoto-0.5.4.ebuild, -xmoto-0.5.7.ebuild,
diff --git a/games-sports/xmoto/files/xmoto-0.5.9-gcc47.patch b/games-sports/xmoto/files/xmoto-0.5.9-gcc47.patch
new file mode 100644
index 000000000000..eb0843ef35ba
--- /dev/null
+++ b/games-sports/xmoto/files/xmoto-0.5.9-gcc47.patch
@@ -0,0 +1,10 @@
+--- src/helpers/System.cpp.old 2012-06-12 11:01:24.332083600 +0200
++++ src/helpers/System.cpp 2012-06-12 11:01:35.335083715 +0200
+@@ -24,6 +24,7 @@
+ #include "Log.h"
+ #include "VExcept.h"
+ #include <sstream>
++#include <unistd.h>
+
+ std::vector<std::string>* System::getDisplayModes(int windowed) {
+ std::vector<std::string>* modes = new std::vector<std::string>;
diff --git a/games-sports/xmoto/xmoto-0.5.9.ebuild b/games-sports/xmoto/xmoto-0.5.9.ebuild
index 2403eb324f29..9cd22101d7ba 100644
--- a/games-sports/xmoto/xmoto-0.5.9.ebuild
+++ b/games-sports/xmoto/xmoto-0.5.9.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-sports/xmoto/xmoto-0.5.9.ebuild,v 1.4 2012/04/22 14:42:39 maekke Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-sports/xmoto/xmoto-0.5.9.ebuild,v 1.5 2012/06/12 18:15:12 mr_bones_ Exp $
EAPI=2
inherit eutils flag-o-matic games
@@ -48,7 +48,8 @@ src_prepare() {
epatch \
"${FILESDIR}"/${P}-libpng.patch \
- "${FILESDIR}"/${P}-utf8.patch
+ "${FILESDIR}"/${P}-utf8.patch \
+ "${FILESDIR}"/${P}-gcc47.patch
}
src_configure() {