summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2011-02-21 20:28:58 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2011-02-21 20:28:58 +0000
commit3f94628991676d11a5e4b6289b12b374e8f1a470 (patch)
tree1c2691727a10e66446608d9daa69fab00c4dab0b /games-sports
parentapp-office/grisbi: Bump to 0.8.0, clean up ebuild (diff)
downloadgentoo-2-3f94628991676d11a5e4b6289b12b374e8f1a470.tar.gz
gentoo-2-3f94628991676d11a5e4b6289b12b374e8f1a470.tar.bz2
gentoo-2-3f94628991676d11a5e4b6289b12b374e8f1a470.zip
work around issues with some drivers related to GL_CLAMP (bug #355821) - patch submitted by Alan Swanson
(Portage version: 2.1.9.25/cvs/Linux i686)
Diffstat (limited to 'games-sports')
-rw-r--r--games-sports/foobillard/ChangeLog9
-rw-r--r--games-sports/foobillard/files/foobillard-3.0a-gl-clamp.patch14
-rw-r--r--games-sports/foobillard/foobillard-3.0a.ebuild7
3 files changed, 25 insertions, 5 deletions
diff --git a/games-sports/foobillard/ChangeLog b/games-sports/foobillard/ChangeLog
index 984d37d0cd30..3126c1e38b10 100644
--- a/games-sports/foobillard/ChangeLog
+++ b/games-sports/foobillard/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for games-sports/foobillard
-# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-sports/foobillard/ChangeLog,v 1.17 2010/09/16 17:02:08 scarabeus Exp $
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/games-sports/foobillard/ChangeLog,v 1.18 2011/02/21 20:28:58 mr_bones_ Exp $
+
+ 21 Feb 2011; Michael Sterrett <mr_bones_@gentoo.org>
+ foobillard-3.0a.ebuild, +files/foobillard-3.0a-gl-clamp.patch:
+ work around issues with some drivers related to GL_CLAMP (bug #355821)
+ - patch submitted by Alan Swanson
16 Sep 2010; Tomáš Chvátal <scarabeus@gentoo.org>
foobillard-3.0a.ebuild:
diff --git a/games-sports/foobillard/files/foobillard-3.0a-gl-clamp.patch b/games-sports/foobillard/files/foobillard-3.0a-gl-clamp.patch
new file mode 100644
index 000000000000..972d14cabb0a
--- /dev/null
+++ b/games-sports/foobillard/files/foobillard-3.0a-gl-clamp.patch
@@ -0,0 +1,14 @@
+diff -ur foobillard-3.0a/src/table.c foobillard-3.0a-glclamp/src/table.c
+--- foobillard-3.0a/src/table.c 2004-01-11 21:53:02.000000000 +0000
++++ foobillard-3.0a-glclamp/src/table.c 2011-02-21 09:14:36.000000000 +0000
+@@ -1214,8 +1214,8 @@
+ GL_UNSIGNED_BYTE, tabletexdata);
+ glTexParameteri(GL_TEXTURE_2D, GL_TEXTURE_MIN_FILTER, options_tex_min_filter);
+ glTexParameteri(GL_TEXTURE_2D, GL_TEXTURE_MAG_FILTER, options_tex_mag_filter);
+- glTexParameteri(GL_TEXTURE_2D, GL_TEXTURE_WRAP_S, GL_CLAMP);
+- glTexParameteri(GL_TEXTURE_2D, GL_TEXTURE_WRAP_T, GL_CLAMP);
++ glTexParameteri(GL_TEXTURE_2D, GL_TEXTURE_WRAP_S, GL_CLAMP_TO_EDGE);
++ glTexParameteri(GL_TEXTURE_2D, GL_TEXTURE_WRAP_T, GL_CLAMP_TO_EDGE);
+ free( tabletexdata );
+ } else {
+ tabletexbind=0;
diff --git a/games-sports/foobillard/foobillard-3.0a.ebuild b/games-sports/foobillard/foobillard-3.0a.ebuild
index bf57835b473c..0e32b0d39947 100644
--- a/games-sports/foobillard/foobillard-3.0a.ebuild
+++ b/games-sports/foobillard/foobillard-3.0a.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2010 Gentoo Foundation
+# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-sports/foobillard/foobillard-3.0a.ebuild,v 1.14 2010/09/16 17:02:08 scarabeus Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-sports/foobillard/foobillard-3.0a.ebuild,v 1.15 2011/02/21 20:28:58 mr_bones_ Exp $
EAPI=2
inherit eutils autotools games
@@ -29,7 +29,8 @@ src_prepare() {
epatch \
"${FILESDIR}"/${P}-no_nvidia.patch \
"${FILESDIR}"/${P}-fbsd.patch \
- "${FILESDIR}"/${P}-as-needed.patch
+ "${FILESDIR}"/${P}-as-needed.patch \
+ "${FILESDIR}"/${P}-gl-clamp.patch
eautoreconf
}