summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2010-04-29 15:45:29 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2010-04-29 15:45:29 +0000
commitcfea4053dfd0ec4e98e0dcac315350b7f2e05e4c (patch)
treef02b5b15c66a6696e0a4892a5fc120b4afec940b /games-sports
parentamd64 stable wrt #306359 (diff)
downloadgentoo-2-cfea4053dfd0ec4e98e0dcac315350b7f2e05e4c.tar.gz
gentoo-2-cfea4053dfd0ec4e98e0dcac315350b7f2e05e4c.tar.bz2
gentoo-2-cfea4053dfd0ec4e98e0dcac315350b7f2e05e4c.zip
improve use flag deps; add gcc45 patch from Kacper Kowalik (Xarthisius) via bug #317751
(Portage version: 2.1.8.3/cvs/Linux i686)
Diffstat (limited to 'games-sports')
-rw-r--r--games-sports/toycars/ChangeLog7
-rw-r--r--games-sports/toycars/files/toycars-0.3.10-gcc45.patch37
-rw-r--r--games-sports/toycars/toycars-0.3.10.ebuild10
3 files changed, 49 insertions, 5 deletions
diff --git a/games-sports/toycars/ChangeLog b/games-sports/toycars/ChangeLog
index 09fa8920dc27..bae7d28a118c 100644
--- a/games-sports/toycars/ChangeLog
+++ b/games-sports/toycars/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for games-sports/toycars
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-sports/toycars/ChangeLog,v 1.16 2010/03/31 19:56:12 tupone Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-sports/toycars/ChangeLog,v 1.17 2010/04/29 15:45:29 mr_bones_ Exp $
+
+ 29 Apr 2010; Michael Sterrett <mr_bones_@gentoo.org>
+ toycars-0.3.10.ebuild, +files/toycars-0.3.10-gcc45.patch:
+ improve use flag deps; add gcc45 patch from Kacper Kowalik (Xarthisius)
+ via bug #317751
31 Mar 2010; Tupone Alfredo <tupone@gentoo.org> toycars-0.3.10.ebuild:
Rename corner.map to fix bug #311811 by Robert Cernansky
diff --git a/games-sports/toycars/files/toycars-0.3.10-gcc45.patch b/games-sports/toycars/files/toycars-0.3.10-gcc45.patch
new file mode 100644
index 000000000000..0e4f350a89dd
--- /dev/null
+++ b/games-sports/toycars/files/toycars-0.3.10-gcc45.patch
@@ -0,0 +1,37 @@
+Fixing compilation with gcc-4.5
+
+http://bugs.gentoo.org/show_bug.cgi?id=317751
+
+Patch written by Kacper Kowalik <xarthisius.kk@gmail.com>
+
+--- toycars_vehicle_editor/src/VehicleEditorUI.cxx
++++ toycars_vehicle_editor/src/VehicleEditorUI.cxx
+@@ -228,7 +228,7 @@
+ sprintf(str, "%d", n);
+ convexChoice->add(str);
+ convexChoice->value(n);
+-vehicleObj.getGeometry()->push_back(std::list<Vec2D>::list());
++vehicleObj.getGeometry()->push_back(std::list<Vec2D>());
+ spriteView->setConvexChoice(n);
+ spriteView->redraw();
+ }
+--- toycars_vehicle_editor/src/VehicleObject.cpp
++++ toycars_vehicle_editor/src/VehicleObject.cpp
+@@ -152,7 +152,7 @@
+ short count;
+ geometry.clear();
+ for (xConvex = xGeometry->FirstChild(); xConvex != NULL; xConvex = xConvex->NextSibling("convex")) {
+- geometry.push_back(std::list<Vec2D>::list());
++ geometry.push_back(std::list<Vec2D>());
+ std::list<Vec2D> &convex = geometry.back();
+ readPointsFromString(xConvex->FirstChild()->ToText()->Value(), convex, count);
+ }
+@@ -411,7 +411,7 @@
+ short count;
+ geometry.clear();
+ for (xConvex = xGeometry->FirstChild(); xConvex != NULL; xConvex = xConvex->NextSibling("convex")) {
+- geometry.push_back(std::list<Vec2D>::list());
++ geometry.push_back(std::list<Vec2D>());
+ std::list<Vec2D> &convex = geometry.back();
+ readPointsFromString(xConvex->FirstChild()->ToText()->Value(), convex, count);
+ }
diff --git a/games-sports/toycars/toycars-0.3.10.ebuild b/games-sports/toycars/toycars-0.3.10.ebuild
index 5c2393cb3dfc..709199216afa 100644
--- a/games-sports/toycars/toycars-0.3.10.ebuild
+++ b/games-sports/toycars/toycars-0.3.10.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-sports/toycars/toycars-0.3.10.ebuild,v 1.5 2010/03/31 19:56:12 tupone Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-sports/toycars/toycars-0.3.10.ebuild,v 1.6 2010/04/29 15:45:29 mr_bones_ Exp $
EAPI=2
inherit eutils flag-o-matic games
@@ -14,15 +14,17 @@ SLOT="0"
KEYWORDS="amd64 x86"
IUSE=""
-DEPEND="media-libs/libsdl[video]
+DEPEND="media-libs/libsdl[audio,video,joystick]
media-libs/sdl-image[png]
- >=x11-libs/fltk-1.1.9:1.1
+ >=x11-libs/fltk-1.1.9:1.1[opengl]
>=media-libs/fmod-4.25.07-r1:1
virtual/glu
virtual/opengl"
src_prepare() {
- epatch "${FILESDIR}"/${P}-glibc-2.10.patch
+ epatch \
+ "${FILESDIR}"/${P}-glibc-2.10.patch \
+ "${FILESDIR}"/${P}-gcc45.patch
mv data/tracks/Corner/{c,C}orner.map
}