summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChris Gianelloni <wolf31o2@gentoo.org>2005-06-17 17:53:29 +0000
committerChris Gianelloni <wolf31o2@gentoo.org>2005-06-17 17:53:29 +0000
commitec86f6f81c3cd3f8b2effc86cfd82284d92454fa (patch)
treebf4d0d5a07bea11331726995149ecbc1819a3aac /games-strategy/mindrover-demo/mindrover-demo-1.07b.ebuild
parentFix missing ${D} (diff)
downloadgentoo-2-ec86f6f81c3cd3f8b2effc86cfd82284d92454fa.tar.gz
gentoo-2-ec86f6f81c3cd3f8b2effc86cfd82284d92454fa.tar.bz2
gentoo-2-ec86f6f81c3cd3f8b2effc86cfd82284d92454fa.zip
Initial import. Ebuild by me. Closing bug #70915.
(Portage version: 2.0.51.22-r1)
Diffstat (limited to 'games-strategy/mindrover-demo/mindrover-demo-1.07b.ebuild')
-rw-r--r--games-strategy/mindrover-demo/mindrover-demo-1.07b.ebuild49
1 files changed, 49 insertions, 0 deletions
diff --git a/games-strategy/mindrover-demo/mindrover-demo-1.07b.ebuild b/games-strategy/mindrover-demo/mindrover-demo-1.07b.ebuild
new file mode 100644
index 000000000000..0ccf96361c01
--- /dev/null
+++ b/games-strategy/mindrover-demo/mindrover-demo-1.07b.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-strategy/mindrover-demo/mindrover-demo-1.07b.ebuild,v 1.1 2005/06/17 17:53:29 wolf31o2 Exp $
+
+inherit eutils games
+
+MY_P="mindrover_demo.run"
+DESCRIPTION="Control a robot as it races across Europa"
+HOMEPAGE="http://www.linuxgamepublishing.com/info.php?id=9"
+SRC_URI=" http://demos.linuxgamepublishing.com/mindrover/${MY_P}"
+
+LICENSE="as-is"
+SLOT="0"
+KEYWORDS="x86"
+RESTRICT="nostrip"
+
+IUSE=""
+
+DEPEND="virtual/libc"
+RDEPEND="virtual/opengl"
+
+S=${WORKDIR}
+dir=${GAMES_PREFIX_OPT}/${PN}
+Ddir=${D}/${dir}
+
+src_unpack() {
+ unpack_makeself ${DISTDIR}/${MY_P} || die "unpacking game"
+}
+
+src_install() {
+ einfo "This will take a while ... go get a pizza or something"
+
+ dodir ${dir}
+
+ tar -zxf data.tar.gz -C ${Ddir}/ || die "armyops untar failed"
+ tar -zxf music.tar.gz -C ${Ddir}/ || die "binaries untar failed"
+
+ dodoc README
+ newicon icon.xpm ${PN}.xpm || die "doins failed"
+ exeinto ${dir}
+ doexe bin/Linux/x86/glibc-2.1/mindrover_demo \
+ bin/Linux/x86/glibc-2.1/lib/libopenal.so.0.0.6 || die "doexe failed"
+ dosym ${dir}/libopenal.so.0.0.6 ${dir}/libopenal.so.0
+
+ games_make_wrapper ${PN} ./mindrover_demo ${dir}
+
+ prepgamesdirs
+ make_desktop_entry ${PN} "Mindrover: Europa Project (Demo)" ${PN}.xpm
+}