summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChris Gianelloni <wolf31o2@gentoo.org>2006-08-06 21:47:20 +0000
committerChris Gianelloni <wolf31o2@gentoo.org>2006-08-06 21:47:20 +0000
commit84aa2f35b2d03baabdb73e16636fe25fc109b416 (patch)
treee8c33653dd3ece748e047f9df76e3a8a3f5ec186 /games-strategy/scorched3d
parentStable on SPARC wrt bug #136695. (diff)
downloadgentoo-2-84aa2f35b2d03baabdb73e16636fe25fc109b416.tar.gz
gentoo-2-84aa2f35b2d03baabdb73e16636fe25fc109b416.tar.bz2
gentoo-2-84aa2f35b2d03baabdb73e16636fe25fc109b416.zip
Version bump. Ebuild by Tristan Heaven <tristanheaven@gmail.com> as well as patches. Closing bug #140643.
(Portage version: 2.1.1_pre4-r1)
Diffstat (limited to 'games-strategy/scorched3d')
-rw-r--r--games-strategy/scorched3d/ChangeLog10
-rw-r--r--games-strategy/scorched3d/files/digest-scorched3d-403
-rw-r--r--games-strategy/scorched3d/files/scorched3d-40-freealut.patch79
-rw-r--r--games-strategy/scorched3d/files/scorched3d-40-unicode.patch39
-rw-r--r--games-strategy/scorched3d/scorched3d-40.ebuild59
5 files changed, 189 insertions, 1 deletions
diff --git a/games-strategy/scorched3d/ChangeLog b/games-strategy/scorched3d/ChangeLog
index e129509cb0d6..810ba005850a 100644
--- a/games-strategy/scorched3d/ChangeLog
+++ b/games-strategy/scorched3d/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for games-strategy/scorched3d
# Copyright 2000-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-strategy/scorched3d/ChangeLog,v 1.30 2006/05/12 18:40:23 wolf31o2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-strategy/scorched3d/ChangeLog,v 1.31 2006/08/06 21:47:20 wolf31o2 Exp $
+
+*scorched3d-40 (06 Aug 2006)
+
+ 06 Aug 2006; Chris Gianelloni <wolf31o2@gentoo.org>
+ +files/scorched3d-40-freealut.patch, +files/scorched3d-40-unicode.patch,
+ +scorched3d-40.ebuild:
+ Version bump. Ebuild by Tristan Heaven <tristanheaven@gmail.com> as well as
+ patches. Closing bug #140643.
*scorched3d-39.1-r1 (12 May 2006)
diff --git a/games-strategy/scorched3d/files/digest-scorched3d-40 b/games-strategy/scorched3d/files/digest-scorched3d-40
new file mode 100644
index 000000000000..d39cf837f2eb
--- /dev/null
+++ b/games-strategy/scorched3d/files/digest-scorched3d-40
@@ -0,0 +1,3 @@
+MD5 76b60b9f73d2c971d86bfac761989cf4 Scorched3D-40-src.tar.gz 55427740
+RMD160 2e900986a8a9262d3ffb85d1f6e6bfd4b4d9b9a6 Scorched3D-40-src.tar.gz 55427740
+SHA256 8722d1f06e50f25f8e373f4388668a8b056e978dba8b86f197a45c3fa1f9008b Scorched3D-40-src.tar.gz 55427740
diff --git a/games-strategy/scorched3d/files/scorched3d-40-freealut.patch b/games-strategy/scorched3d/files/scorched3d-40-freealut.patch
new file mode 100644
index 000000000000..8fe0706cac81
--- /dev/null
+++ b/games-strategy/scorched3d/files/scorched3d-40-freealut.patch
@@ -0,0 +1,79 @@
+--- configure
++++ configure
+@@ -3946,7 +3946,7 @@
+ if test x"$use_static_openal" = x"yes"; then
+ LIBS="$LIBS /usr/local/lib/libopenal.a"
+ else
+- LIBS="$LIBS `$OPENAL_CONFIG --libs`"
++ LIBS="$LIBS `$OPENAL_CONFIG --libs` -lalut"
+ fi
+
+ CFLAGS="$CFLAGS `$OPENAL_CONFIG --cflags`"
+
+--- src/sound/SoundBufferStaticWav.cpp
++++ src/sound/SoundBufferStaticWav.cpp
+@@ -57,44 +57,7 @@
+ SoundBuffer(fileName),
+ buffer_(0)
+ {
+- unsigned int error;
+-
+- // Create a buffer
+- alGetError();
+- alGenBuffers(1, &buffer_);
+- if ((error = alGetError()) != AL_NO_ERROR)
+- {
+- return;
+- }
+-
+- // Load WAV
+- void *data;
+- ALenum format;
+- ALsizei size;
+- ALsizei freq;
+- ALboolean loop;
+-
+-#ifdef __DARWIN__
+- alutLoadWAVFile((ALbyte*) fileName,&format,&data,&size,&freq);
+-#else
+- alutLoadWAVFile((ALbyte*) fileName,&format,&data,&size,&freq,&loop);
+-#endif
+-
+- if ((error = alGetError()) != AL_NO_ERROR)
+- {
+- return;
+- }
+-
+- // Load WAV into buffer
+- alBufferData(buffer_,format,data,size,freq);
+- if ((error = alGetError()) != AL_NO_ERROR)
+- {
+- return;
+- }
+-
+- // Delete WAV memory
+- alutUnloadWAV(format,data,size,freq);
+- if ((error = alGetError()) != AL_NO_ERROR)
++ if ((buffer_ = alutCreateBufferFromFile(fileName)) == AL_NONE)
+ {
+ return;
+ }
+
+--- src/sound/Sound.cpp
++++ src/sound/Sound.cpp
+@@ -28,6 +28,7 @@
+ #include <sound/PlayingSoundSource.h>
+ #include <AL/al.h>
+ #include <AL/alc.h>
++#include <AL/alut.h>
+ #include <algorithm>
+
+ Sound *Sound::instance_ = 0;
+@@ -150,6 +151,7 @@
+ totalSources_.push_back(source);
+ availableSources_.push_back(source);
+ }
++ alutInitWithoutContext(NULL, NULL);
+
+ init_ = true;
+ return init_;
diff --git a/games-strategy/scorched3d/files/scorched3d-40-unicode.patch b/games-strategy/scorched3d/files/scorched3d-40-unicode.patch
new file mode 100644
index 000000000000..0e71268fcfa5
--- /dev/null
+++ b/games-strategy/scorched3d/files/scorched3d-40-unicode.patch
@@ -0,0 +1,39 @@
+diff -urN scorched.orig/configure scorched/configure
+--- scorched.orig/configure 2006-07-15 11:15:30.000000000 -0400
++++ scorched/configure 2006-08-02 17:05:08.000000000 -0400
+@@ -5159,7 +5159,7 @@
+ # Check for extra functions
+
+
+-for ac_func in vsnprintf snprintf
++for ac_func in vsnprintf snprintf vasprintf asprintf
+ do
+ as_ac_var=`echo "ac_cv_func_$ac_func" | $as_tr_sh`
+ echo "$as_me:$LINENO: checking for $ac_func" >&5
+diff -urN scorched.orig/src/scorched/NetLan.cpp scorched/src/scorched/NetLan.cpp
+--- scorched.orig/src/scorched/NetLan.cpp 2006-07-05 13:16:14.000000000 -0400
++++ scorched/src/scorched/NetLan.cpp 2006-08-02 17:05:08.000000000 -0400
+@@ -96,9 +96,9 @@
+ // Radio Buttons
+ wxFlexGridSizer *radioSizer = new wxFlexGridSizer(1, 8, 5, 5);
+ IDC_RADIO_NET_CTRL = new wxRadioButton(parent, IDC_RADIO_NET,
+- "Internet", wxDefaultPosition, wxDefaultSize, wxRB_GROUP);
++ wxT("Internet"), wxDefaultPosition, wxDefaultSize, wxRB_GROUP);
+ IDC_RADIO_LAN_CTRL = new wxRadioButton(parent, IDC_RADIO_LAN,
+- "LAN", wxDefaultPosition, wxDefaultSize, 0);
++ wxT("LAN"), wxDefaultPosition, wxDefaultSize, 0);
+ radioSizer->Add(IDC_RADIO_NET_CTRL, 0, wxRIGHT, 10);
+ radioSizer->Add(IDC_RADIO_LAN_CTRL, 0, wxRIGHT, 0);
+ sizer->Add(radioSizer, 0, wxALIGN_CENTER | wxALL, 5);
+diff -urN scorched.orig/src/scorched/OptionEntrySetter.cpp scorched/src/scorched/OptionEntrySetter.cpp
+--- scorched.orig/src/scorched/OptionEntrySetter.cpp 2006-07-11 10:35:32.000000000 -0400
++++ scorched/src/scorched/OptionEntrySetter.cpp 2006-08-02 17:05:08.000000000 -0400
+@@ -122,7 +122,7 @@
+ {
+ sizer->Add(control =
+ new wxCheckBox(parent, -1,
+- "",
++ wxT(""),
+ wxDefaultPosition, wxDefaultSize),
+ 0, wxALIGN_LEFT);
+ control->SetToolTip(
diff --git a/games-strategy/scorched3d/scorched3d-40.ebuild b/games-strategy/scorched3d/scorched3d-40.ebuild
new file mode 100644
index 000000000000..34df79a02020
--- /dev/null
+++ b/games-strategy/scorched3d/scorched3d-40.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-strategy/scorched3d/scorched3d-40.ebuild,v 1.1 2006/08/06 21:47:20 wolf31o2 Exp $
+
+inherit wxwidgets games
+
+DESCRIPTION="Multi-player tank battle in 3D (OpenGL)"
+HOMEPAGE="http://www.scorched3d.co.uk/"
+SRC_URI="mirror://sourceforge/${PN}/Scorched3D-${PV}-src.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="mysql"
+
+DEPEND="virtual/opengl
+ virtual/glu
+ media-libs/libogg
+ media-libs/libvorbis
+ ~media-libs/openal-0.0.8
+ media-libs/freealut
+ media-libs/libsdl
+ media-libs/sdl-net
+ >=x11-libs/wxGTK-2.6
+ >=media-libs/freetype-2
+ mysql? ( dev-db/mysql )"
+RDEPEND="${DEPEND}"
+
+S=${WORKDIR}/scorched
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/${P}-freealut.patch
+ epatch "${FILESDIR}"/${P}-unicode.patch
+}
+
+pkg_setup() {
+ games_pkg_setup
+ WX_GTK_VER="2.6" \
+ need-wxwidgets gtk2 || die "You need to emerge wxGTK with USE='X'"
+}
+
+src_compile() {
+ egamesconf \
+ --disable-dependency-tracking \
+ --exec_prefix="${GAMES_PREFIX}" \
+ --datadir="${GAMES_DATADIR}/${PN}" \
+ --with-docdir="/usr/share/doc/${PF}" \
+ --with-wx-config="${WX_CONFIG}" \
+ $(use_with mysql) \
+ || die "egamesconf failed"
+ emake || die "emake failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+ prepgamesdirs
+}