summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2013-01-31 20:04:47 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2013-01-31 20:04:47 +0000
commit6ee4061a5968e9bf709626d1dd57b7b8d359a61b (patch)
tree1674ac187e91efedca347723b6e19f77248134bf /games-strategy/smac
parentAllow build of multiple plugins in different directories. Make variables more... (diff)
downloadgentoo-2-6ee4061a5968e9bf709626d1dd57b7b8d359a61b.tar.gz
gentoo-2-6ee4061a5968e9bf709626d1dd57b7b8d359a61b.tar.bz2
gentoo-2-6ee4061a5968e9bf709626d1dd57b7b8d359a61b.zip
add log message about CONFIG_UID16 (bug #340303); tidy
(Portage version: 2.1.11.31/cvs/Linux x86_64, unsigned Manifest commit)
Diffstat (limited to 'games-strategy/smac')
-rw-r--r--games-strategy/smac/ChangeLog8
-rw-r--r--games-strategy/smac/smac-6.0a.ebuild23
2 files changed, 17 insertions, 14 deletions
diff --git a/games-strategy/smac/ChangeLog b/games-strategy/smac/ChangeLog
index 8e4bd0a6aab2..278152837d98 100644
--- a/games-strategy/smac/ChangeLog
+++ b/games-strategy/smac/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for games-strategy/smac
-# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-strategy/smac/ChangeLog,v 1.18 2012/02/05 06:25:05 vapier Exp $
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/games-strategy/smac/ChangeLog,v 1.19 2013/01/31 20:04:47 mr_bones_ Exp $
+
+ 31 Jan 2013; Michael Sterrett <mr_bones_@gentoo.org> smac-6.0a.ebuild:
+ add log message about CONFIG_UID16 (bug #340303); tidy
05 Feb 2012; Mike Frysinger <vapier@gentoo.org> smac-6.0a.ebuild:
Move to new unpacker eclass for unpack_makeself.
@@ -60,4 +63,3 @@
+smac-6.0a.ebuild:
Initial import. Ebuild by <anakin.skyw@gmx.de> and submitted to bug #98687.
Closing bug #98687 and bug #31395.
-
diff --git a/games-strategy/smac/smac-6.0a.ebuild b/games-strategy/smac/smac-6.0a.ebuild
index fd296448d7b9..d145c5cf2bb6 100644
--- a/games-strategy/smac/smac-6.0a.ebuild
+++ b/games-strategy/smac/smac-6.0a.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2012 Gentoo Foundation
+# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-strategy/smac/smac-6.0a.ebuild,v 1.22 2012/02/05 06:25:05 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-strategy/smac/smac-6.0a.ebuild,v 1.23 2013/01/31 20:04:47 mr_bones_ Exp $
EAPI=2
inherit eutils unpacker cdrom games
@@ -24,7 +24,7 @@ RDEPEND="sys-libs/glibc
x11-libs/libXau
x11-libs/libXdmcp
!ppc? ( sys-libs/lib-compat-loki )
- media-libs/libsdl
+ media-libs/libsdl[audio,video]
media-libs/sdl-ttf
media-libs/sdl-mixer
media-libs/smpeg
@@ -45,20 +45,19 @@ src_unpack() {
src_install() {
einfo "Copying files... this may take a while..."
exeinto "${dir}"
- doexe "${CDROM_ROOT}"/bin/x86/{smac,smacx,smacpack} || die "doexe failed"
+ doexe "${CDROM_ROOT}"/bin/x86/{smac,smacx,smacpack} || die
insinto "${dir}"
doins ${CDROM_ROOT}/{{Alien_Crossfire,Alpha_Centauri}_Manual.pdf,QuickStart.txt,README,icon.{bmp,xpm}}
cd "${Ddir}"
- tar xzf "${CDROM_ROOT}"/data.tar.gz || die "unpack"
+ tar xzf "${CDROM_ROOT}"/data.tar.gz || die
insinto "${dir}"/data
- doins "${CDROM_ROOT}"/data/*.{pcx,cvr,flc,gif} || die "copying data"
- doins -r "${CDROM_ROOT}"/data/{facs,fx,projs,techs,voices} \
- || die "doins failed"
+ doins "${CDROM_ROOT}"/data/*.{pcx,cvr,flc,gif} || die
+ doins -r "${CDROM_ROOT}"/data/{facs,fx,projs,techs,voices} || die
if use videos ; then
- doins -r "${CDROM_ROOT}"/data/movies || die "copying movies"
+ doins -r "${CDROM_ROOT}"/data/movies || die
fi
cd "${S}"/a
@@ -66,7 +65,7 @@ src_install() {
cd ${P}-ppc
fi
loki_patch --verify patch.dat
- loki_patch patch.dat "${Ddir}" >& /dev/null || die "patching"
+ loki_patch patch.dat "${Ddir}" >& /dev/null || die
# now, since these files are coming off a cd, the times/sizes/md5sums wont
# be different ... that means portage will try to unmerge some files (!)
@@ -87,7 +86,7 @@ src_install() {
einfo "Linking libs provided by 'sys-libs/lib-compat-loki' to '${dir}'."
dosym /lib/loki_ld-linux.so.2 "${dir}"/ld-linux.so.2 && \
dosym /usr/lib/loki_libc.so.6 "${dir}"/libc.so.6 && \
- dosym /usr/lib/loki_libnss_files.so.2 "${dir}"/libnss_files.so.2 || die "dosym failed"
+ dosym /usr/lib/loki_libnss_files.so.2 "${dir}"/libnss_files.so.2 || die
fi
}
@@ -99,4 +98,6 @@ pkg_postinst() {
elog " smac"
elog "To play Alien Crossfire run:"
elog " smacx"
+ elog "Be sure to enable CONFIG_UID16 in your kernel config or"
+ elog "the game will error." # bug 340303
}